summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-11 17:24:54 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-11 17:24:54 +0000
commit77f05c62ee62ab631e67f94e1ba5bb98e8f1b8a9 (patch)
treea15760b036aaf1a440af65602ecd46065271271a /app-sci/snns
parentversion bump/KEYWORD unmask (diff)
downloadgentoo-2-77f05c62ee62ab631e67f94e1ba5bb98e8f1b8a9.tar.gz
gentoo-2-77f05c62ee62ab631e67f94e1ba5bb98e8f1b8a9.tar.bz2
gentoo-2-77f05c62ee62ab631e67f94e1ba5bb98e8f1b8a9.zip
more tweaks
Diffstat (limited to 'app-sci/snns')
-rw-r--r--app-sci/snns/ChangeLog7
-rw-r--r--app-sci/snns/files/digest-snns-4.2-r22
-rw-r--r--app-sci/snns/snns-4.2-r2.ebuild65
3 files changed, 73 insertions, 1 deletions
diff --git a/app-sci/snns/ChangeLog b/app-sci/snns/ChangeLog
index 4d7b3e9cd3c0..149f25fc2410 100644
--- a/app-sci/snns/ChangeLog
+++ b/app-sci/snns/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-sci/snns
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/snns/ChangeLog,v 1.2 2002/11/08 23:43:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/snns/ChangeLog,v 1.3 2002/11/11 17:24:54 vapier Exp $
+
+*snns-4.2-r2 (11 Nov 2002)
+
+ 11 Nov 2002; Mike Frysinger <vapier@gentoo.org> :
+ Tweaked ebuild a little bit more per #10390
*snns-4.2-r1 (08 Nov 2002)
diff --git a/app-sci/snns/files/digest-snns-4.2-r2 b/app-sci/snns/files/digest-snns-4.2-r2
new file mode 100644
index 000000000000..5777b9a356d0
--- /dev/null
+++ b/app-sci/snns/files/digest-snns-4.2-r2
@@ -0,0 +1,2 @@
+MD5 4609dfd61714bfbb0842d4e8e905e584 SNNSv4.2.tar.gz 2170375
+MD5 e91242fdc43877013ade3b5f2213659a SNNSv4.2.Manual.pdf 2103861
diff --git a/app-sci/snns/snns-4.2-r2.ebuild b/app-sci/snns/snns-4.2-r2.ebuild
new file mode 100644
index 000000000000..a04753efdedd
--- /dev/null
+++ b/app-sci/snns/snns-4.2-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/snns/snns-4.2-r2.ebuild,v 1.1 2002/11/11 17:24:54 vapier Exp $
+
+MY_P="SNNSv${PV}"
+DESCRIPTION="Stuttgart Neural Network Simulator"
+HOMEPAGE="http://www-ra.informatik.uni-tuebingen.de/SNNS/"
+SRC_URI="http://www-ra.informatik.uni-tuebingen.de/downloads/SNNS/${MY_P}.tar.gz
+ doc? ( http://www-ra.informatik.uni-tuebingen.de/downloads/SNNS/${MY_P}.Manual.pdf )"
+
+LICENSE="SNNS-${PV}"
+KEYWORDS="x86"
+SLOT="0"
+IUSE="X doc"
+
+DEPEND="X? ( virtual/x11 )
+ virtual/glibc"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-gentoo.patch || die "patch failed"
+}
+
+src_compile() {
+ local myconf="--enable-global"
+ local compileopts="compile-kernel compile-tools"
+
+ if [ `use X` ] ; then
+ myconf="${myconf} --with-x"
+ compileopts="${compileopts} compile-xgui"
+ else
+ myconf="${myconf} --without-x"
+ fi
+
+ econf ${myconf}
+ emake ${compileopts} || die "emake failed"
+}
+
+src_install() {
+ for file in `find tools -type f -perm +100`; do
+ dobin $file
+ done
+
+ if [ `use X` ] ; then
+ newbin xgui/sources/xgui snns
+
+ dodir /etc/env.d
+ echo XGUILOADPATH=/usr/share/doc/${PF}/ > ${D}/etc/env.d/99snns
+
+ insinto /usr/share/doc/${PF}
+ doins default.cfg help.hdoc
+ fi
+
+ insinto /usr/share/doc/${PF}
+ use doc && doins ${DISTDIR}/${MY_P}.Manual.pdf
+
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+
+ doman man/man*/*
+}