summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-06-25 22:46:07 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-06-25 22:46:07 +0000
commitccc043cecad32bc75ce26da41ab08df05acb5ed8 (patch)
tree86cc2ae0f5e17f98c5f59c7e3e9ed6f3cb696cd9 /app-sci/xcircuit
parentstable on amd64 (Manifest recommit) (diff)
downloadgentoo-2-ccc043cecad32bc75ce26da41ab08df05acb5ed8.tar.gz
gentoo-2-ccc043cecad32bc75ce26da41ab08df05acb5ed8.tar.bz2
gentoo-2-ccc043cecad32bc75ce26da41ab08df05acb5ed8.zip
Version bump.
Diffstat (limited to 'app-sci/xcircuit')
-rw-r--r--app-sci/xcircuit/ChangeLog7
-rw-r--r--app-sci/xcircuit/files/digest-xcircuit-3.2.221
-rw-r--r--app-sci/xcircuit/xcircuit-3.2.22.ebuild47
3 files changed, 54 insertions, 1 deletions
diff --git a/app-sci/xcircuit/ChangeLog b/app-sci/xcircuit/ChangeLog
index 29b11ee8903c..240510049883 100644
--- a/app-sci/xcircuit/ChangeLog
+++ b/app-sci/xcircuit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-sci/xcircuit
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/xcircuit/ChangeLog,v 1.17 2004/06/24 22:21:25 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/xcircuit/ChangeLog,v 1.18 2004/06/25 22:46:07 plasmaroo Exp $
+
+*xcircuit-3.2.22 (25 Jun 2004)
+
+ 25 Jun 2004; <plasmaroo@gentoo.org> +xcircuit-3.2.22.ebuild:
+ Version bump.
02 Jun 2004; Aron Griffis <agriffis@gentoo.org> xcircuit-3.1.31.ebuild:
Fix use invocation
diff --git a/app-sci/xcircuit/files/digest-xcircuit-3.2.22 b/app-sci/xcircuit/files/digest-xcircuit-3.2.22
new file mode 100644
index 000000000000..53fc95774569
--- /dev/null
+++ b/app-sci/xcircuit/files/digest-xcircuit-3.2.22
@@ -0,0 +1 @@
+MD5 370da21b56f7bef9ae137b8e10ff2323 xcircuit-3.2.22.tgz 1293668
diff --git a/app-sci/xcircuit/xcircuit-3.2.22.ebuild b/app-sci/xcircuit/xcircuit-3.2.22.ebuild
new file mode 100644
index 000000000000..7a65ed0770b7
--- /dev/null
+++ b/app-sci/xcircuit/xcircuit-3.2.22.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/xcircuit/xcircuit-3.2.22.ebuild,v 1.1 2004/06/25 22:46:07 plasmaroo Exp $
+
+DESCRIPTION="Circuit drawing and schematic capture program."
+SRC_URI="http://xcircuit.ece.jhu.edu/archive/${P}.tgz"
+HOMEPAGE="http://xcircuit.ece.jhu.edu"
+
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="tcltk"
+
+DEPEND="virtual/x11
+ virtual/ghostscript
+ tcltk? ( dev-lang/tk )"
+
+src_compile() {
+
+ sed -e '693s:LDFLAGS="":LDFLAGS="-L/usr/X11R6/lib":;694i LIBS="${LIBS} ${LIB_SPECS}"' -i configure.in
+ aclocal && autoconf || die "Could not recreate configuration files!"
+
+ if use tcltk; then
+ econf --with-tcl --with-tk || die "econf failed"
+ else
+ econf || die "econf failed"
+ fi
+
+ if use tcltk; then
+ sed -e '67s/extern //' -i events.c
+ sed -e 's/extern Tcl_Interp/Tcl_Interp/' -i tclxcircuit.c
+ sed -e '2982d; 3069d;' -i xcircuit.c
+ make tcl || die
+ fi
+ make || die
+
+}
+
+src_install () {
+
+ emake DESTDIR=${D} install || die "Installation failed"
+ if use tcltk; then
+ emake DESTDIR=${D} install-tcl || die "Installation failed"
+ fi
+ dodoc COPYRIGHT README*
+
+}