summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-02-15 12:40:50 +0000
committerMichael Imhof <tantive@gentoo.org>2003-02-15 12:40:50 +0000
commit0b020dbcbb90650ac305e2e95b54a31bb0307731 (patch)
tree0eb53ef410a2a33d29435723f90848015c2a4a60 /app-sci
parentfixed missing digest (diff)
downloadgentoo-2-0b020dbcbb90650ac305e2e95b54a31bb0307731.tar.gz
gentoo-2-0b020dbcbb90650ac305e2e95b54a31bb0307731.tar.bz2
gentoo-2-0b020dbcbb90650ac305e2e95b54a31bb0307731.zip
Changed ~sparc and ~alpha to -sparc and -alpha; Added a patch to pick up prox information from http_proxy
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/zetagrid/ChangeLog8
-rw-r--r--app-sci/zetagrid/files/digest-zetagrid-1.0-r42
-rw-r--r--app-sci/zetagrid/files/zeta.sh11
-rw-r--r--app-sci/zetagrid/zetagrid-1.0-r4.ebuild49
4 files changed, 68 insertions, 2 deletions
diff --git a/app-sci/zetagrid/ChangeLog b/app-sci/zetagrid/ChangeLog
index db3e5cdaa8d8..ac09abf0bb97 100644
--- a/app-sci/zetagrid/ChangeLog
+++ b/app-sci/zetagrid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-sci/zetagrid
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/zetagrid/ChangeLog,v 1.6 2003/02/14 17:41:40 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/zetagrid/ChangeLog,v 1.7 2003/02/15 12:40:50 tantive Exp $
+
+*zetagrid-1.0-r4 (15 Feb 2003)
+
+ 15 Feb 2003; Michael Imhof <tantive@gentoo.org> :
+ Changed ~sparc and ~alpha to -sparc and -alpha
+ Added a patch for zeta.sh to pick up proxy information from http_proxy.
*zetagrid-1.0-r3 (14 Feb 2003)
diff --git a/app-sci/zetagrid/files/digest-zetagrid-1.0-r4 b/app-sci/zetagrid/files/digest-zetagrid-1.0-r4
new file mode 100644
index 000000000000..539b55863550
--- /dev/null
+++ b/app-sci/zetagrid/files/digest-zetagrid-1.0-r4
@@ -0,0 +1,2 @@
+MD5 c1ceb75711dd9dd01647211bce742647 zeta_cmd.zip 46148
+MD5 fce1921170a936c7b234ec071953eea5 zeta_progress.zip 5874
diff --git a/app-sci/zetagrid/files/zeta.sh b/app-sci/zetagrid/files/zeta.sh
index 35f076531954..bfd6750a2d65 100644
--- a/app-sci/zetagrid/files/zeta.sh
+++ b/app-sci/zetagrid/files/zeta.sh
@@ -19,4 +19,13 @@
#
# ======================================================================
-nohup nice -19 java -Xmx128m -Djava.library.path=. -Dsun.net.inetaddr.ttl=0 -Dnetworkaddress.cache.ttl=0 -Dnetworkaddress.cache.negative.ttl=0 -cp zeta.jar:zeta_client.jar zeta.ZetaClient &
+if [ -n "$http_proxy" ]; then
+ http_proxy="${http_proxy#http://}"
+ http_proxy="${http_proxy%/}"
+ proxies="-Dhttp.proxyHost=${http_proxy%:*} \
+ -Dhttp.proxyPort=${http_proxy#*:}"
+else
+ proxies=""
+fi
+
+nohup nice -19 java -Xmx128m $proxies -Djava.library.path=. -Dsun.net.inetaddr.ttl=0 -Dnetworkaddress.cache.ttl=0 -Dnetworkaddress.cache.negative.ttl=0 -cp zeta.jar:zeta_client.jar zeta.ZetaClient &
diff --git a/app-sci/zetagrid/zetagrid-1.0-r4.ebuild b/app-sci/zetagrid/zetagrid-1.0-r4.ebuild
new file mode 100644
index 000000000000..62b1598a13ec
--- /dev/null
+++ b/app-sci/zetagrid/zetagrid-1.0-r4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/zetagrid/zetagrid-1.0-r4.ebuild,v 1.1 2003/02/15 12:40:50 tantive Exp $
+
+S=${WORKDIR}/zetagrid-${PV}
+DESCRIPTION="An open source and platform independent grid system"
+SRC_URI="http://www.zetagrid.net/zeta/zeta_cmd.zip http://www.zetagrid.net/zeta/add-ons/zeta_progress.zip"
+HOMEPAGE="http://www.zetagrid.net http://cvs.gentoo.org/~tantive"
+IUSE=""
+
+DEPEND="virtual/glibc
+ app-arch/unzip"
+RDEPEND="virtual/jre
+ >=sys-libs/lib-compat-1.1"
+SLOT="0"
+LICENSE="unknown"
+KEYWORDS="x86 ppc -sparc -alpha"
+
+src_unpack() {
+ unpack zeta_cmd.zip zeta_progress.zip
+ if test -e /opt/zetagrid/zeta.cfg; then
+ cp /opt/zetagrid/zeta.cfg ${WORKDIR}/zeta.cfg
+ fi
+}
+
+src_install() {
+ dodir /opt/zetagrid
+ cp ${FILESDIR}/zeta.sh ${D}/opt/zetagrid
+ cp ${FILESDIR}/zeta_progress.sh ${D}/opt/zetagrid
+ cp ${WORKDIR}/* ${D}/opt/zetagrid
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/zetagrid.init zetagrid
+}
+
+pkg_postinst() {
+ einfo "Zetagrid is now installed in /opt/zetagrid"
+ einfo "Please change zeta.cfg for configuration issues!"
+ einfo "More information about setup can be found at"
+ einfo "http://cvs.gentoo.org/~tantive"
+ einfo
+ einfo "Zetagrid can be started using zeta.sh"
+ einfo "Progress information is displayed by zeta_progress.sh or"
+ einfo "by "java -cp zeta_progress.jar zeta.JShowProgress"."
+ einfo
+ ewarn "If you're getting an error at first execution"
+ ewarn "please run it a second time, this issue is known"
+ ewarn "and only happens at the very first start."
+}
+