summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-03-03 11:33:11 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-03-03 11:33:11 +0000
commit18270a33849d76510c59067cb6b0b618fb53b20f (patch)
treeea1b23749e275ef1a9e4d2eb4e7798bd0b4ecd03 /app-sci
parentadding restricter depend. closes 43575 (Manifest recommit) (diff)
downloadgentoo-2-18270a33849d76510c59067cb6b0b618fb53b20f.tar.gz
gentoo-2-18270a33849d76510c59067cb6b0b618fb53b20f.tar.bz2
gentoo-2-18270a33849d76510c59067cb6b0b618fb53b20f.zip
Version bump, RESTRICT="nomirror"
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/foldingathome/ChangeLog8
-rw-r--r--app-sci/foldingathome/Manifest2
-rw-r--r--app-sci/foldingathome/files/digest-foldingathome-4.0.01
-rw-r--r--app-sci/foldingathome/foldingathome-4.0.0.ebuild54
4 files changed, 64 insertions, 1 deletions
diff --git a/app-sci/foldingathome/ChangeLog b/app-sci/foldingathome/ChangeLog
index 4629785597d9..d8943bb664a6 100644
--- a/app-sci/foldingathome/ChangeLog
+++ b/app-sci/foldingathome/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-sci/foldingathome
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/foldingathome/ChangeLog,v 1.7 2004/03/01 13:09:09 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/foldingathome/ChangeLog,v 1.8 2004/03/03 11:33:11 phosphan Exp $
+
+*foldingathome-4.0.0 (03 Mar 2004)
+
+ 03 Mar 2004; Patrick Kursawe <phosphan@gentoo.org>
+ foldingathome-4.0.0.ebuild:
+ Version bump inspired by bug #34859
*foldingathome-3.24-r1 (01 Mar 2004)
diff --git a/app-sci/foldingathome/Manifest b/app-sci/foldingathome/Manifest
index b36ce5988d8c..2a139450df10 100644
--- a/app-sci/foldingathome/Manifest
+++ b/app-sci/foldingathome/Manifest
@@ -1,5 +1,6 @@
MD5 5c26c03a2b43eb175769a75e941badec foldingathome-3.14.ebuild 1117
MD5 15f7e18c0ed8c0c09dd792eb75c57125 foldingathome-3.24-r1.ebuild 1602
+MD5 137b5e37f25b3818a5ece849cfde8c0b foldingathome-4.0.0.ebuild 1287
MD5 1a83aa658cf629d1d036251bdf030178 ChangeLog 1310
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 e95be0e5334a02a9e9d86940c433b1d4 foldingathome-3.24.ebuild 1310
@@ -10,3 +11,4 @@ MD5 398541541417353090c2a40cb4fe4a3b files/folding-init.d-r1 746
MD5 aec1f2de50cf95bf1797d61ae94b3b04 files/folding.sh 88
MD5 507a00167f75ffe5044d132a477cdd8b files/digest-foldingathome-3.14 66
MD5 ad7ecc18b7b0f523434d668ba40295f4 files/digest-foldingathome-3.24 143
+MD5 6c633c6cc20e087d9da4585c5d9563dc files/digest-foldingathome-4.0.0 66
diff --git a/app-sci/foldingathome/files/digest-foldingathome-4.0.0 b/app-sci/foldingathome/files/digest-foldingathome-4.0.0
new file mode 100644
index 000000000000..6018adcfd4d5
--- /dev/null
+++ b/app-sci/foldingathome/files/digest-foldingathome-4.0.0
@@ -0,0 +1 @@
+MD5 d8ca3f78a3fff62059b780891d4c1e06 FAH4Console-Linux.exe 246740
diff --git a/app-sci/foldingathome/foldingathome-4.0.0.ebuild b/app-sci/foldingathome/foldingathome-4.0.0.ebuild
new file mode 100644
index 000000000000..02ec03e84ff1
--- /dev/null
+++ b/app-sci/foldingathome/foldingathome-4.0.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/foldingathome/foldingathome-4.0.0.ebuild,v 1.1 2004/03/03 11:33:11 phosphan Exp $
+
+# no version number on this install dir since upgrades will be using same dir
+# (data will be stored here too)
+I="/opt/foldingathome"
+
+inherit eutils
+
+DESCRIPTION="Help simulate protein folding at home"
+HOMEPAGE="http://folding.stanford.edu/"
+SRC_URI="http://www.stanford.edu/group/pandegroup/release/FAH4Console-Linux.exe"
+RESTRICT="nomirror"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-apps/baselayout-1.8.0
+ >=sys-libs/glibc-2.3.0"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${A}" ${PN}
+}
+
+src_install() {
+ exeinto ${I}
+ doexe foldingathome
+ doexe ${FILESDIR}/folding.sh
+ doexe ${FILESDIR}/initfolding
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/folding-init.d-r1 foldingathome
+}
+
+pkg_preinst() {
+ enewuser foldingathome -1 /bin/bash /opt/foldingathome
+}
+
+pkg_postinst() {
+ chown -R foldingathome:nogroup /opt/foldingathome
+ einfo "To run Folding@home in the background at boot:"
+ einfo " rc-update add foldingathome default"
+ einfo ""
+ einfo "For first run configuration, please run /opt/foldingathome/initfolding"
+}
+
+pkg_postrm() {
+ einfo "Folding@home data files were not removed."
+ einfo " Remove them manually from ${I}"
+ einfo ""
+}