summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-02-07 06:22:03 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-02-07 06:22:03 +0000
commit37d3ca2fdecf67129dbb34a9c98e5cae71a088f0 (patch)
tree9c0d613e31596215639fc00d065b9e1d7a42927d /app-sci
parentjust doin what the man says (diff)
downloadgentoo-2-37d3ca2fdecf67129dbb34a9c98e5cae71a088f0.tar.gz
gentoo-2-37d3ca2fdecf67129dbb34a9c98e5cae71a088f0.tar.bz2
gentoo-2-37d3ca2fdecf67129dbb34a9c98e5cae71a088f0.zip
new version (bug fixes and updates)
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/tbass/ChangeLog8
-rw-r--r--app-sci/tbass/files/digest-tbass-200301086
-rw-r--r--app-sci/tbass/tbass-20030108.ebuild76
3 files changed, 89 insertions, 1 deletions
diff --git a/app-sci/tbass/ChangeLog b/app-sci/tbass/ChangeLog
index d634e5771a00..358ea97f48c5 100644
--- a/app-sci/tbass/ChangeLog
+++ b/app-sci/tbass/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-sci/tbass
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-sci/tbass/ChangeLog,v 1.4 2003/01/08 01:40:54 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/tbass/ChangeLog,v 1.5 2003/02/07 06:22:03 george Exp $
+
+*tbass-20030108 (06 Feb 2003)
+
+ 06 Feb 2003; George Shapovalov <george@gentoo.org> tbass-20030108.ebuild :
+ new version (#13670)
+ thanks to Dave Nellans <dnellans@cs.utah.edu> for submission
07 Jan 2003; George Shapovalov <george@gentoo.org> tbass-20020729.ebuild :
added IUSE
diff --git a/app-sci/tbass/files/digest-tbass-20030108 b/app-sci/tbass/files/digest-tbass-20030108
new file mode 100644
index 000000000000..733d28fc05e8
--- /dev/null
+++ b/app-sci/tbass/files/digest-tbass-20030108
@@ -0,0 +1,6 @@
+MD5 5cb6cbc053a8f993b20dec9bf93417bd balsa-20030108.tar.gz 939532
+MD5 29607ba5259e42363ea1b86838c3743b balsa-manual.pdf 369873
+MD5 af8abda78884e905470e992f57e64534 dma-example.tar.gz 7194
+MD5 6bf0aa7eb37a33728f58221502cc7f6a examples.tar.gz 7017
+MD5 1dd3ad22d8963224e28803f6205ea0b0 balsa-tech-ams-20020402.tar.gz 40354
+MD5 e62008bbe3fc641759adeba9bed09d0d balsa-tech-verilog-20030108.tar.gz 50377
diff --git a/app-sci/tbass/tbass-20030108.ebuild b/app-sci/tbass/tbass-20030108.ebuild
new file mode 100644
index 000000000000..01a0819fa92d
--- /dev/null
+++ b/app-sci/tbass/tbass-20030108.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/tbass/tbass-20030108.ebuild,v 1.1 2003/02/07 06:22:03 george Exp $
+
+IUSE=""
+
+Name="balsa"
+
+DESCRIPTION="Balsa is both a framework for synthesising asynchronous hardware systems and the language for describing such systems"
+HOMEPAGE="http://www.cs.man.ac.uk/amulet/projects/balsa/"
+SRC_URI="ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/snapshots/${Name}-${PV}.tar.gz
+ ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/docs/balsa-manual.pdf
+ ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/examples/dma-example.tar.gz
+ ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/examples/examples.tar.gz
+ ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/snapshots/${Name}-tech-ams-20020402.tar.gz
+ ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/snapshots/${Name}-tech-verilog-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc "
+
+DEPEND="virtual/glibc
+ sys-devel/binutils
+ >=app-sci/lard-20030109
+ dev-libs/gmp
+ sys-devel/perl
+ x11-libs/gtk+"
+
+RDEPEND="${DEPEND}
+ dev-util/guile
+ media-gfx/graphviz"
+
+S=${WORKDIR}/${Name}-${PV}
+
+src_unpack() {
+ unpack ${Name}-${PV}.tar.gz dma-example.tar.gz examples.tar.gz ${Name}-tech-ams-20020402.tar.gz ${Name}-tech-verilog-${PV}.tar.gz
+}
+
+src_compile() {
+ # compile balsa
+ econf
+
+ cd bin
+ sed -e "s: \$(bindir): \$(DESTDIR)\$(bindir):g" Makefile > Makefile.1
+ cp Makefile.1 Makefile
+ emake || die
+
+ # configure tech paths
+ cd ${WORKDIR}/balsa-tech-ams-1.0
+ econf
+
+ cd ${WORKDIR}/balsa-tech-verilog-1.0
+ econf
+}
+
+src_install() {
+ # install balsa
+ einstall || die "make install failed"
+
+ # move the docs to the right directory
+ dodoc ${D}/usr/doc/*
+ rm -rf ${D}/usr/doc
+
+ # install manual and examples
+ dodir /usr/share/doc/${P}/examples/dma-example
+ cp -R ${WORKDIR}/dma-example ${D}/usr/share/doc/${P}/examples
+ cp -R ${WORKDIR}/examples/* ${D}/usr/share/doc/${P}/examples
+ dodoc ${DISTDIR}/balsa-manual.pdf
+
+ # install tech
+ cd ${WORKDIR}/balsa-tech-ams-1.0
+ make DESTDIR=${D} install || die "make install failed"
+
+ cd ${WORKDIR}/balsa-tech-verilog-1.0
+ make DESTDIR=${D} install || die "make install failed"
+}