summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-12-07 14:33:21 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-12-07 14:33:21 +0000
commit68828544ea5d9d9435e7ec69c49c493ae53e7526 (patch)
treee74b9d1e020afb311ff819b52062063aaa83747b /app-sci
parentstable on amd64 per bug #72521 (Manifest recommit) (diff)
downloadgentoo-2-68828544ea5d9d9435e7ec69c49c493ae53e7526.tar.gz
gentoo-2-68828544ea5d9d9435e7ec69c49c493ae53e7526.tar.bz2
gentoo-2-68828544ea5d9d9435e7ec69c49c493ae53e7526.zip
Version bump
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/octave/ChangeLog7
-rw-r--r--app-sci/octave/Manifest2
-rw-r--r--app-sci/octave/files/digest-octave-2.1.641
-rw-r--r--app-sci/octave/octave-2.1.64.ebuild102
4 files changed, 111 insertions, 1 deletions
diff --git a/app-sci/octave/ChangeLog b/app-sci/octave/ChangeLog
index 3235227c2434..4e571ed5b5f2 100644
--- a/app-sci/octave/ChangeLog
+++ b/app-sci/octave/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-sci/octave
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/ChangeLog,v 1.37 2004/11/30 15:02:53 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/ChangeLog,v 1.38 2004/12/07 14:33:21 phosphan Exp $
+
+*octave-2.1.64 (07 Dec 2004)
+
+ 07 Dec 2004; Patrick Kursawe <phosphan@gentoo.org> +octave-2.1.64.ebuild:
+ Version bump
30 Nov 2004; Patrick Kursawe <phosphan@gentoo.org> octave-2.1.50.ebuild:
Adding fortran compiler check from newest version to .50 because of bug #66193.
diff --git a/app-sci/octave/Manifest b/app-sci/octave/Manifest
index 6575c85d8b59..2508063f0a68 100644
--- a/app-sci/octave/Manifest
+++ b/app-sci/octave/Manifest
@@ -1,3 +1,4 @@
+MD5 8b9543f0736a385f3a84905e93af6cf7 octave-2.1.64.ebuild 2857
MD5 da68a6e1ee5ed6f35f9a2e328d809a49 octave-2.1.50.ebuild 2361
MD5 3b91b6ca6d7146d7d1973f1642d083c7 octave-2.1.57.ebuild 2195
MD5 3fa509863bf3278c00c398c886102a8f octave-2.1.57-r1.ebuild 2855
@@ -10,3 +11,4 @@ MD5 74d376b9c7367fe7b333cbc7e8ca37b3 files/kill-dvips.diff 2448
MD5 045463e5ebb1615d834a8145b27a765d files/filebuf.diff 1275
MD5 806a54605ad877d62105b2f58819c92d files/digest-octave-2.1.50 67
MD5 32c6cee1f5b42b8b20369c3722fb4db2 files/digest-octave-2.1.57 67
+MD5 157e958a946705cefe2968c7f46d5263 files/digest-octave-2.1.64 67
diff --git a/app-sci/octave/files/digest-octave-2.1.64 b/app-sci/octave/files/digest-octave-2.1.64
new file mode 100644
index 000000000000..bf66a94cf4d9
--- /dev/null
+++ b/app-sci/octave/files/digest-octave-2.1.64
@@ -0,0 +1 @@
+MD5 01ec8b13bd850123b190129be93adc1f octave-2.1.64.tar.bz2 4341798
diff --git a/app-sci/octave/octave-2.1.64.ebuild b/app-sci/octave/octave-2.1.64.ebuild
new file mode 100644
index 000000000000..52aff4c5d0fc
--- /dev/null
+++ b/app-sci/octave/octave-2.1.64.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.1.64.ebuild,v 1.1 2004/12/07 14:33:21 phosphan Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="GNU Octave is a high-level language (MatLab compatible) intended for numerical computations"
+HOMEPAGE="http://www.octave.org/"
+SRC_URI="ftp://ftp.octave.org/pub/octave/bleeding-edge/${P}.tar.bz2
+ ftp://ftp.math.uni-hamburg.de/pub/soft/math/octave/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~amd64"
+IUSE="emacs static readline zlib tetex hdf5 mpi ifc blas"
+
+DEPEND="virtual/libc
+ >=sys-libs/ncurses-5.2-r3
+ >=media-gfx/gnuplot-3.7.1-r3
+ >=dev-libs/fftw-2.1.3
+ >=dev-util/gperf-2.7.2
+ zlib? ( sys-libs/zlib )
+ hdf5? ( dev-libs/hdf5 )
+ tetex? ( virtual/tetex )
+ x86? ( ifc? ( dev-lang/ifc ) )
+ blas? ( virtual/blas )"
+
+# NOTE: octave supports blas/lapack from intel but this is not open
+# source nor is it free (as in beer OR speech) Check out...
+# http://developer.intel.com/software/products/mkl/mkl52/index.htm for
+# more information
+
+pkg_setup() {
+ use ifc || if [ -z `which g77` ]; then
+ #if ifc is defined then the dep was already checked
+ eerror "No fortran compiler found on the system!"
+ eerror "Please add f77 to your USE flags and reemerge gcc!"
+ die
+ fi
+}
+
+src_compile() {
+ filter-flags -ffast-math
+
+ local myconf
+
+ use static || myconf="--disable-static --enable-shared --enable-dl"
+ use readline || myconf="${myconf} --disable-readline"
+ use hdf5 || myconf="${myconf} --without-hdf5"
+ use mpi || myconf="${myconf} --without-mpi"
+
+ # Only add -lz to LDFLAGS if we have zlib in USE !
+ # BUG #52604
+ # Danny van Dyk 2004/08/26
+ use zlib && LDFLAGS="${LDFLAGS} -lz"
+
+ # NOTE: This version actually works with gcc-3.x
+ ./configure ${myconf} --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/state/octave \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --build=${CHOST} \
+ --target=${CHOST} \
+ --enable-rpath \
+ --enable-lite-kernel \
+ LDFLAGS="${LDFLAGS}" || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die "make install failed"
+ use tetex && octave-install-doc
+ if use emacs; then
+ cd emacs
+ exeinto /usr/bin
+ doexe otags
+ doman otags.1
+ for emacsdir in /usr/share/emacs/site-lisp /usr/lib/xemacs/site-lisp; do
+ insinto ${emacsdir}
+ doins *.el
+ done
+ cd ..
+ fi
+}
+
+octave-install-doc() {
+ echo "Installing documentation..."
+ insinto /usr/share/doc/${PF}
+ doins doc/faq/Octave-FAQ.dvi
+ doins doc/interpreter/octave.dvi
+ doins doc/liboctave/liboctave.dvi
+ doins doc/refcard/refcard-a4.dvi
+ doins doc/refcard/refcard-legal.dvi
+ doins doc/refcard/refcard-letter.dvi
+}