summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-03-12 16:32:09 +0000
committerMichael Imhof <tantive@gentoo.org>2003-03-12 16:32:09 +0000
commit71bc2e86b053796c0f30404f7b6a5db9d2284f83 (patch)
tree3c646335f361dde8f318e63e3ae61292dd304ef9 /app-sci
parentAdded -DTUNTAP to emake. Should close #16384. (diff)
downloadgentoo-2-71bc2e86b053796c0f30404f7b6a5db9d2284f83.tar.gz
gentoo-2-71bc2e86b053796c0f30404f7b6a5db9d2284f83.tar.bz2
gentoo-2-71bc2e86b053796c0f30404f7b6a5db9d2284f83.zip
Added submitted ebuild and bumped version to 20310 as 20304 can no longer be retrieved. Shoud close #17334.
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/chessbrain/ChangeLog18
-rw-r--r--app-sci/chessbrain/chessbrain-20304.ebuild45
-rw-r--r--app-sci/chessbrain/chessbrain-20310.ebuild45
-rw-r--r--app-sci/chessbrain/files/cb-conf.d3
-rw-r--r--app-sci/chessbrain/files/cb-init.d50
-rw-r--r--app-sci/chessbrain/files/digest-chessbrain-203041
-rw-r--r--app-sci/chessbrain/files/digest-chessbrain-203101
7 files changed, 163 insertions, 0 deletions
diff --git a/app-sci/chessbrain/ChangeLog b/app-sci/chessbrain/ChangeLog
new file mode 100644
index 000000000000..cbe78f04ad2f
--- /dev/null
+++ b/app-sci/chessbrain/ChangeLog
@@ -0,0 +1,18 @@
+# ChangeLog for app-sci/chessbrain
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/chessbrain/ChangeLog,v 1.1 2003/03/12 16:32:09 tantive Exp $
+
+*chessbrain-20310 (12 Mar 2003)
+
+ 12 Mar 2003; Michael Imhof <tantive@gentoo.org>
+ chessbrain-20310.ebuild:
+ Added submitted ebuild and bumped version to 20310 as 20304 can no longer be
+ retrieved. Shoud close #17334.
+
+*ChessBrain-20304 (08 Mar 2003)
+
+ 08 Mar 2003; Abhishek Amit <abhishekamit2000@yahoo.com>
+ chessbrain-20304.ebuild files/cb-conf.d files/cb-init.d
+ files/digest-chessbrain-20304 :
+ Initial import. Ebuild submitted by Abhishek Amit
+ <abhishekamit2000@yahoo.com>. Modeled after setiathome ebuild.
diff --git a/app-sci/chessbrain/chessbrain-20304.ebuild b/app-sci/chessbrain/chessbrain-20304.ebuild
new file mode 100644
index 000000000000..130a05d56062
--- /dev/null
+++ b/app-sci/chessbrain/chessbrain-20304.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/chessbrain/chessbrain-20304.ebuild,v 1.1 2003/03/12 16:32:09 tantive Exp $
+
+
+DESCRIPTION="This is a client for ChessBrain, a distibuted computing project."
+
+HOMEPAGE="http://www.chessbrain.net/"
+PV=${PV}-01
+SRC_URI="http://www.chessbrain.net/client${PV}-lin.tgz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=""
+# no version number on this install dir since upgrades will be using same dir
+# (data will be stored here too)
+I=/opt/chessbrain
+S=${WORKDIR}
+src_install () {
+ dodir ${I}
+ cp {cbspn,cbspn.conf} ${D}/${I}
+ chown nobody.nogroup ${D}/${I}
+ chown nobody.nogroup ${D}/${I}/cbspn
+ chmod +s ${S}/cbspn
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/cb-init.d chessbrain
+ insinto /etc/conf.d ; newins ${FILESDIR}/cb-conf.d chessbrain
+ echo "CHESSBRAIN_DIR=${I}">> ${D}/etc/conf.d/chessbrain
+}
+
+pkg_postinst () {
+ einfo "To run ChessBrain in the background at boot:"
+ einfo " Edit ${I}/cbspn.conf for information relevant to ChessBrain"
+ einfo " See http://www.chessbrain.net/peernodenotes.html"
+ einfo " Then just run \`/etc/init.d/chessbrain start\`"
+ einfo ""
+ einfo "Otherwise remember to cd into the directory"
+ einfo "where it should keep its data files first, like so:"
+ einfo " cd ${I} && ./cbspn"
+}
diff --git a/app-sci/chessbrain/chessbrain-20310.ebuild b/app-sci/chessbrain/chessbrain-20310.ebuild
new file mode 100644
index 000000000000..967f07b38d3d
--- /dev/null
+++ b/app-sci/chessbrain/chessbrain-20310.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/chessbrain/chessbrain-20310.ebuild,v 1.1 2003/03/12 16:32:09 tantive Exp $
+
+
+DESCRIPTION="This is a client for ChessBrain, a distibuted computing project."
+
+HOMEPAGE="http://www.chessbrain.net/"
+PV=${PV}-01
+SRC_URI="http://www.chessbrain.net/client${PV}-lin.tgz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=""
+# no version number on this install dir since upgrades will be using same dir
+# (data will be stored here too)
+I=/opt/chessbrain
+S=${WORKDIR}
+src_install () {
+ dodir ${I}
+ cp {cbspn,cbspn.conf} ${D}/${I}
+ chown nobody.nogroup ${D}/${I}
+ chown nobody.nogroup ${D}/${I}/cbspn
+ chmod +s ${S}/cbspn
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/cb-init.d chessbrain
+ insinto /etc/conf.d ; newins ${FILESDIR}/cb-conf.d chessbrain
+ echo "CHESSBRAIN_DIR=${I}">> ${D}/etc/conf.d/chessbrain
+}
+
+pkg_postinst () {
+ einfo "To run ChessBrain in the background at boot:"
+ einfo " Edit ${I}/cbspn.conf for information relevant to ChessBrain"
+ einfo " See http://www.chessbrain.net/peernodenotes.html"
+ einfo " Then just run \`/etc/init.d/chessbrain start\`"
+ einfo ""
+ einfo "Otherwise remember to cd into the directory"
+ einfo "where it should keep its data files first, like so:"
+ einfo " cd ${I} && ./cbspn"
+}
diff --git a/app-sci/chessbrain/files/cb-conf.d b/app-sci/chessbrain/files/cb-conf.d
new file mode 100644
index 000000000000..6b687e61f696
--- /dev/null
+++ b/app-sci/chessbrain/files/cb-conf.d
@@ -0,0 +1,3 @@
+# Config file for /etc/init.d/chessbrain
+
+# this is the directory where setiathome's data files will be stored
diff --git a/app-sci/chessbrain/files/cb-init.d b/app-sci/chessbrain/files/cb-init.d
new file mode 100644
index 000000000000..b0cc6d42361a
--- /dev/null
+++ b/app-sci/chessbrain/files/cb-init.d
@@ -0,0 +1,50 @@
+#!/sbin/runscript
+
+cpus=`egrep -c "^processor" /proc/cpuinfo`
+
+checkconfig() {
+ if [ ! -e ${CHESSBRAIN_DIR} ]
+ then
+ einfo "Creating ${CHESSBRAIN_DIR}"
+ mkdir ${CHESSBRAIN_DIR}
+ fi
+
+ if [ $cpus != '1' ]; then
+ cd ${CHESSBRAIN_DIR}
+ for cpu in `seq 2 $cpus`; do
+ if [ ! -e ${CHESSBRAIN_DIR}/cpu${cpu} ]; then
+ mkdir ${CHESSBRAIN_DIR}/cpu${cpu}
+ cp ${CHESSBRAIN_DIR}/* ${CHESSBRAIN_DIR}/cpu${cpu} > /dev/null
+ cp ${CHESSBRAIN_DIR}/cbspan.conf ${CHESSBRAIN_DIR}/cpu${cpu}
+ fi
+ done
+ fi
+}
+
+start() {
+ checkconfig
+
+
+ if [ $cpus = '1' ]; then
+ ebegin "Starting ChessBrain"
+ else
+ ebegin "Starting ChessBrain ($cpus processors)"
+ fi
+
+ for cpu in `seq 1 $cpus`; do
+ cd ${CHESSBRAIN_DIR}
+ if [ $cpu != '1' ]; then
+ cd cpu${cpu}
+ fi
+
+ ./cbspn >&/dev/null&
+ done
+
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ChessBrain"
+ killall cbspn
+ eend $?
+}
diff --git a/app-sci/chessbrain/files/digest-chessbrain-20304 b/app-sci/chessbrain/files/digest-chessbrain-20304
new file mode 100644
index 000000000000..16da56c7f3ea
--- /dev/null
+++ b/app-sci/chessbrain/files/digest-chessbrain-20304
@@ -0,0 +1 @@
+MD5 543eddee6345c6c4d4eb8722c863d48c client20304-01-lin.tgz 130817
diff --git a/app-sci/chessbrain/files/digest-chessbrain-20310 b/app-sci/chessbrain/files/digest-chessbrain-20310
new file mode 100644
index 000000000000..65a65f93280c
--- /dev/null
+++ b/app-sci/chessbrain/files/digest-chessbrain-20310
@@ -0,0 +1 @@
+MD5 ea3467c5552a43909644d24f82946b32 client20310-01-lin.tgz 130426