summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-11-09 12:30:13 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-11-09 12:30:13 +0000
commit5e7f9d96380cbdad04a14e68645353fa73c2d2a1 (patch)
tree376c59bdd902192cbc9d41e3ed4dda86eef9807a /app-shells/bash-completion
parenttemporarily set RESTRICT=nomirror (see comment in ebuild) (Manifest recommit) (diff)
downloadgentoo-2-5e7f9d96380cbdad04a14e68645353fa73c2d2a1.tar.gz
gentoo-2-5e7f9d96380cbdad04a14e68645353fa73c2d2a1.tar.bz2
gentoo-2-5e7f9d96380cbdad04a14e68645353fa73c2d2a1.zip
Updated profile.d file to also source anything in ~/.bash_completion.d
Diffstat (limited to 'app-shells/bash-completion')
-rw-r--r--app-shells/bash-completion/ChangeLog5
-rw-r--r--app-shells/bash-completion/Manifest10
-rw-r--r--app-shells/bash-completion/files/bash-completion9
3 files changed, 17 insertions, 7 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index 8c746fd9d3ad..3ad188b0163c 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-shells/bash-completion
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.77 2004/11/05 09:02:40 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.78 2004/11/09 12:30:13 ka0ttic Exp $
+
+ 09 Nov 2004; Aaron Walker <ka0ttic@gentoo.org> files/bash-completion:
+ Updated profile.d file to also source anything in ~/.bash_completion.d
05 Nov 2004; Joshua Kinard <kumba@gentoo.org>
bash-completion-20040711.ebuild:
diff --git a/app-shells/bash-completion/Manifest b/app-shells/bash-completion/Manifest
index 70933af9a79e..5228118c2a6d 100644
--- a/app-shells/bash-completion/Manifest
+++ b/app-shells/bash-completion/Manifest
@@ -1,11 +1,11 @@
-MD5 d2167d429b99e12f8d6318d6a174d881 ChangeLog 10999
-MD5 7d4aeaf81dd9f767c41a81c3e47d01a2 bash-completion-20040704-r1.ebuild 2087
+MD5 50f43407f43fdbbfa26b4d63f947497a bash-completion-20040711.ebuild 2088
MD5 f6bee54f0c35dc47430924ecb49c03fb bash-completion-20040704.ebuild 2092
+MD5 7d4aeaf81dd9f767c41a81c3e47d01a2 bash-completion-20040704-r1.ebuild 2087
+MD5 f96d9ff7458148b834f9809580fe037c ChangeLog 11145
MD5 00e8cae3d9ece63e4be61f4a2b3afd5e metadata.xml 930
-MD5 50f43407f43fdbbfa26b4d63f947497a bash-completion-20040711.ebuild 2088
MD5 3790b4d8b911d7cb16effa66acdc6e93 bash-completion-20041017.ebuild 2123
-MD5 ff208a2c09a302be5db88edf519a4086 files/bash-completion 626
+MD5 c763c0113c858c177a9a090ebb5eff0f files/bash-completion 788
MD5 49e9f0b0674471ff56169ce7d9265fb2 files/digest-bash-completion-20040704 151
-MD5 49e9f0b0674471ff56169ce7d9265fb2 files/digest-bash-completion-20040704-r1 151
MD5 73c3177da25971c1db7bb6482b5d1580 files/digest-bash-completion-20040711 151
MD5 236fd9c517ac5642cae8df109dbaf9f6 files/digest-bash-completion-20041017 152
+MD5 49e9f0b0674471ff56169ce7d9265fb2 files/digest-bash-completion-20040704-r1 151
diff --git a/app-shells/bash-completion/files/bash-completion b/app-shells/bash-completion/files/bash-completion
index bd3c9a1d91b4..3d4699395054 100644
--- a/app-shells/bash-completion/files/bash-completion
+++ b/app-shells/bash-completion/files/bash-completion
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/files/bash-completion,v 1.5 2004/07/29 02:48:19 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/files/bash-completion,v 1.6 2004/11/09 12:30:13 ka0ttic Exp $
#
# START bash completion -- do not remove this line
bash=${BASH_VERSION%.*}; bmajor=${bash%.*}; bminor=${bash#*.}
@@ -12,4 +12,11 @@ if [ "$PS1" ] && [ -f /etc/bash_completion ] ; then
fi
fi
unset bash bmajor bminor
+
+# per-user completions
+if [ "$PS1" ] && [ -d ~/.bash_completion.d ] ; then
+ for file in ~/.bash_completion.d/* ; do
+ [ -f $file ] && source $file
+ done
+fi
# END bash completion -- do not remove this line