summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-24 22:13:41 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-24 22:13:41 +0000
commit7bf8a41e92f6d7163badf5ee1390acd97db2108e (patch)
treeb2f6a7a4cb5477ec9abebffa6f20f153fa6c994b /app-shells/bash
parenttouch up style a bit (diff)
downloadgentoo-2-7bf8a41e92f6d7163badf5ee1390acd97db2108e.tar.gz
gentoo-2-7bf8a41e92f6d7163badf5ee1390acd97db2108e.tar.bz2
gentoo-2-7bf8a41e92f6d7163badf5ee1390acd97db2108e.zip
Add another fix from upstream.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/bash')
-rw-r--r--app-shells/bash/ChangeLog6
-rw-r--r--app-shells/bash/bash-4.0.ebuild9
-rw-r--r--app-shells/bash/files/bash-4.0-pcomplete-save-parser-state.patch12
3 files changed, 22 insertions, 5 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 8938aa772c27..17d7c715f4fb 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.200 2009/02/24 17:18:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.201 2009/02/24 22:13:40 vapier Exp $
+
+ 24 Feb 2009; Mike Frysinger <vapier@gentoo.org>
+ +files/bash-4.0-pcomplete-save-parser-state.patch, bash-4.0.ebuild:
+ Add another fix from upstream.
24 Feb 2009; Mike Frysinger <vapier@gentoo.org> bash-4.0.ebuild:
Drop BSD patch as it causes bad behavior on Linux #259860.
diff --git a/app-shells/bash/bash-4.0.ebuild b/app-shells/bash/bash-4.0.ebuild
index b5a39df69bff..d4e8a37f507e 100644
--- a/app-shells/bash/bash-4.0.ebuild
+++ b/app-shells/bash/bash-4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.0.ebuild,v 1.5 2009/02/24 17:18:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.0.ebuild,v 1.6 2009/02/24 22:13:40 vapier Exp $
EAPI="1"
@@ -67,9 +67,10 @@ src_unpack() {
if ! use vanilla ; then
epatch "${FILESDIR}"/${PN}-3.2-parallel-build.patch #189671
epatch "${FILESDIR}"/${PN}-4.0-ldflags-for-build.patch #211947
- epatch "${FILESDIR}"/${PN}-4.0-comsub-backslash-metacharacters.patch
- epatch "${FILESDIR}"/${PN}-4.0-save-current-token.patch
- epatch "${FILESDIR}"/${PN}-4.0-exit-checkjobs.patch
+ epatch "${FILESDIR}"/${P}-pcomplete-save-parser-state.patch
+ epatch "${FILESDIR}"/${P}-comsub-backslash-metacharacters.patch
+ epatch "${FILESDIR}"/${P}-save-current-token.patch
+ epatch "${FILESDIR}"/${P}-exit-checkjobs.patch
epatch "${FILESDIR}"/${PN}-4.0-negative-return.patch
# Log bash commands to syslog #91327
if use bashlogger ; then
diff --git a/app-shells/bash/files/bash-4.0-pcomplete-save-parser-state.patch b/app-shells/bash/files/bash-4.0-pcomplete-save-parser-state.patch
new file mode 100644
index 000000000000..71b6e9632025
--- /dev/null
+++ b/app-shells/bash/files/bash-4.0-pcomplete-save-parser-state.patch
@@ -0,0 +1,12 @@
+http://lists.gnu.org/archive/html/bug-bash/2009-02/msg00142.html
+
+*** ../bash-4.0/pcomplete.c 2009-02-01 17:12:31.000000000 -0500
+--- pcomplete.c 2009-02-22 17:08:25.000000000 -0500
+***************
+*** 1033,1036 ****
+--- 1033,1037 ----
+
+ pps = &ps;
++ save_parser_state (pps);
+ begin_unwind_frame ("gen-shell-function-matches");
+ add_unwind_protect (restore_parser_state, (char *)pps);