summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-23 01:25:56 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-23 01:25:56 +0000
commitcad81a3893904b8be7feb029a1bb1b62457746a0 (patch)
treeb9fe7b275d3f442125fe71c90c067b051fd7654a /app-shells/bash
parentuse proper include path (diff)
downloadgentoo-2-cad81a3893904b8be7feb029a1bb1b62457746a0.tar.gz
gentoo-2-cad81a3893904b8be7feb029a1bb1b62457746a0.tar.bz2
gentoo-2-cad81a3893904b8be7feb029a1bb1b62457746a0.zip
The prototypes have been fixed in a different way apparently, so drop this patch.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/bash')
-rw-r--r--app-shells/bash/ChangeLog7
-rw-r--r--app-shells/bash/bash-4.0.ebuild3
-rw-r--r--app-shells/bash/files/bash-4.0-protos.patch35
3 files changed, 7 insertions, 38 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 51ab545a0e22..39795a23ca84 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.196 2009/02/21 23:03:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.197 2009/02/23 01:25:56 vapier Exp $
+
+ 23 Feb 2009; Mike Frysinger <vapier@gentoo.org>
+ -files/bash-4.0-protos.patch, bash-4.0.ebuild:
+ The prototypes have been fixed in a different way apparently, so drop this
+ patch.
*bash-4.0 (21 Feb 2009)
diff --git a/app-shells/bash/bash-4.0.ebuild b/app-shells/bash/bash-4.0.ebuild
index fdc3effdda2a..e6265da78902 100644
--- a/app-shells/bash/bash-4.0.ebuild
+++ b/app-shells/bash/bash-4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.0.ebuild,v 1.1 2009/02/21 23:03:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.0.ebuild,v 1.2 2009/02/23 01:25:56 vapier Exp $
EAPI="1"
@@ -68,7 +68,6 @@ src_unpack() {
cd ../..
if ! use vanilla ; then
- epatch "${FILESDIR}"/${PN}-4.0-protos.patch
epatch "${FILESDIR}"/${PN}-3.2-parallel-build.patch #189671
epatch "${FILESDIR}"/${PN}-4.0-ldflags-for-build.patch #211947
epatch "${FILESDIR}"/${PN}-3.2-process-subst.patch
diff --git a/app-shells/bash/files/bash-4.0-protos.patch b/app-shells/bash/files/bash-4.0-protos.patch
deleted file mode 100644
index 6b38e6849973..000000000000
--- a/app-shells/bash/files/bash-4.0-protos.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-move prototypes around so they show up when needed
-
---- a/lib/glob/strmatch.c
-+++ b/lib/glob/strmatch.c
-@@ -25,9 +25,6 @@
- #include "strmatch.h"
-
- extern int xstrmatch __P((char *, char *, int));
--#if defined (HANDLE_MULTIBYTE)
--extern int internal_wstrmatch __P((wchar_t *, wchar_t *, int));
--#endif
-
- int
- strmatch (pattern, string, flags)
---- a/lib/glob/strmatch.h
-+++ b/lib/glob/strmatch.h
-@@ -57,6 +57,7 @@
-
- #if HANDLE_MULTIBYTE
- extern int wcsmatch __P((wchar_t *, wchar_t *, int));
-+extern int internal_wstrmatch __P((wchar_t *, wchar_t *, int));
- #endif
-
- #endif /* _STRMATCH_H */
---- a/quit.h
-+++ b/quit.h
-@@ -21,6 +21,8 @@
- #if !defined (_QUIT_H_)
- #define _QUIT_H_
-
-+#include "sig.h"
-+
- /* Non-zero means SIGINT has already ocurred. */
- extern volatile int interrupt_state;
- extern volatile int terminating_signal;