summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-01-04 17:47:56 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-01-04 17:47:56 +0000
commitb65332a0e43ef77c776d1bd2be5112f6f108c648 (patch)
tree4ff46c711629f9677b35def41b96a78d214d5167 /app-shells/pdksh/pdksh-5.2.14-r4.ebuild
parentAdding amd64 keyword to satisfy dependencies (diff)
downloadgentoo-2-b65332a0e43ef77c776d1bd2be5112f6f108c648.tar.gz
gentoo-2-b65332a0e43ef77c776d1bd2be5112f6f108c648.tar.bz2
gentoo-2-b65332a0e43ef77c776d1bd2be5112f6f108c648.zip
patch for new coreutils syntax, thanks to: Stefan Knoblich <stkn@gentoo.org> in bug #31835
Diffstat (limited to 'app-shells/pdksh/pdksh-5.2.14-r4.ebuild')
-rw-r--r--app-shells/pdksh/pdksh-5.2.14-r4.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/app-shells/pdksh/pdksh-5.2.14-r4.ebuild b/app-shells/pdksh/pdksh-5.2.14-r4.ebuild
index ccdc4753d3a8..c2fceb6fae5f 100644
--- a/app-shells/pdksh/pdksh-5.2.14-r4.ebuild
+++ b/app-shells/pdksh/pdksh-5.2.14-r4.ebuild
@@ -1,26 +1,30 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/pdksh/pdksh-5.2.14-r4.ebuild,v 1.15 2003/09/19 00:47:22 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/pdksh/pdksh-5.2.14-r4.ebuild,v 1.16 2004/01/04 17:47:50 seemant Exp $
+
+inherit eutils
S=${WORKDIR}/${P}
DESCRIPTION="The Public Domain Korn Shell"
-SRC_URI="ftp://ftp.cs.mun.ca/pub/pdksh/${P}.tar.gz
- ftp://ftp.cs.mun.ca/pub/pdksh/${P}-patches.1"
HOMEPAGE="http://www.cs.mun.ca/~michael/pdksh/"
-KEYWORDS="x86 ppc sparc alpha ia64"
+SRC_URI="ftp://ftp.cs.mun.ca/pub/pdksh/${P}.tar.gz
+ ftp://ftp.cs.mun.ca/pub/pdksh/${P}-patches.1"
+
SLOT="0"
LICENSE="as-is"
+KEYWORDS="x86 ppc sparc alpha ~hppa ~mips ~arm ~amd64 ia64 ~ppc64"
-DEPEND=">=sys-libs/glibc-2.1.3"
+DEPEND=">=sys-libs/glibc-2.1.3
+ sys-apps/coreutils"
src_unpack() {
unpack ${P}.tar.gz
cd ${S}
- patch -p2 < ${DISTDIR}/${P}-patches.1
+ epatch ${DISTDIR}/${P}-patches.1
+ epatch ${FILESDIR}/${P}-coreutils-posix-fix.patch
}
src_compile() {
-
echo 'ksh_cv_dev_fd=${ksh_cv_dev_fd=yes}' > config.cache
./configure \
@@ -31,7 +35,6 @@ src_compile() {
}
src_install() {
-
into /
dobin ksh
into usr
@@ -39,5 +42,4 @@ src_install() {
dodoc BUG-REPORTS ChangeLog* CONTRIBUTORS LEGAL NEWS NOTES PROJECTS README
docinto etc
dodoc etc/*
-
}