summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-26 10:00:59 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-26 10:00:59 +0000
commit54c8b89ef266bb055fdf31304d94fdcf7c710c23 (patch)
tree5f278f71f4c1ddfb64864730b4260e9db0d1552a /app-shells/prll
parentStable on everywhere. Bug with stablereq was closed and none expect Jer objec... (diff)
downloadgentoo-2-54c8b89ef266bb055fdf31304d94fdcf7c710c23.tar.gz
gentoo-2-54c8b89ef266bb055fdf31304d94fdcf7c710c23.tar.bz2
gentoo-2-54c8b89ef266bb055fdf31304d94fdcf7c710c23.zip
Imported from sunrise, Thanks Jure Varlec for inial ebuild, #299798.
(Portage version: 2.2_rc63/cvs/Linux i686)
Diffstat (limited to 'app-shells/prll')
-rw-r--r--app-shells/prll/ChangeLog11
-rw-r--r--app-shells/prll/files/0.4-ldflags.patch13
-rw-r--r--app-shells/prll/files/0.4-prefix.patch20
-rw-r--r--app-shells/prll/metadata.xml8
-rw-r--r--app-shells/prll/prll-0.4.ebuild30
5 files changed, 82 insertions, 0 deletions
diff --git a/app-shells/prll/ChangeLog b/app-shells/prll/ChangeLog
new file mode 100644
index 000000000000..3948efffee46
--- /dev/null
+++ b/app-shells/prll/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-shells/prll
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/prll/ChangeLog,v 1.1 2010/02/26 10:00:58 jlec Exp $
+
+*prll-0.4 (26 Feb 2010)
+
+ 26 Feb 2010; Justin Lecher (jlec) <jlec@j-schmitz.net>
+ +files/0.4-ldflags.patch, +files/0.4-prefix.patch, +prll-0.4.ebuild,
+ +metadata.xml:
+ Imported from sunrise, Thanks Jure Varlec for inial ebuild, #299798.
+
diff --git a/app-shells/prll/files/0.4-ldflags.patch b/app-shells/prll/files/0.4-ldflags.patch
new file mode 100644
index 000000000000..4e17c394ef83
--- /dev/null
+++ b/app-shells/prll/files/0.4-ldflags.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index c4587e7..b53dbb8 100644
+--- a/Makefile
++++ b/Makefile
+@@ -13,7 +13,7 @@ sanitycheck: check_key_size
+ ./check_key_size && touch sanitycheck || (rm -f sanitycheck && false)
+
+ prll_jobserver: sanitycheck
+- $(CC) $(CFLAGS) -o prll_jobserver prll_jobserver.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o prll_jobserver prll_jobserver.c
+
+ test: prll_jobserver
+ cd tests && $(MAKE)
diff --git a/app-shells/prll/files/0.4-prefix.patch b/app-shells/prll/files/0.4-prefix.patch
new file mode 100644
index 000000000000..82bf35891228
--- /dev/null
+++ b/app-shells/prll/files/0.4-prefix.patch
@@ -0,0 +1,20 @@
+diff --git a/prll.sh b/prll.sh
+index 2ed4c04..bcf1525 100644
+--- a/prll.sh
++++ b/prll.sh
+@@ -25,13 +25,13 @@ function prll() {
+ EOF
+ return 1
+ fi
+- /usr/bin/which prll_jobserver > /dev/null
++ @GENTOO_PORTAGE_EPREFIX@/usr/bin/which prll_jobserver > /dev/null
+ if [[ $? -ne 0 ]] ; then
+ echo "PRLL: Missing prll_jobserver." 1>&2
+ return 1
+ fi
+ if [[ -z $PRLL_NR_CPUS ]] ; then
+- /usr/bin/which grep > /dev/null
++ @GENTOO_PORTAGE_EPREFIX@/usr/bin/which grep > /dev/null
+ if [[ $? -ne 0 || ! -a /proc/cpuinfo ]] ; then
+ echo "PRLL: Environment variable PRLL_NR_CPUS is not set" 1>&2
+ echo "PRLL: and either the grep utility is missing or" 1>&2
diff --git a/app-shells/prll/metadata.xml b/app-shells/prll/metadata.xml
new file mode 100644
index 000000000000..05e29780c54a
--- /dev/null
+++ b/app-shells/prll/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-shells/prll/prll-0.4.ebuild b/app-shells/prll/prll-0.4.ebuild
new file mode 100644
index 000000000000..ec3a3040c0bc
--- /dev/null
+++ b/app-shells/prll/prll-0.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/prll/prll-0.4.ebuild,v 1.1 2010/02/26 10:00:58 jlec Exp $
+
+EAPI="2"
+
+inherit eutils prefix toolchain-funcs
+
+DESCRIPTION="A utility for parallelizing execution in bash or zsh"
+HOMEPAGE="http://prll.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3 WTFPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~x86-linux ~amd64-linux"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-ldflags.patch
+ epatch "${FILESDIR}"/${PV}-prefix.patch
+ tc-export CC
+ eprefixify ${PN}.sh
+}
+
+src_install() {
+ dobin ${PN}_jobserver || die
+ insinto /etc/profile.d/
+ doins ${PN}.sh || die
+ dodoc ChangeLog AUTHORS README NEWS || die
+}