summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPanagiotis Christopoulos <pchrist@gentoo.org>2008-08-03 16:10:31 +0000
committerPanagiotis Christopoulos <pchrist@gentoo.org>2008-08-03 16:10:31 +0000
commit8064e3dee3fec26d87a1367a3c65e360e3a534c7 (patch)
tree2a63c4d3e6215195a87b7c7e45d5b7e04b0d872b /app-shells/scsh/scsh-0.6.6.ebuild
parentkeywording ~amd64 (diff)
downloadgentoo-2-8064e3dee3fec26d87a1367a3c65e360e3a534c7.tar.gz
gentoo-2-8064e3dee3fec26d87a1367a3c65e360e3a534c7.tar.bz2
gentoo-2-8064e3dee3fec26d87a1367a3c65e360e3a534c7.zip
Add missing IUSE variable in ebuilds and fix typos
Diffstat (limited to 'app-shells/scsh/scsh-0.6.6.ebuild')
-rw-r--r--app-shells/scsh/scsh-0.6.6.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/app-shells/scsh/scsh-0.6.6.ebuild b/app-shells/scsh/scsh-0.6.6.ebuild
index 48bbd82db28e..301f9810fd74 100644
--- a/app-shells/scsh/scsh-0.6.6.ebuild
+++ b/app-shells/scsh/scsh-0.6.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/scsh/scsh-0.6.6.ebuild,v 1.6 2006/01/05 17:53:39 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/scsh/scsh-0.6.6.ebuild,v 1.7 2008/08/03 16:10:31 pchrist Exp $
inherit eutils scsh
@@ -12,6 +12,7 @@ SRC_URI="ftp://ftp.scsh.net/pub/scsh/${MV}/${P}.tar.gz"
LICENSE="as-is BSD"
SLOT="0"
KEYWORDS="~amd64 ppc sparc x86"
+IUSE=""
DEPEND=""
@@ -20,9 +21,9 @@ src_unpack() {
set_layout
set_path_variables
unpack ${A}
- cd ${S}
+ cd "${S}"
if ! use scsh; then
- epatch ${FILESDIR}/0.6.6-Makefile.in-doc-dir-gentoo.patch || die
+ epatch "${FILESDIR}/0.6.6-Makefile.in-doc-dir-gentoo.patch" || die
fi
}
@@ -31,14 +32,14 @@ src_compile() {
--libdir=/usr/$(get_libdir)
--includedir=/usr/include
--with-lib-dirs-list=$(scsh_scsh_path)"
- econf ${scsh_conf} || die
+ econf "${scsh_conf}" || die
emake || die
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
dodir /etc/env.d
- cat >${D}/etc/env.d/50scsh <<EOF
+ cat >"${D}/etc/env.d/50scsh" <<EOF
SCSH_LIB_DIRS='${SCSH_LIB_DIRS}'
EOF
}