summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2007-03-01 21:29:31 +0000
committerFabian Groffen <grobian@gentoo.org>2007-03-01 21:29:31 +0000
commit9004caf211813c295238c4f0851bc336375b0aa0 (patch)
tree54f889ccbb730a98fdaeda44db2778b317492c74 /app-shells/tcsh
parentmake sure we look for updated binpath in $ROOT as noted by Diego (diff)
downloadgentoo-2-9004caf211813c295238c4f0851bc336375b0aa0.tar.gz
gentoo-2-9004caf211813c295238c4f0851bc336375b0aa0.tar.bz2
gentoo-2-9004caf211813c295238c4f0851bc336375b0aa0.zip
New revision which uses an entirely revamped config files system. Should fix issues for KDE users. Please test.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'app-shells/tcsh')
-rw-r--r--app-shells/tcsh/ChangeLog8
-rw-r--r--app-shells/tcsh/files/digest-tcsh-6.14-r306
-rw-r--r--app-shells/tcsh/tcsh-6.14-r30.ebuild77
3 files changed, 90 insertions, 1 deletions
diff --git a/app-shells/tcsh/ChangeLog b/app-shells/tcsh/ChangeLog
index 102af83f60e6..86193e9a01b6 100644
--- a/app-shells/tcsh/ChangeLog
+++ b/app-shells/tcsh/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/tcsh
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/ChangeLog,v 1.66 2007/01/24 03:57:08 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/ChangeLog,v 1.67 2007/03/01 21:29:31 grobian Exp $
+
+*tcsh-6.14-r30 (01 Mar 2007)
+
+ 01 Mar 2007; Fabian Groffen <grobian@gentoo.org> +tcsh-6.14-r30.ebuild:
+ New revision which uses an entirely revamped config files system. Should fix
+ issues for KDE users. Please test.
24 Jan 2007; Marius Mauch <genone@gentoo.org> tcsh-6.14-r3.ebuild:
Replacing einfo with elog
diff --git a/app-shells/tcsh/files/digest-tcsh-6.14-r30 b/app-shells/tcsh/files/digest-tcsh-6.14-r30
new file mode 100644
index 000000000000..cf0bb409a11f
--- /dev/null
+++ b/app-shells/tcsh/files/digest-tcsh-6.14-r30
@@ -0,0 +1,6 @@
+MD5 353d1bb7d2741bf8de602c7b6f0efd79 tcsh-6.14.00.tar.gz 859780
+RMD160 fa7635225ceb0225aedcfad5dd9d8e17d8d70849 tcsh-6.14.00.tar.gz 859780
+SHA256 fd738ac0c003d283a214d15d46c1bc3fb80afad697110994dccb8d101f0d6f0e tcsh-6.14.00.tar.gz 859780
+MD5 e29f4f00e34fb959e6eebad5dbc9340e tcsh-config-1.1.tar.bz2 2263
+RMD160 3bc26e190bd56f07a629c3eba8a1fd881bc02d72 tcsh-config-1.1.tar.bz2 2263
+SHA256 c37544e77b6fe7a675d2a92819c42aa35fe91a23db6974866deb4a06ac5ae2a6 tcsh-config-1.1.tar.bz2 2263
diff --git a/app-shells/tcsh/tcsh-6.14-r30.ebuild b/app-shells/tcsh/tcsh-6.14-r30.ebuild
new file mode 100644
index 000000000000..1eab8bee9c57
--- /dev/null
+++ b/app-shells/tcsh/tcsh-6.14-r30.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.14-r30.ebuild,v 1.1 2007/03/01 21:29:31 grobian Exp $
+
+inherit eutils
+
+PATCHVER="1.1"
+
+MY_P="${P}.00"
+DESCRIPTION="Enhanced version of the Berkeley C shell (csh)"
+HOMEPAGE="http://www.tcsh.org/"
+SRC_URI="ftp://ftp.astron.com/pub/tcsh/${MY_P}.tar.gz
+ mirror://gentoo/tcsh-config-${PATCHVER}.tar.bz2
+ http://www.gentoo.org/~grobian/distfiles/tcsh-config-${PATCHVER}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="perl catalogs"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ perl? ( dev-lang/perl )
+ !app-shells/csh" # bug #119703
+
+S=${WORKDIR}/${MY_P}
+
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/${MY_P}"-debian-dircolors.patch # bug #120792
+ epatch "${FILESDIR}/${P}"-makefile.patch # bug #151951
+
+ if use catalogs ; then
+ einfo "enabling NLS catalogs support..."
+ sed -i -e "s/#undef NLS_CATALOGS/#define NLS_CATALOGS/" \
+ ${WORKDIR}/${MY_P}/config_f.h || die
+ eend $?
+ fi
+}
+
+src_compile() {
+ econf --prefix=/ || die "econf failed"
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install.man || die
+
+ if use perl ; then
+ perl tcsh.man2html || die
+ dohtml tcsh.html/*.html
+ fi
+
+ insinto /etc
+ doins \
+ "${WORKDIR}"/tcsh-config/csh.cshrc \
+ "${WORKDIR}"/tcsh-config/csh.login
+
+ insinto /etc/profile.d
+ doins \
+ "${WORKDIR}"/tcsh-config/tcsh-bindkey.csh \
+ "${WORKDIR}"/tcsh-config/tcsh-settings.csh
+
+ dodoc FAQ Fixes NewThings Ported README WishList Y2K
+
+ # bug #119703: add csh -> tcsh symlink
+ dosym /bin/tcsh /bin/csh
+}
+
+pkg_postinst() {
+ ewarn "This revision of tcsh does use a completely revamped configuration"
+ ewarn "files system, which is based on the bash equivalents. It should"
+ ewarn "fix issues for KDE users, and miscelaneous issues of environment"
+ ewarn "variables not set that should have, like EDITOR. If you rely"
+ ewarn "on the /etc/csh.* files heavily, you may find your setup will be"
+ ewarn "broken now."
+}