summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-11-12 12:18:03 +0000
committerMichael Weber <xmw@gentoo.org>2011-11-12 12:18:03 +0000
commit055564c27638bcc495f9068c834ac51381bd22e9 (patch)
tree7624878ae97382d0c8193ab3f55cf855ce10c234 /app-shells
parentCorrected Slotting of media-libs/libpng and media-libs/tiff (diff)
downloadgentoo-2-055564c27638bcc495f9068c834ac51381bd22e9.tar.gz
gentoo-2-055564c27638bcc495f9068c834ac51381bd22e9.tar.bz2
gentoo-2-055564c27638bcc495f9068c834ac51381bd22e9.zip
Revbump to optionally include multi-line prompt patch by Ben Hoskings as suggested by James Bowlin (bug 205809)
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/fish/ChangeLog9
-rw-r--r--app-shells/fish/files/fish-1.23.1-multi-line_prompts.patch15
-rw-r--r--app-shells/fish/fish-1.23.1-r2.ebuild66
3 files changed, 89 insertions, 1 deletions
diff --git a/app-shells/fish/ChangeLog b/app-shells/fish/ChangeLog
index 0ee9c4e2933d..551f8db0ecd0 100644
--- a/app-shells/fish/ChangeLog
+++ b/app-shells/fish/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/fish
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/ChangeLog,v 1.49 2011/07/07 10:41:38 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/ChangeLog,v 1.50 2011/11/12 12:18:03 xmw Exp $
+
+*fish-1.23.1-r2 (12 Nov 2011)
+
+ 12 Nov 2011; Michael Weber <xmw@gentoo.org> +fish-1.23.1-r2.ebuild,
+ +files/fish-1.23.1-multi-line_prompts.patch:
+ Revbump to optionally include multi-line prompt patch by Ben Hoskings as
+ suggested by James Bowlin (bug 205809)
07 Jul 2011; Lars Wendler <polynomial-c@gentoo.org> -fish-1.23.0.ebuild,
fish-1.23.1.ebuild, fish-1.23.1-r1.ebuild:
diff --git a/app-shells/fish/files/fish-1.23.1-multi-line_prompts.patch b/app-shells/fish/files/fish-1.23.1-multi-line_prompts.patch
new file mode 100644
index 000000000000..221323d9f638
--- /dev/null
+++ b/app-shells/fish/files/fish-1.23.1-multi-line_prompts.patch
@@ -0,0 +1,15 @@
+Downloaded from http://benhoskin.gs/2009/11/25/multi-line-prompts-in-fish/
+
+--- fish-1.23.1/reader.c
++++ fish-1.23.1/reader.c
+@@ -698,6 +698,10 @@
+ for( i=0; i<al_get_count( &prompt_list); i++ )
+ {
+ sb_append( &data->prompt_buff, (wchar_t *)al_get( &prompt_list, i ) );
++ if (i + 1 < al_get_count( &prompt_list))
++ {
++ sb_append( &data->prompt_buff, L"\n" );
++ }
+ }
+
+ al_foreach( &prompt_list, &free );
diff --git a/app-shells/fish/fish-1.23.1-r2.ebuild b/app-shells/fish/fish-1.23.1-r2.ebuild
new file mode 100644
index 000000000000..86611821b311
--- /dev/null
+++ b/app-shells/fish/fish-1.23.1-r2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/fish-1.23.1-r2.ebuild,v 1.1 2011/11/12 12:18:03 xmw Exp $
+
+EAPI="4"
+
+inherit base autotools eutils
+
+DESCRIPTION="fish is the Friendly Interactive SHell"
+HOMEPAGE="http://fishshell.com/"
+SRC_URI="http://fishshell.com/files/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="X vanilla"
+
+DEPEND="sys-libs/ncurses
+ sys-devel/bc
+ sys-devel/gettext
+ www-client/htmlview
+ X? ( x11-misc/xsel )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.23.0-glibc-2.8.patch"
+ "${FILESDIR}/${PN}-1.22.3-gettext.patch"
+ "${FILESDIR}/${P}-gentoo-alt.patch"
+)
+
+src_prepare() {
+ base_src_prepare
+
+ if ! use vanilla ; then
+ epatch "${FILESDIR}"/${P}-fish_indent.patch
+ epatch "${FILESDIR}"/${P}-multi-line_prompts.patch
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ # Set things up for fish to be a default shell.
+ # It has to be in /bin in case /usr is unavailable.
+ # Also, all of its utilities have to be in /bin.
+ econf \
+ docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --without-xsel \
+ --bindir="${EPREFIX}"/bin
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+}
+
+pkg_postinst() {
+ elog
+ elog "To use ${PN} as your default shell, you need to add ${EPREFIX}/bin/${PN}"
+ elog "to ${EPREFIX}/etc/shells."
+ elog
+ ewarn "Many files moved to ${EROOT}usr/share/fish/completions from ${EROOT}etc/fish.d/."
+ ewarn "Delete everything in ${EROOT}etc/fish.d/ except fish_interactive.fish."
+ ewarn "Otherwise, fish won't notice updates to the installed files,"
+ ewarn "because the ones in /etc will override the new ones in /usr."
+ echo
+}