summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2015-01-01 10:31:00 +0000
committerMikle Kolyada <zlogene@gentoo.org>2015-01-01 10:31:00 +0000
commit1eedb447ff29f7990c9817394752e4c8b1690515 (patch)
tree3411b862cfb6b6c318f59143c239b8445d65b991 /app-shells
parentVersion bump for Rails 4.2. Dropped keywords tracked in bug 534186. (diff)
downloadgentoo-2-1eedb447ff29f7990c9817394752e4c8b1690515.tar.gz
gentoo-2-1eedb447ff29f7990c9817394752e4c8b1690515.tar.bz2
gentoo-2-1eedb447ff29f7990c9817394752e4c8b1690515.zip
Security cleanup
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xC42EB5D6)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/mksh/ChangeLog8
-rw-r--r--app-shells/mksh/mksh-48b.ebuild38
-rw-r--r--app-shells/mksh/mksh-49.ebuild42
-rw-r--r--app-shells/mksh/mksh-50b.ebuild42
-rw-r--r--app-shells/mksh/mksh-50c.ebuild42
5 files changed, 6 insertions, 166 deletions
diff --git a/app-shells/mksh/ChangeLog b/app-shells/mksh/ChangeLog
index b62f6013b973..313ad5299384 100644
--- a/app-shells/mksh/ChangeLog
+++ b/app-shells/mksh/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/mksh
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/mksh/ChangeLog,v 1.59 2014/10/30 09:54:45 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/mksh/ChangeLog,v 1.60 2015/01/01 10:31:00 zlogene Exp $
+
+ 01 Jan 2015; Mikle Kolyada <zlogene@gentoo.org> -mksh-48b.ebuild,
+ -mksh-49.ebuild, -mksh-50b.ebuild, -mksh-50c.ebuild:
+ Security cleanup
30 Oct 2014; Agostino Sarubbo <ago@gentoo.org> mksh-50d.ebuild:
Stable for x86, wrt bug #522416
diff --git a/app-shells/mksh/mksh-48b.ebuild b/app-shells/mksh/mksh-48b.ebuild
deleted file mode 100644
index a44928e5b20b..000000000000
--- a/app-shells/mksh/mksh-48b.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/mksh/mksh-48b.ebuild,v 1.4 2014/02/23 08:50:40 ago Exp $
-
-EAPI=4
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="MirBSD KSH Shell"
-HOMEPAGE="http://mirbsd.de/mksh"
-SRC_URI="http://www.mirbsd.org/MirOS/dist/mir/mksh/${PN}-R${PV}.tgz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
-IUSE="static"
-DEPEND="static? ( dev-libs/klibc )"
-RDEPEND=""
-S="${WORKDIR}/${PN}"
-
-src_compile() {
- tc-export CC
- # we want to build static with klibc
- if use static; then unset CC; export CC="/usr/bin/klcc"; export LDSTATIC="-static"; fi
- export CPPFLAGS="${CPPFLAGS} -DMKSH_DEFAULT_PROFILEDIR=\\\"${EPREFIX}/etc\\\""
- # we can't assume lto existing/enabled, so we add a fallback
- sh Build.sh -r -c lto || sh Rebuild.sh || die
-}
-
-src_install() {
- exeinto /bin
- doexe mksh
- doman mksh.1
- dodoc dot.mkshrc
-}
-
-src_test() {
- ./test.sh || die
-}
diff --git a/app-shells/mksh/mksh-49.ebuild b/app-shells/mksh/mksh-49.ebuild
deleted file mode 100644
index d48b923a28de..000000000000
--- a/app-shells/mksh/mksh-49.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/mksh/mksh-49.ebuild,v 1.1 2014/02/06 09:37:57 polynomial-c Exp $
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="MirBSD KSH Shell"
-HOMEPAGE="http://mirbsd.de/mksh"
-SRC_URI="http://www.mirbsd.org/MirOS/dist/mir/mksh/${PN}-R${PV}.tgz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="static"
-DEPEND="static? ( dev-libs/klibc )"
-RDEPEND=""
-S="${WORKDIR}/${PN}"
-
-src_compile() {
- tc-export CC
- # we want to build static with klibc
- if use static ; then
- unset CC
- export CC="/usr/bin/klcc"
- export LDSTATIC="-static"
- fi
- export CPPFLAGS="${CPPFLAGS} -DMKSH_DEFAULT_PROFILEDIR=\\\"${EPREFIX}/etc\\\""
- # we can't assume lto existing/enabled, so we add a fallback
- sh Build.sh -r -c lto || sh Rebuild.sh || die
-}
-
-src_install() {
- exeinto /bin
- doexe mksh
- doman mksh.1
- dodoc dot.mkshrc
-}
-
-src_test() {
- ./test.sh || die
-}
diff --git a/app-shells/mksh/mksh-50b.ebuild b/app-shells/mksh/mksh-50b.ebuild
deleted file mode 100644
index 05f478591ce1..000000000000
--- a/app-shells/mksh/mksh-50b.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/mksh/mksh-50b.ebuild,v 1.1 2014/09/04 08:31:29 patrick Exp $
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="MirBSD KSH Shell"
-HOMEPAGE="http://mirbsd.de/mksh"
-SRC_URI="http://www.mirbsd.org/MirOS/dist/mir/mksh/${PN}-R${PV}.tgz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="static"
-DEPEND="static? ( dev-libs/klibc )"
-RDEPEND=""
-S="${WORKDIR}/${PN}"
-
-src_compile() {
- tc-export CC
- # we want to build static with klibc
- if use static ; then
- unset CC
- export CC="/usr/bin/klcc"
- export LDSTATIC="-static"
- fi
- export CPPFLAGS="${CPPFLAGS} -DMKSH_DEFAULT_PROFILEDIR=\\\"${EPREFIX}/etc\\\""
- # we can't assume lto existing/enabled, so we add a fallback
- sh Build.sh -r -c lto || sh Rebuild.sh || die
-}
-
-src_install() {
- exeinto /bin
- doexe mksh
- doman mksh.1
- dodoc dot.mkshrc
-}
-
-src_test() {
- ./test.sh || die
-}
diff --git a/app-shells/mksh/mksh-50c.ebuild b/app-shells/mksh/mksh-50c.ebuild
deleted file mode 100644
index 57112dd8a84e..000000000000
--- a/app-shells/mksh/mksh-50c.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/mksh/mksh-50c.ebuild,v 1.1 2014/10/03 21:31:55 polynomial-c Exp $
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="MirBSD KSH Shell"
-HOMEPAGE="http://mirbsd.de/mksh"
-SRC_URI="http://www.mirbsd.org/MirOS/dist/mir/mksh/${PN}-R${PV}.tgz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="static"
-DEPEND="static? ( dev-libs/klibc )"
-RDEPEND=""
-S="${WORKDIR}/${PN}"
-
-src_compile() {
- tc-export CC
- # we want to build static with klibc
- if use static ; then
- unset CC
- export CC="/usr/bin/klcc"
- export LDSTATIC="-static"
- fi
- export CPPFLAGS="${CPPFLAGS} -DMKSH_DEFAULT_PROFILEDIR=\\\"${EPREFIX}/etc\\\""
- # we can't assume lto existing/enabled, so we add a fallback
- sh Build.sh -r -c lto || sh Rebuild.sh || die
-}
-
-src_install() {
- exeinto /bin
- doexe mksh
- doman mksh.1
- dodoc dot.mkshrc
-}
-
-src_test() {
- ./test.sh || die
-}