summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-23 23:53:25 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-23 23:53:25 +0000
commita2724356ec3cf20894de0018bfb5aa08745a07e8 (patch)
tree5f8b54f4b5a33fbef91a831daef565f77c9e5b61 /app-shells
parentVersion bump for Gnome 3.14. Dropped keywords, bug #526914. (diff)
downloadgentoo-2-a2724356ec3cf20894de0018bfb5aa08745a07e8.tar.gz
gentoo-2-a2724356ec3cf20894de0018bfb5aa08745a07e8.tar.bz2
gentoo-2-a2724356ec3cf20894de0018bfb5aa08745a07e8.zip
Package a new snapshot with upstream fix for bug #528064 (and more). Update the Gentoo bundle with new patch, proper eselect module version (bug #530798) and fixed non-existing file ref (bug #532126).
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/ChangeLog10
-rw-r--r--app-shells/bash-completion/bash-completion-2.1_p20141224.ebuild93
2 files changed, 102 insertions, 1 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index 0e52aebc35bb..5673fd649da0 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-shells/bash-completion
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.277 2014/11/20 11:48:41 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.278 2014/12/23 23:53:25 mgorny Exp $
+
+*bash-completion-2.1_p20141224 (23 Dec 2014)
+
+ 23 Dec 2014; Michał Górny <mgorny@gentoo.org>
+ +bash-completion-2.1_p20141224.ebuild:
+ Package a new snapshot with upstream fix for bug #528064 (and more). Update
+ the Gentoo bundle with new patch, proper eselect module version (bug #530798)
+ and fixed non-existing file ref (bug #532126).
*bash-completion-2.1-r93 (20 Nov 2014)
diff --git a/app-shells/bash-completion/bash-completion-2.1_p20141224.ebuild b/app-shells/bash-completion/bash-completion-2.1_p20141224.ebuild
new file mode 100644
index 000000000000..d82d9581c745
--- /dev/null
+++ b/app-shells/bash-completion/bash-completion-2.1_p20141224.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-2.1_p20141224.ebuild,v 1.1 2014/12/23 23:53:25 mgorny Exp $
+
+EAPI=5
+
+BASHCOMP_P=bashcomp-2.0.1
+inherit versionator
+
+DESCRIPTION="Programmable Completion for bash"
+HOMEPAGE="http://bash-completion.alioth.debian.org/"
+SRC_URI="http://dev.gentoo.org/~mgorny/dist/${P}.tar.xz
+ http://dev.gentoo.org/~mgorny/dist/${BASHCOMP_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris"
+IUSE=""
+
+RDEPEND=">=app-shells/bash-4.3_p30-r1
+ sys-apps/miscfiles
+ !app-admin/eselect-bashcomp"
+DEPEND="app-arch/xz-utils"
+PDEPEND=">=app-shells/gentoo-bashcomp-20140911"
+
+# Remove unwanted completions.
+STRIP_COMPLETIONS=(
+ # Slackware package stuff, quite generic names cause collisions
+ # (e.g. with sys-apps/pacman)
+ explodepkg installpkg makepkg pkgtool removepkg upgradepkg
+
+ # Debian/Red Hat network stuff
+ ifdown ifup ifstatus
+
+ # Installed in app-editors/vim-core
+ xxd
+
+ # Now-dead symlinks to deprecated completions
+ hd ncal
+)
+
+src_prepare() {
+ epatch "${WORKDIR}/${BASHCOMP_P}/${P}"-*.patch
+}
+
+src_test() { :; } # Skip testsuite because of interactive shell wrt #477066
+
+src_install() {
+ # work-around race conditions, bug #526996
+ mkdir -p "${ED}"/usr/share/bash-completion/{completions,helpers} || die
+
+ emake DESTDIR="${D}" profiledir=/etc/bash/bashrc.d install
+
+ local file
+ for file in "${STRIP_COMPLETIONS[@]}"; do
+ rm "${ED}"/usr/share/bash-completion/completions/${file} || die
+ done
+ # remove deprecated completions (moved to other packages)
+ rm "${ED}"/usr/share/bash-completion/completions/_* || die
+
+ dodoc AUTHORS CHANGES README
+
+ # install the eselect module
+ insinto /usr/share/eselect/modules
+ doins "${WORKDIR}/${BASHCOMP_P}/bashcomp.eselect"
+ doman "${WORKDIR}/${BASHCOMP_P}/bashcomp.eselect.5"
+}
+
+pkg_postinst() {
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 2.1-r90 ${v}; then
+ ewarn "For bash-completion autoloader to work, all completions need to"
+ ewarn "be installed in /usr/share/bash-completion/completions. You may"
+ ewarn "need to rebuild packages that installed completions in the old"
+ ewarn "location. You can do this using:"
+ ewarn
+ ewarn "$ find ${EPREFIX}/usr/share/bash-completion -maxdepth 1 -type f '!' -name 'bash_completion' -exec emerge -1v {} +"
+ ewarn
+ ewarn "After the rebuild, you should remove the old setup symlinks:"
+ ewarn
+ ewarn "$ find ${EPREFIX}/etc/bash_completion.d -type l -delete"
+ fi
+ done
+
+ if has_version 'app-shells/zsh'; then
+ elog
+ elog "If you are interested in using the provided bash completion functions with"
+ elog "zsh, valuable tips on the effective use of bashcompinit are available:"
+ elog " http://www.zsh.org/mla/workers/2003/msg00046.html"
+ elog
+ fi
+}