summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-22 00:17:35 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-22 00:17:35 +0000
commitaff526e0a6df8c89b9094fb60afabb9daa221781 (patch)
treeb366858f8d0df2cd6a1d27d999ab10bf068ca0a7 /app-shells
parentVersion bump. (diff)
downloadgentoo-2-aff526e0a6df8c89b9094fb60afabb9daa221781.tar.gz
gentoo-2-aff526e0a6df8c89b9094fb60afabb9daa221781.tar.bz2
gentoo-2-aff526e0a6df8c89b9094fb60afabb9daa221781.zip
Grab patches from upstream to fix #115142.
(Portage version: 2.0.53)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog7
-rw-r--r--app-shells/bash/bash-3.1-r1.ebuild144
-rw-r--r--app-shells/bash/files/digest-bash-3.1-r13
3 files changed, 153 insertions, 1 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 3dbdf439b6f3..c65481c0b43c 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.80 2005/12/10 21:57:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.81 2005/12/22 00:17:35 vapier Exp $
+
+*bash-3.1-r1 (22 Dec 2005)
+
+ 22 Dec 2005; Mike Frysinger <vapier@gentoo.org> +bash-3.1-r1.ebuild:
+ Grab patches from upstream to fix #115142.
*bash-3.1 (10 Dec 2005)
diff --git a/app-shells/bash/bash-3.1-r1.ebuild b/app-shells/bash/bash-3.1-r1.ebuild
new file mode 100644
index 000000000000..0fc3835750c9
--- /dev/null
+++ b/app-shells/bash/bash-3.1-r1.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.1-r1.ebuild,v 1.1 2005/12/22 00:17:35 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+# Official patchlevel
+# See ftp://ftp.cwru.edu/pub/bash/bash-3.1-patches/
+PLEVEL=1
+READLINE_VER=5.1
+READLINE_PLEVEL=1
+
+DESCRIPTION="The standard GNU Bourne again shell"
+HOMEPAGE="http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
+# Hit the GNU mirrors before hitting Chet's site
+SRC_URI="mirror://gnu/bash/${P}.tar.gz
+ ftp://ftp.cwru.edu/pub/bash/${P}.tar.gz
+ $(for ((i=1; i<=PLEVEL; i++)); do
+ printf 'ftp://ftp.cwru.edu/pub/bash/bash-%s-patches/bash%s-%03d\n' \
+ ${PV} ${PV/\.} ${i}
+ printf 'mirror://gnu/bash/bash-%s-patches/bash%s-%03d\n' \
+ ${PV} ${PV/\.} ${i}
+ done)
+ $(for ((i=1; i<=READLINE_PLEVEL; i++)); do
+ printf 'ftp://ftp.cwru.edu/pub/bash/readline-%s-patches/readline%s-%03d\n' \
+ ${READLINE_VER} ${READLINE_VER/\.} ${i}
+ printf 'mirror://gnu/bash/readline-%s-patches/readline%s-%03d\n' \
+ ${READLINE_VER} ${READLINE_VER/\.} ${i}
+ done)"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="afs nls build bashlogger unicode"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.1-gentoo.patch
+
+ # Include official patches
+ local i
+ for ((i=1; i<=PLEVEL; i++)); do
+ epatch "${DISTDIR}"/${PN}${PV/\.}-$(printf '%03d' ${i})
+ done
+ cd lib/readline
+ for ((i=1; i<=READLINE_PLEVEL; i++)); do
+ epatch "${DISTDIR}"/readline${READLINE_VER/\.}-$(printf '%03d' ${i})
+ done
+ cd ../..
+
+ # Fall back to /etc/inputrc
+ epatch "${FILESDIR}"/${PN}-3.0-etc-inputrc.patch
+ # Add more ulimit options (from Fedora)
+ epatch "${FILESDIR}"/${P}-ulimit.patch
+ # Fix a memleak in read_builtin (from Fedora)
+ epatch "${FILESDIR}"/${PN}-3.0-read-memleak.patch
+ # Don't barf on handled signals in scripts
+ epatch "${FILESDIR}"/${PN}-3.0-trap-fg-signals.patch
+# # Fix generation of signals list when cross-compiling
+# epatch "${FILESDIR}"/${PN}-3.0-cross-signals.patch
+ # Log bash commands to syslog #91327
+ if use bashlogger ; then
+ echo
+ ewarn "The logging patch should ONLY be used in restricted (i.e. honeypot) envs."
+ ewarn "This will log ALL output you enter into the shell, you have been warned."
+ ebeep
+ epause
+ epatch "${FILESDIR}"/${PN}-3.1-bash-logger.patch
+ fi
+
+ epatch "${FILESDIR}"/${PN}-3.0-configs.patch
+
+ sed -i 's:-lcurses:-lncurses:' configure || die "sed configure"
+}
+
+src_compile() {
+ filter-flags -malign-double
+
+ local myconf=
+
+ # Always use the buildin readline, else if we update readline
+ # bash gets borked as readline is usually not binary compadible
+ # between minor versions.
+ #myconf="${myconf} $(use_with !readline installed-readline)"
+ myconf="${myconf} --without-installed-readline"
+
+ # Don't even think about building this statically without
+ # reading Bug 7714 first. If you still build it statically,
+ # don't come crying to use with bugs ;).
+ #use static && export LDFLAGS="${LDFLAGS} -static"
+ use nls || myconf="${myconf} --disable-nls"
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses
+ export bash_cv_termcap_lib=libcurses
+ myconf="${myconf} --with-ncurses"
+
+ econf \
+ $(use_with afs) \
+ --disable-profiling \
+ --without-gnu-malloc \
+ ${myconf} || die
+ emake -j1 || die "make failed" # see bug 102426
+}
+
+src_install() {
+ einstall || die
+
+ dodir /bin
+ mv "${D}"/usr/bin/bash "${D}"/bin/
+ [[ ${USERLAND} != "BSD" ]] && dosym bash /bin/sh
+ dosym bash /bin/rbash
+
+ insinto /etc/bash
+ doins "${FILESDIR}"/{bashrc,bash_logout}
+ insinto /etc/skel
+ for f in bash{_logout,_profile,rc} ; do
+ newins "${FILESDIR}"/dot-${f} .${f}
+ done
+
+ if use build ; then
+ rm -rf "${D}"/usr
+ else
+ doman doc/*.1
+ dodoc README NEWS AUTHORS CHANGES COMPAT Y2K doc/FAQ doc/INTRO
+ dosym bash.info.gz /usr/share/info/bashref.info.gz
+ fi
+}
+
+pkg_preinst() {
+ if [[ -e ${ROOT}/etc/bashrc ]] && [[ ! -d ${ROOT}/etc/bash ]] ; then
+ mkdir -p "${ROOT}"/etc/bash
+ mv -f "${ROOT}"/etc/bashrc "${ROOT}"/etc/bash/
+ fi
+
+ # our bash_logout is just a place holder so dont
+ # force users to go through etc-update all the time
+ if [[ -e ${ROOT}/etc/bash/bash_logout ]] ; then
+ rm -f "${D}"/etc/bash/bash_logout
+ fi
+}
diff --git a/app-shells/bash/files/digest-bash-3.1-r1 b/app-shells/bash/files/digest-bash-3.1-r1
new file mode 100644
index 000000000000..337b1b5cc017
--- /dev/null
+++ b/app-shells/bash/files/digest-bash-3.1-r1
@@ -0,0 +1,3 @@
+MD5 ef5304c4b22aaa5088972c792ed45d72 bash-3.1.tar.gz 2533934
+MD5 c0d33bdfed6e4e6a9ae9200b77cd5c99 bash31-001 2708
+MD5 63faf622820ca0828131c8b5aeac1e6a readline51-001 2042