summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-11-05 18:45:54 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-11-05 18:45:54 +0000
commitb07ea28186bddba87abfc180862b18af44052a1b (patch)
treef0fd8db14d7746dffc4bf74d8e7d2fa35c6bbf17 /app-shells
parentunmask gnome for testing (diff)
downloadgentoo-2-b07ea28186bddba87abfc180862b18af44052a1b.tar.gz
gentoo-2-b07ea28186bddba87abfc180862b18af44052a1b.tar.bz2
gentoo-2-b07ea28186bddba87abfc180862b18af44052a1b.zip
Revision bump; fix install of args that are a relative path.
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion-config/ChangeLog9
-rw-r--r--app-shells/bash-completion-config/Manifest9
-rw-r--r--app-shells/bash-completion-config/bash-completion-config-0.4-r1.ebuild41
-rw-r--r--app-shells/bash-completion-config/files/0.4-r1_fix-relative-path-install.diff42
-rw-r--r--app-shells/bash-completion-config/files/digest-bash-completion-config-0.4-r11
5 files changed, 98 insertions, 4 deletions
diff --git a/app-shells/bash-completion-config/ChangeLog b/app-shells/bash-completion-config/ChangeLog
index ec58daa9db7f..846da73e4bd8 100644
--- a/app-shells/bash-completion-config/ChangeLog
+++ b/app-shells/bash-completion-config/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/bash-completion-config
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion-config/ChangeLog,v 1.10 2004/11/04 17:29:54 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion-config/ChangeLog,v 1.11 2004/11/05 18:45:54 ka0ttic Exp $
+
+*bash-completion-config-0.4-r1 (05 Nov 2004)
+
+ 05 Nov 2004; Aaron Walker <ka0ttic@gentoo.org>
+ +files/0.4-r1_fix-relative-path-install.diff,
+ +bash-completion-config-0.4-r1.ebuild:
+ Revision bump; fix install of args that are a relative path.
04 Nov 2004; Markus Rothe <corsair@gentoo.org>
bash-completion-config-0.4.ebuild:
diff --git a/app-shells/bash-completion-config/Manifest b/app-shells/bash-completion-config/Manifest
index 1bc0497fcf46..316e0888a9cc 100644
--- a/app-shells/bash-completion-config/Manifest
+++ b/app-shells/bash-completion-config/Manifest
@@ -1,8 +1,11 @@
-MD5 12956455e900a2c850bf10e7c46807a3 ChangeLog 1778
+MD5 a509ee3fdbf96aa382a7dfba1fc8c8cb bash-completion-config-0.4-r1.ebuild 1154
+MD5 43afbf4c33b1541c504e55fc14309838 bash-completion-config-0.3.ebuild 1030
MD5 21ec12e910d1fce7b411939e3ea1f9fb bash-completion-config-0.2.ebuild 1124
+MD5 2e024cc1d6a41b27ea3ab566857d0179 ChangeLog 2026
MD5 99ce5509db4b50f28a1f6675f8c09b2b metadata.xml 258
-MD5 43afbf4c33b1541c504e55fc14309838 bash-completion-config-0.3.ebuild 1030
MD5 1a5b42a2ad08f8d81b09e70fd69b3568 bash-completion-config-0.4.ebuild 1040
-MD5 056262600c205cc61bdf6b59918cedb2 files/digest-bash-completion-config-0.3 71
MD5 c7ae0ecb11005614eebcc3915cc8b0aa files/digest-bash-completion-config-0.2 71
+MD5 056262600c205cc61bdf6b59918cedb2 files/digest-bash-completion-config-0.3 71
MD5 bdb3858021e2314c9f5414d05cc12b7f files/digest-bash-completion-config-0.4 71
+MD5 bdb3858021e2314c9f5414d05cc12b7f files/digest-bash-completion-config-0.4-r1 71
+MD5 20b30d38aa0dc256e11aac18d548bfbb files/0.4-r1_fix-relative-path-install.diff 1432
diff --git a/app-shells/bash-completion-config/bash-completion-config-0.4-r1.ebuild b/app-shells/bash-completion-config/bash-completion-config-0.4-r1.ebuild
new file mode 100644
index 000000000000..62573c8ebfd5
--- /dev/null
+++ b/app-shells/bash-completion-config/bash-completion-config-0.4-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion-config/bash-completion-config-0.4-r1.ebuild,v 1.1 2004/11/05 18:45:54 ka0ttic Exp $
+
+inherit eutils
+
+MY_PN="bashcomp-config"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Utility to easily add/remove bash-completions to your environment"
+HOMEPAGE="http://developer.berlios.de/projects/bashcomp-config/"
+SRC_URI="http://download.berlios.de/${MY_PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~s390 ~x86 ~mips ~sparc ~ppc ~ppc-macos ~ppc64"
+IUSE=""
+
+RDEPEND=">=app-shells/bash-2.05"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PVR}_fix-relative-path-install.diff
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS TODO ChangeLog README
+}
+
+pkg_postinst() {
+ echo
+ einfo "To enable command-line completion for bash-completion-config,"
+ einfo "run the following as root:"
+ einfo
+ einfo " bash-completion-config --global --install bash-completion-config"
+ echo
+}
diff --git a/app-shells/bash-completion-config/files/0.4-r1_fix-relative-path-install.diff b/app-shells/bash-completion-config/files/0.4-r1_fix-relative-path-install.diff
new file mode 100644
index 000000000000..cc503a3c1a05
--- /dev/null
+++ b/app-shells/bash-completion-config/files/0.4-r1_fix-relative-path-install.diff
@@ -0,0 +1,42 @@
+--- bash-completion-config.in.r50 2004-11-05 11:44:07.534197154 -0500
++++ bash-completion-config.in 2004-11-05 11:44:14.908265230 -0500
+@@ -1,7 +1,7 @@
+ #!%BASH%
+ # Copyright 1999-2004 Gentoo Foundation
+ # Distributed under the terms of the GNU General Public License v2
+-# $Id: 0.4-r1_fix-relative-path-install.diff,v 1.1 2004/11/05 18:45:54 ka0ttic Exp $
++# $Id: 0.4-r1_fix-relative-path-install.diff,v 1.1 2004/11/05 18:45:54 ka0ttic Exp $
+ #
+ # Author: Aaron Walker <ka0ttic@gentoo.org>
+
+@@ -275,10 +275,26 @@
+ header
+ for bashcomp in "$@" ; do
+ [[ "${bashcomp}" == -* ]] && continue;
+-
+- file="$BASHCOMP_DIR/${bashcomp##*/}"
+- [[ "${bashcomp}" == */* ]] && file=$bashcomp # a path was given
+-
++
++ # what form is the argument in?
++ case "${bashcomp}" in
++ /*) # absolute path
++ file="$bashcomp" ;;
++
++ */*) # relative path
++ file="$PWD/$bashcomp" ;;
++
++ *) # just the name
++ # CWD
++ if [ -f "${bashcomp}" ] ; then
++ file="$PWD/$bashcomp"
++ # assume BASHCOMP_DIR
++ else
++ file="$BASHCOMP_DIR/$bashcomp"
++ fi
++ ;;
++ esac
++
+ if [ ! -e "${file}" ] ; then
+ ewarn "${file##*/} doesn't seem to exist"
+ continue
diff --git a/app-shells/bash-completion-config/files/digest-bash-completion-config-0.4-r1 b/app-shells/bash-completion-config/files/digest-bash-completion-config-0.4-r1
new file mode 100644
index 000000000000..88c3ace0f548
--- /dev/null
+++ b/app-shells/bash-completion-config/files/digest-bash-completion-config-0.4-r1
@@ -0,0 +1 @@
+MD5 479a61889bf897c2f4d412eb9c892a80 bashcomp-config-0.4.tar.bz2 92312