summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-11-04 12:25:30 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-11-04 12:25:30 +0000
commit8339c45855c0cae23f65367856885aacb2c4b5b6 (patch)
tree28443e83f0cb1e8cc20564b2381d3f7301f5b55e /app-text/a2ps
parentx86 stable per bug 340070 (diff)
downloadgentoo-2-8339c45855c0cae23f65367856885aacb2c4b5b6.tar.gz
gentoo-2-8339c45855c0cae23f65367856885aacb2c4b5b6.tar.bz2
gentoo-2-8339c45855c0cae23f65367856885aacb2c4b5b6.zip
Fixed cleanup patch for LINGUAS="ja", bug #335803.
(Portage version: 2.1.9.22/cvs/Linux x86_64)
Diffstat (limited to 'app-text/a2ps')
-rw-r--r--app-text/a2ps/ChangeLog6
-rw-r--r--app-text/a2ps/a2ps-4.14-r1.ebuild12
-rw-r--r--app-text/a2ps/files/a2ps-4.14-ja-cleanup.patch122
3 files changed, 135 insertions, 5 deletions
diff --git a/app-text/a2ps/ChangeLog b/app-text/a2ps/ChangeLog
index 93a3d08eb404..3f7f342f41e0 100644
--- a/app-text/a2ps/ChangeLog
+++ b/app-text/a2ps/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/a2ps
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/ChangeLog,v 1.95 2010/09/27 20:24:48 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/ChangeLog,v 1.96 2010/11/04 12:25:30 matsuu Exp $
+
+ 04 Nov 2010; MATSUU Takuto <matsuu@gentoo.org> a2ps-4.14-r1.ebuild,
+ +files/a2ps-4.14-ja-cleanup.patch:
+ Fixed cleanup patch for LINGUAS="ja", bug #335803.
27 Sep 2010; Jeroen Roovers <jer@gentoo.org> a2ps-4.14-r1.ebuild:
Stable for HPPA (bug #322867).
diff --git a/app-text/a2ps/a2ps-4.14-r1.ebuild b/app-text/a2ps/a2ps-4.14-r1.ebuild
index 8d89d2170118..6f6d16218bf5 100644
--- a/app-text/a2ps/a2ps-4.14-r1.ebuild
+++ b/app-text/a2ps/a2ps-4.14-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/a2ps-4.14-r1.ebuild,v 1.9 2010/09/27 20:24:48 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/a2ps-4.14-r1.ebuild,v 1.10 2010/11/04 12:25:30 matsuu Exp $
inherit eutils autotools elisp-common
@@ -44,7 +44,13 @@ src_unpack() {
# this will break
#epatch "${FILESDIR}/${PN}-4.13c-stdarg.patch"
use vanilla || epatch "${FILESDIR}/${PN}-4.13-stdout.diff"
- use linguas_ja && epatch "${DISTDIR}/${P}-ja_nls.patch.gz"
+ if use linguas_ja ; then
+ epatch "${DISTDIR}/${P}-ja_nls.patch.gz"
+ # bug #335803
+ epatch "${FILESDIR}/${P}-ja-cleanup.patch"
+ else
+ epatch "${FILESDIR}/${P}-cleanup.patch"
+ fi
# fix fnmatch replacement, bug #134546
epatch "${FILESDIR}/${PN}-4.13c-fnmatch-replacement.patch"
@@ -67,8 +73,6 @@ src_unpack() {
# fix compilation error due to obstack.h issue, bug 269638
epatch "${FILESDIR}/${P}-ptrdiff_t.patch"
- epatch "${FILESDIR}"/${P}-cleanup.patch
-
eautoreconf
}
diff --git a/app-text/a2ps/files/a2ps-4.14-ja-cleanup.patch b/app-text/a2ps/files/a2ps-4.14-ja-cleanup.patch
new file mode 100644
index 000000000000..16271b3ec674
--- /dev/null
+++ b/app-text/a2ps/files/a2ps-4.14-ja-cleanup.patch
@@ -0,0 +1,122 @@
+diff --git lib/argmatch.c lib/argmatch.c
+index f983e9d..eadc7ea 100644
+--- lib/argmatch.c
++++ lib/argmatch.c
+@@ -21,6 +21,7 @@
+ #include "argmatch.h"
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #ifdef STDC_HEADERS
+ # include <string.h>
+ #endif
+diff --git lib/encoding.c lib/encoding.c
+index 9bd9f2a..f554a6d 100644
+--- lib/encoding.c
++++ lib/encoding.c
+@@ -989,7 +989,7 @@ dump_encoding_setup (FILE * stream,
+ /* Create the dictionary and fill it */
+ fprintf (stream, "%% Dictionary for %s support\n",
+ encoding->name);
+- fprintf (stream, "/%sdict %d dict begin\n", encoding->key,
++ fprintf (stream, "/%sdict %zu dict begin\n", encoding->key,
+ (encoding->composite_flag == true)? nb+nb+ns:nb+ns);
+ for (i = 0 ; i < nb ; i++)
+ fprintf (stream, " /f%s %sEncoding /%s reencode_font\n",
+diff --git lib/output.c lib/output.c
+index b5fc37d..5f67676 100644
+--- lib/output.c
++++ lib/output.c
+@@ -84,7 +84,7 @@ new_derivation (enum derivation_type type)
+ static void
+ derivation_self_print (struct derivation * derivation, FILE * stream)
+ {
+- fprintf (stream, "At %x: ", (int) derivation);
++ fprintf (stream, "At %p: ", derivation);
+ switch (derivation->type)
+ {
+ case nothing:
+@@ -525,7 +525,7 @@ output_file (struct output * out, a2ps_job * job,
+ expand_user_string (job, FIRST_FILE (job),
+ (const uchar *) "Expand: requirement",
+ (const uchar *) token));
+- output (dest, expansion);
++ output (dest, "%s", expansion);
+ continue;
+ }
+
+diff --git lib/parseppd.y lib/parseppd.y
+index a7558ba..c89d188 100644
+--- lib/parseppd.y
++++ lib/parseppd.y
+@@ -154,7 +154,7 @@ font_clause :
+ void
+ yyerror (const char *msg)
+ {
+- error_at_line (1, 0, ppdfilename, ppdlineno, msg);
++ error_at_line (1, 0, ppdfilename, ppdlineno, "%s", msg);
+ }
+
+ /*
+diff --git lib/psgen.c lib/psgen.c
+index 9eeef74..9d7a27d 100644
+--- lib/psgen.c
++++ lib/psgen.c
+@@ -232,7 +232,7 @@ output_marker (a2ps_job * job, const char * kind, uchar * marker)
+ default:
+ *buf = '\0';
+ ps_escape_char (job, cp[i], buf);
+- output (jdiv, (char *) buf);
++ output (jdiv, "%s", buf);
+ break;
+ }
+ }
+diff --git lib/quotearg.c lib/quotearg.c
+index 16d0b91..89db991 100644
+--- lib/quotearg.c
++++ lib/quotearg.c
+@@ -60,6 +60,7 @@
+
+ #if HAVE_MBRTOWC && HAVE_WCHAR_H
+ # include <wchar.h>
++# include <wctype.h>
+ #else
+ # define iswprint(wc) 1
+ # define mbrtowc(pwc, s, n, ps) 1
+diff --git lib/title.c lib/title.c
+index cf4a34b..7a3e87b 100644
+--- lib/title.c
++++ lib/title.c
+@@ -28,6 +28,7 @@
+ #endif
+
+ #include <stdio.h>
++#include <string.h>
+
+ #if HAVE_VPRINTF || HAVE_DOPRNT || _LIBC
+ # if __STDC__
+diff --git src/long-options.c src/long-options.c
+index fb40cd9..7bd77b0 100644
+--- src/long-options.c
++++ src/long-options.c
+@@ -22,6 +22,7 @@
+ #endif
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <getopt.h>
+ #include "closeout.h"
+ #include "long-options.h"
+diff --git src/parsessh.y src/parsessh.y
+index 21e9559..569fdb6 100644
+--- src/parsessh.y
++++ src/parsessh.y
+@@ -740,7 +740,7 @@ exception_def_opt:
+ void
+ yyerror (const char *msg)
+ {
+- error_at_line (1, 0, sshfilename, sshlineno, msg);
++ error_at_line (1, 0, sshfilename, sshlineno, "%s", msg);
+ }
+
+ /*