summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-01-10 20:39:43 +0000
committerUlrich Müller <ulm@gentoo.org>2011-01-10 20:39:43 +0000
commitb4eeee681778fef94b6cb9d87c052fa53127a628 (patch)
tree436b5f34c6fdc1811808244f5019697c7b0344d3 /app-text/a2ps
parentstable ppc, bug 343569 (diff)
downloadgentoo-2-b4eeee681778fef94b6cb9d87c052fa53127a628.tar.gz
gentoo-2-b4eeee681778fef94b6cb9d87c052fa53127a628.tar.bz2
gentoo-2-b4eeee681778fef94b6cb9d87c052fa53127a628.zip
Fix regression wrt Emacs support, bug 350451.
(Portage version: 2.1.9.30/cvs/Linux x86_64)
Diffstat (limited to 'app-text/a2ps')
-rw-r--r--app-text/a2ps/ChangeLog9
-rw-r--r--app-text/a2ps/a2ps-4.14-r2.ebuild119
-rw-r--r--app-text/a2ps/files/50a2ps-gentoo.el3
3 files changed, 126 insertions, 5 deletions
diff --git a/app-text/a2ps/ChangeLog b/app-text/a2ps/ChangeLog
index 459617301585..9f48c7dc7026 100644
--- a/app-text/a2ps/ChangeLog
+++ b/app-text/a2ps/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/a2ps
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/ChangeLog,v 1.97 2010/12/02 01:15:47 flameeyes Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/ChangeLog,v 1.98 2011/01/10 20:39:43 ulm Exp $
+
+*a2ps-4.14-r2 (10 Jan 2011)
+
+ 10 Jan 2011; Ulrich Mueller <ulm@gentoo.org> +a2ps-4.14-r2.ebuild:
+ Fix regression wrt Emacs support, bug 350451.
02 Dec 2010; Diego E. Pettenò <flameeyes@gentoo.org> a2ps-4.13c-r6.ebuild:
Drop WANT_AUTOMAKE=latest.
diff --git a/app-text/a2ps/a2ps-4.14-r2.ebuild b/app-text/a2ps/a2ps-4.14-r2.ebuild
new file mode 100644
index 000000000000..feb9bbf208a3
--- /dev/null
+++ b/app-text/a2ps/a2ps-4.14-r2.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/a2ps-4.14-r2.ebuild,v 1.1 2011/01/10 20:39:43 ulm Exp $
+
+inherit eutils autotools elisp-common
+
+DESCRIPTION="Any to PostScript filter"
+HOMEPAGE="http://www.inf.enst.fr/~demaille/a2ps/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
+ linguas_ja? ( mirror://gentoo/${P}-ja_nls.patch.gz )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="emacs nls latex vanilla userland_BSD userland_GNU linguas_ja"
+
+RESTRICT="test"
+
+DEPEND=">=dev-util/gperf-2.7.2
+ || ( >=dev-util/yacc-1.9.1 sys-devel/bison )
+ app-text/ghostscript-gpl
+ >=app-text/psutils-1.17
+ emacs? ( virtual/emacs )
+ latex? ( virtual/latex-base )
+ nls? ( sys-devel/gettext )"
+RDEPEND="app-text/ghostscript-gpl
+ app-text/wdiff
+ userland_GNU? ( || ( >=sys-apps/coreutils-6.10-r1 sys-apps/mktemp ) )
+ userland_BSD? ( sys-freebsd/freebsd-ubin )
+ >=app-text/psutils-1.17
+ emacs? ( virtual/emacs )
+ latex? ( virtual/latex-base )
+ nls? ( virtual/libintl )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+S="${WORKDIR}/${PN}-${PV:0:4}"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-4.13c-locale-gentoo.diff"
+ # this will break
+ #epatch "${FILESDIR}/${PN}-4.13c-stdarg.patch"
+ use vanilla || epatch "${FILESDIR}/${PN}-4.13-stdout.diff"
+ if use linguas_ja ; then
+ epatch "${DISTDIR}/${P}-ja_nls.patch.gz"
+ # bug #335803
+ epatch "${FILESDIR}/${P}-ja-cleanup.patch"
+ else
+ epatch "${FILESDIR}/${P}-cleanup.patch"
+ fi
+
+ # fix fnmatch replacement, bug #134546
+ epatch "${FILESDIR}/${PN}-4.13c-fnmatch-replacement.patch"
+
+ # bug #122026
+ epatch "${FILESDIR}/${P}-psset.patch"
+
+ # fix emacs printing, bug #114627
+ epatch "${FILESDIR}/a2ps-4.13c-emacs.patch"
+
+ # fix chmod error, #167670
+ epatch "${FILESDIR}/a2ps-4.13-manpage-chmod.patch"
+
+ # add configure check for mempcpy, bug 216588
+ epatch "${FILESDIR}/${P}-check-mempcpy.patch"
+
+ # fix compilation error due to invalid stpcpy() prototype, bug 216588
+ epatch "${FILESDIR}/${P}-fix-stpcpy-proto.patch"
+
+ # fix compilation error due to obstack.h issue, bug 269638
+ epatch "${FILESDIR}/${P}-ptrdiff_t.patch"
+
+ eautoreconf
+}
+
+src_compile() {
+ local myconf="COM_netscape=no COM_acroread=no"
+
+ if ! use emacs ; then
+ myconf="${myconf} EMACS=no"
+ fi
+
+ if ! use latex ; then
+ myconf="${myconf} COM_latex=no"
+ fi
+
+ export LANG=C LC_ALL=C
+
+ econf \
+ --sysconfdir=/etc/a2ps \
+ $(use_enable nls) \
+ ${myconf} || die "econf failed"
+
+ # parallel make b0rked
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ lispdir="${SITELISP}/${PN}" \
+ install || die "emake install failed"
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+
+ dodoc ANNOUNCE AUTHORS ChangeLog FAQ NEWS README* THANKS TODO
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/app-text/a2ps/files/50a2ps-gentoo.el b/app-text/a2ps/files/50a2ps-gentoo.el
index 8c7344bbfc62..3e12daaf9a4b 100644
--- a/app-text/a2ps/files/50a2ps-gentoo.el
+++ b/app-text/a2ps/files/50a2ps-gentoo.el
@@ -1,6 +1,3 @@
-
-;;; a2ps site-lisp configuration
-
(add-to-list 'load-path "@SITELISP@")
(autoload 'a2ps-mode "a2ps" nil t)
(autoload 'a2ps-buffer "a2ps-print" nil t)