summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerbie Hopkins <herbs@gentoo.org>2006-01-12 12:51:22 +0000
committerHerbie Hopkins <herbs@gentoo.org>2006-01-12 12:51:22 +0000
commit74b8bce92c5dd58b4b797dfc6d3e14bbbe2e5cbc (patch)
tree2f93a459c0c78bb8c1bd9c6915689d4714cf720b /app-text/acroread
parentDeps should be on ruby packages and not directly on the databases. Also, mar... (diff)
downloadgentoo-2-74b8bce92c5dd58b4b797dfc6d3e14bbbe2e5cbc.tar.gz
gentoo-2-74b8bce92c5dd58b4b797dfc6d3e14bbbe2e5cbc.tar.bz2
gentoo-2-74b8bce92c5dd58b4b797dfc6d3e14bbbe2e5cbc.zip
Add binary libcups.so to avoid unconditionaly depending on cups.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'app-text/acroread')
-rw-r--r--app-text/acroread/ChangeLog9
-rw-r--r--app-text/acroread/Manifest14
-rw-r--r--app-text/acroread/acroread-7.0.5-r1.ebuild97
-rw-r--r--app-text/acroread/files/digest-acroread-7.0.5-r16
4 files changed, 114 insertions, 12 deletions
diff --git a/app-text/acroread/ChangeLog b/app-text/acroread/ChangeLog
index 7cf9ec4ab9ed..b47b19ac86e6 100644
--- a/app-text/acroread/ChangeLog
+++ b/app-text/acroread/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/acroread
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/ChangeLog,v 1.66 2006/01/11 11:47:57 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/ChangeLog,v 1.67 2006/01/12 12:51:22 herbs Exp $
+
+*acroread-7.0.5-r1 (12 Jan 2006)
+
+ 12 Jan 2006; Herbie Hopkins <herbs@gentoo.org> +acroread-7.0.5-r1.ebuild:
+ Add a binary libcups that's pulled in with USE=-cups to avoid unconditionaly
+ depending on cups (bug 118745). Remove the amd64 gconv workaround, this was
+ fixed in glibc a while ago.
11 Jan 2006; Herbie Hopkins <herbs@gentoo.org> acroread-7.0.5.ebuild:
Also fix the x86 deps for bug 118417 (with the ok from genstef).
diff --git a/app-text/acroread/Manifest b/app-text/acroread/Manifest
index 4eff274bc1a5..d6ab8aae24d8 100644
--- a/app-text/acroread/Manifest
+++ b/app-text/acroread/Manifest
@@ -1,19 +1,11 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 be2d8fe6b762731b90f67c9c9beebfa1 ChangeLog 12085
+MD5 17e45828ac0d61ef24a7897bbab42817 ChangeLog 12383
MD5 520bad9028981b2837696c4f7a4f84b4 acroread-5.10.ebuild 2511
MD5 7c177b350d5c17994dd80569e0fcdb22 acroread-7.0.1.1.ebuild 3439
+MD5 4097639b92938b3c5122f748ffd01f0e acroread-7.0.5-r1.ebuild 2879
MD5 8461462ce3069335bc32373c453e16a5 acroread-7.0.5.ebuild 2679
MD5 00414d6be2296740cc5225ca93a3d035 files/acroread-scim.patch 488
MD5 d0981fc5a58874b78a6f2a2b73d3e43d files/digest-acroread-5.10 63
MD5 56c836a11cd417c3694a90f2c1ccfef9 files/digest-acroread-7.0.1.1 1185
MD5 c7f8b023e5f98d120c27778a2b2184b7 files/digest-acroread-7.0.5 395
+MD5 a7710a4939e2b52a8c5f42df6ab4a49e files/digest-acroread-7.0.5-r1 458
MD5 26b4b081d538c195dc39bcb2ec8e6f3a metadata.xml 161
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDxPB42G5bA0cA/ScRAp8WAJ9AsU9BcxZyq7Coj3MX2itDL1s2qgCeNhAF
-bMJ9ax9QMDAeha4TaHA1y0U=
-=InHf
------END PGP SIGNATURE-----
diff --git a/app-text/acroread/acroread-7.0.5-r1.ebuild b/app-text/acroread/acroread-7.0.5-r1.ebuild
new file mode 100644
index 000000000000..43782553ed65
--- /dev/null
+++ b/app-text/acroread/acroread-7.0.5-r1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/acroread-7.0.5-r1.ebuild,v 1.1 2006/01/12 12:51:22 herbs Exp $
+
+inherit eutils nsplugins rpm versionator
+
+DESCRIPTION="Adobe's PDF reader"
+HOMEPAGE="http://www.adobe.com/products/acrobat/"
+SRC_HEAD="http://ardownload.adobe.com/pub/adobe/reader/unix/7x/7.0.5"
+SRC_FOOT="-$(replace_version_separator 3 "-")-1.i386.rpm"
+SRC_URI="nls? ( linguas_de? ( ${SRC_HEAD}/deu/AdobeReader_deu${SRC_FOOT} )
+ !linguas_de? ( linguas_fr? ( ${SRC_HEAD}/fra/AdobeReader_fra${SRC_FOOT} )
+ !linguas_fr? ( linguas_ja? ( ${SRC_HEAD}/jpn/AdobeReader_jpn${SRC_FOOT} )
+ !linguas_ja? ( linguas_ko? ( ${SRC_HEAD}/kor/AdobeReader_kor${SRC_FOOT} )
+ !linguas_ko? ( ${SRC_HEAD}/enu/AdobeReader_enu${SRC_FOOT} ) ) ) ) )
+ !nls? ( ${SRC_HEAD}/enu/AdobeReader_enu${SRC_FOOT} )
+ x86? ( !cups? ( mirror://gentoo/libcups.so-i386.bz2 ) )"
+LICENSE="Adobe"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="cups ldap nsplugin nls"
+RESTRICT="nostrip"
+
+RDEPEND="virtual/libc
+ x86? ( >=x11-libs/gtk+-2.0
+ cups? ( net-print/cups )
+ ldap? ( net-nds/openldap ) )
+ amd64? ( >=app-emulation/emul-linux-x86-baselibs-2.4.2
+ >=app-emulation/emul-linux-x86-gtklibs-2.0 )"
+PROVIDE="virtual/pdfviewer"
+
+INSTALLDIR=/opt/Acrobat7
+
+S=${WORKDIR}/usr/local/Adobe/Acrobat7.0
+
+pkg_setup() {
+ # x86 binary package, ABI=x86
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/25
+ has_multilib_profile && ABI="x86"
+}
+
+src_unpack() {
+ rpm_src_unpack
+ cd ${S}
+ epatch ${FILESDIR}/acroread-scim.patch
+}
+
+src_install() {
+ local i
+
+ cp Resource/Support/AdobeReader_KDE.desktop AdobeReader.desktop
+ domenu AdobeReader.desktop
+ doicon Resource/Icons/AdobeReader.png
+
+ dodir ${INSTALLDIR}
+ DIRS="Reader Resource"
+ for i in ${DIRS}
+ do
+ if [ -d ${i} ] ; then
+ chown -R --dereference root:0 ${i}
+ mv ${i} ${D}${INSTALLDIR}
+ fi
+ done
+
+ exeinto ${INSTALLDIR}
+ doexe bin/acroread || die "doexe failed"
+ dodoc Browser/Browser_Plugin_HowTo.txt
+
+ if use nsplugin ; then
+ exeinto /opt/netscape/plugins
+ doexe Browser/intellinux/nppdf.so
+ inst_plugin /opt/netscape/plugins/nppdf.so
+ fi
+
+ if ! use ldap ; then
+ rm ${D}${INSTALLDIR}/Reader/intellinux/plug_ins/PPKLite.api
+ fi
+
+ # libcups is needed for printing support (bug 118417)
+ if use x86 && ! use cups ; then
+ mv ${WORKDIR}/libcups.so-i386 ${WORKDIR}/libcups.so.2
+ exeinto ${INSTALLDIR}/Reader/intellinux/lib
+ doexe ${WORKDIR}/libcups.so.2
+ dosym libcups.so.2 ${INSTALLDIR}/Reader/intellinux/lib/libcups.so
+ fi
+
+ dodir /usr/bin
+ dosym ${INSTALLDIR}/acroread /usr/bin/acroread
+}
+
+pkg_postinst () {
+ # fix wrong directory permissions (bug #25931)
+ find ${INSTALLDIR} -type d | xargs chmod 755 || die
+
+ einfo "The Acrobat(TM) Security Plugin will be enabled with USE=ldap"
+ einfo "The Acrobat(TM) Browser Plugin will be enabled with USE=nsplugin"
+}
diff --git a/app-text/acroread/files/digest-acroread-7.0.5-r1 b/app-text/acroread/files/digest-acroread-7.0.5-r1
new file mode 100644
index 000000000000..a6ca414bf2de
--- /dev/null
+++ b/app-text/acroread/files/digest-acroread-7.0.5-r1
@@ -0,0 +1,6 @@
+MD5 d3066743e14de81a92e6728e83a3c79f AdobeReader_deu-7.0.5-1.i386.rpm 43768693
+MD5 f5a59ea1b7f46c347e6932d045a17f8c AdobeReader_enu-7.0.5-1.i386.rpm 38774864
+MD5 4c76496f85c30025d9dddcd3318c4e39 AdobeReader_fra-7.0.5-1.i386.rpm 43326070
+MD5 105e5c27ece8d7d46b84cc1eaf5afdd2 AdobeReader_jpn-7.0.5-1.i386.rpm 52437779
+MD5 d612c2f38e07a68ba46e3383cbd16e23 AdobeReader_kor-7.0.5-1.i386.rpm 47343485
+MD5 262fe0ef8f6de053c410e175aafa25b9 libcups.so-i386.bz2 50564