summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2010-11-14 19:28:43 +0000
committerSebastian Pipping <sping@gentoo.org>2010-11-14 19:28:43 +0000
commit36639fa39619e86a5a637a1d5bdb0cccbb7e3f23 (patch)
treee2887f317680b93ebad898df600ad31f30efbeec /app-text/asciidoc
parentalpha/ia64/sparc stable (bug #339161) (diff)
downloadgentoo-2-36639fa39619e86a5a637a1d5bdb0cccbb7e3f23.tar.gz
gentoo-2-36639fa39619e86a5a637a1d5bdb0cccbb7e3f23.tar.bz2
gentoo-2-36639fa39619e86a5a637a1d5bdb0cccbb7e3f23.zip
app-text/asciidoc: Bump to 8.6.3 (bug #339068)
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'app-text/asciidoc')
-rw-r--r--app-text/asciidoc/ChangeLog11
-rw-r--r--app-text/asciidoc/asciidoc-8.6.3.ebuild94
-rw-r--r--app-text/asciidoc/asciidoc-9999.ebuild94
3 files changed, 198 insertions, 1 deletions
diff --git a/app-text/asciidoc/ChangeLog b/app-text/asciidoc/ChangeLog
index e5cb34bc4b7c..c9eb58bdce4b 100644
--- a/app-text/asciidoc/ChangeLog
+++ b/app-text/asciidoc/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-text/asciidoc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/asciidoc/ChangeLog,v 1.63 2010/10/15 13:56:19 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/asciidoc/ChangeLog,v 1.64 2010/11/14 19:28:43 sping Exp $
+
+*asciidoc-9999 (14 Nov 2010)
+*asciidoc-8.6.3 (14 Nov 2010)
+
+ 14 Nov 2010; Sebastian Pipping <sping@gentoo.org> +asciidoc-8.6.3.ebuild,
+ +asciidoc-9999.ebuild:
+ Bump to 8.6.3 (bug #339068), migrate to a hybrid release/live ebuild.
+ Upstream is not shipping HTML docs anymore: for now we don't build them
+ downstream.
15 Oct 2010; Brent Baude <ranger@gentoo.org> asciidoc-8.5.3.ebuild:
stable ppc, bug 332577
diff --git a/app-text/asciidoc/asciidoc-8.6.3.ebuild b/app-text/asciidoc/asciidoc-8.6.3.ebuild
new file mode 100644
index 000000000000..1d42b32db267
--- /dev/null
+++ b/app-text/asciidoc/asciidoc-8.6.3.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/asciidoc/asciidoc-8.6.3.ebuild,v 1.1 2010/11/14 19:28:43 sping Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2:2.5"
+RESTRICT_PYTHON_ABIS="3.*"
+
+[ "$PV" == "9999" ] && inherit mercurial autotools
+inherit python
+
+DESCRIPTION="A text document format for writing short documents, articles, books and UNIX man pages"
+HOMEPAGE="http://www.methods.co.nz/asciidoc/"
+if [ "$PV" == "9999" ]; then
+ EHG_REPO_URI="https://asciidoc.googlecode.com/hg/"
+ SRC_URI=""
+ KEYWORDS=""
+ S=${WORKDIR}/hg
+else
+ SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples vim-syntax"
+
+RDEPEND=">=app-text/docbook-xsl-stylesheets-1.75
+ dev-libs/libxslt
+ media-gfx/graphviz
+ app-text/docbook-xml-dtd:4.5
+"
+DEPEND=""
+
+if [ "$PV" == "9999" ]; then
+ DEPEND="${DEPEND}
+ dev-util/aap
+ www-client/lynx
+ dev-util/source-highlight"
+fi
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ if ! use vim-syntax; then
+ sed -i -e '/^install/s/install-vim//' Makefile.in
+ else
+ sed -i\
+ -e "/^vimdir/s:@sysconfdir@/vim:${EPREFIX}/usr/share/vim/vimfiles:" \
+ -e 's:/etc/vim::' \
+ Makefile.in || die
+ fi
+
+ # Only needed for prefix - harmless (does nothing) otherwise
+ sed -i -e "s:^CONF_DIR=.*:CONF_DIR='${EPREFIX}/etc/asciidoc':" \
+ "${S}/asciidoc.py" || die
+
+ [ "$PV" == "9999" ] && eautoconf
+}
+
+src_configure() {
+ econf --sysconfdir="${EPREFIX}"/usr/share
+}
+
+src_compile() {
+ default
+
+ if [ "$PV" == "9999" ]; then
+ ( cd doc && aap -f main.aap ../{CHANGELOG,README,BUGS} )
+ fi
+}
+
+src_install() {
+ use vim-syntax && dodir /usr/share/vim/vimfiles
+
+ emake DESTDIR="${D}" install || die "install failed"
+
+ python_convert_shebangs -r 2 "${D}"
+
+ if use examples; then
+ # This is a symlink to a directory
+ rm examples/website/images || die
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die
+ dosym ../../../asciidoc/images /usr/share/doc/${PF}/examples || die
+ fi
+
+ dodoc BUGS CHANGELOG README docbook-xsl/asciidoc-docbook-xsl.txt \
+ dblatex/dblatex-readme.txt filters/code/code-filter-readme.txt || die
+}
diff --git a/app-text/asciidoc/asciidoc-9999.ebuild b/app-text/asciidoc/asciidoc-9999.ebuild
new file mode 100644
index 000000000000..681ea3f75030
--- /dev/null
+++ b/app-text/asciidoc/asciidoc-9999.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/asciidoc/asciidoc-9999.ebuild,v 1.1 2010/11/14 19:28:43 sping Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2:2.5"
+RESTRICT_PYTHON_ABIS="3.*"
+
+[ "$PV" == "9999" ] && inherit mercurial autotools
+inherit python
+
+DESCRIPTION="A text document format for writing short documents, articles, books and UNIX man pages"
+HOMEPAGE="http://www.methods.co.nz/asciidoc/"
+if [ "$PV" == "9999" ]; then
+ EHG_REPO_URI="https://asciidoc.googlecode.com/hg/"
+ SRC_URI=""
+ KEYWORDS=""
+ S=${WORKDIR}/hg
+else
+ SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples vim-syntax"
+
+RDEPEND=">=app-text/docbook-xsl-stylesheets-1.75
+ dev-libs/libxslt
+ media-gfx/graphviz
+ app-text/docbook-xml-dtd:4.5
+"
+DEPEND=""
+
+if [ "$PV" == "9999" ]; then
+ DEPEND="${DEPEND}
+ dev-util/aap
+ www-client/lynx
+ dev-util/source-highlight"
+fi
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ if ! use vim-syntax; then
+ sed -i -e '/^install/s/install-vim//' Makefile.in
+ else
+ sed -i\
+ -e "/^vimdir/s:@sysconfdir@/vim:${EPREFIX}/usr/share/vim/vimfiles:" \
+ -e 's:/etc/vim::' \
+ Makefile.in || die
+ fi
+
+ # Only needed for prefix - harmless (does nothing) otherwise
+ sed -i -e "s:^CONF_DIR=.*:CONF_DIR='${EPREFIX}/etc/asciidoc':" \
+ "${S}/asciidoc.py" || die
+
+ [ "$PV" == "9999" ] && eautoconf
+}
+
+src_configure() {
+ econf --sysconfdir="${EPREFIX}"/usr/share
+}
+
+src_compile() {
+ default
+
+ if [ "$PV" == "9999" ]; then
+ ( cd doc && aap -f main.aap ../{CHANGELOG,README,BUGS} )
+ fi
+}
+
+src_install() {
+ use vim-syntax && dodir /usr/share/vim/vimfiles
+
+ emake DESTDIR="${D}" install || die "install failed"
+
+ python_convert_shebangs -r 2 "${D}"
+
+ if use examples; then
+ # This is a symlink to a directory
+ rm examples/website/images || die
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die
+ dosym ../../../asciidoc/images /usr/share/doc/${PF}/examples || die
+ fi
+
+ dodoc BUGS CHANGELOG README docbook-xsl/asciidoc-docbook-xsl.txt \
+ dblatex/dblatex-readme.txt filters/code/code-filter-readme.txt || die
+}