summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2006-08-30 03:40:30 +0000
committerJon Hood <squinky86@gentoo.org>2006-08-30 03:40:30 +0000
commitc70c5a52710bc261b64ce4ca57842cdd18fdf8f2 (patch)
tree420e1be1ec2916141e8d39c2a987a008b4f64894 /app-text/bibletime
parentVersion bump and remove older version (diff)
downloadgentoo-2-c70c5a52710bc261b64ce4ca57842cdd18fdf8f2.tar.gz
gentoo-2-c70c5a52710bc261b64ce4ca57842cdd18fdf8f2.tar.bz2
gentoo-2-c70c5a52710bc261b64ce4ca57842cdd18fdf8f2.zip
Version bump, remove old versions.
(Portage version: 2.1.1_rc1-r1)
Diffstat (limited to 'app-text/bibletime')
-rw-r--r--app-text/bibletime/ChangeLog9
-rw-r--r--app-text/bibletime/bibletime-1.6_rc1.ebuild88
-rw-r--r--app-text/bibletime/files/digest-bibletime-1.6_rc16
3 files changed, 102 insertions, 1 deletions
diff --git a/app-text/bibletime/ChangeLog b/app-text/bibletime/ChangeLog
index 01f5c1440a2e..324e4838509a 100644
--- a/app-text/bibletime/ChangeLog
+++ b/app-text/bibletime/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/bibletime
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/ChangeLog,v 1.34 2006/07/07 14:26:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/ChangeLog,v 1.35 2006/08/30 03:40:30 squinky86 Exp $
+
+*bibletime-1.6_rc1 (30 Aug 2006)
+
+ 30 Aug 2006; Jon Hood <squinky86@gentoo.org>
+ -files/bibletime-1.6_beta2-gcc4.patch, -bibletime-1.6_beta2.ebuild,
+ -bibletime-1.6_beta3.ebuild, +bibletime-1.6_rc1.ebuild:
+ Version bump, remove old versions.
07 Jul 2006; Diego Pettenò <flameeyes@gentoo.org> bibletime-1.5.3.ebuild,
bibletime-1.6_beta2.ebuild, bibletime-1.6_beta3.ebuild:
diff --git a/app-text/bibletime/bibletime-1.6_rc1.ebuild b/app-text/bibletime/bibletime-1.6_rc1.ebuild
new file mode 100644
index 000000000000..71aa19ed9890
--- /dev/null
+++ b/app-text/bibletime/bibletime-1.6_rc1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/bibletime-1.6_rc1.ebuild,v 1.1 2006/08/30 03:40:30 squinky86 Exp $
+
+inherit kde eutils versionator
+
+MY_PV="$(replace_version_separator 2 '')"
+MY_P="${PN}-${MY_PV}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="KDE Bible study application using the SWORD library."
+HOMEPAGE="http://www.bibletime.info/"
+SRC_URI="mirror://sourceforge/bibletime/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=app-text/sword-1.5.8
+ >=dev-cpp/clucene-0.9.15"
+
+LANGS_PKG=${PN}-i18n-${MY_PV}
+LANGS="af bg cs da de en_GB es fi fr hu it ko nl nn_NO no pl pt_BR ro ru sk ua"
+LANGS_DOC="bg cs de fi fr it ko nl pt_BR ru"
+
+for X in ${LANGS}; do
+ SRC_URI="${SRC_URI} linguas_${X}? ( mirror://sourceforge/bibletime/${LANGS_PKG}.tar.bz2 )"
+done
+
+need-kde 3.4
+
+pkg_setup() {
+ if ! built_with_use app-text/sword curl; then
+ echo
+ ewarn "The SWORD library may not have been compiled with curl support."
+ ewarn "If you wish to use BibleTime's ability to download modules"
+ ewarn "straight from the SWORD website, please make sure app-text/sword"
+ ewarn "was compiled with USE=\"curl\"."
+ ewarn "Press ctrl+c to abort the merge of BibleTime if you want to"
+ ewarn "recompile SWORD with curl support."
+ echo
+ ebeep 5
+ fi
+}
+
+src_unpack() {
+ kde_src_unpack
+
+ local MAKE_LANGS MAKE_LANGS_DOC
+ for X in ${LANGS}; do
+ use linguas_${X} && MAKE_LANGS="${MAKE_LANGS} ${X/pt_BR/pt_br}.po"
+ done
+ for X in ${LANGS_DOC}; do
+ use linguas_${X} && MAKE_LANGS_DOC="${MAKE_LANGS_DOC} ${X/pt_BR/pt-br}"
+ done
+
+ if [ -d "${WORKDIR}/${LANGS_PKG}" ]; then
+ cd "${WORKDIR}/${LANGS_PKG}"
+ sed -i -e "s,^POFILES.*,POFILES = ${MAKE_LANGS}," po/Makefile.am
+ sed -i -e "s,^SUBDIRS.*,SUBDIRS = ${MAKE_LANGS_DOC}," docs/Makefile.am
+ rm configure
+ fi
+}
+
+src_compile() {
+ kde_src_compile
+
+ local _S="${S}"
+ if [ -d "${WORKDIR}/${LANGS_PKG}" ]; then
+ S="${WORKDIR}/${LANGS_PKG}"
+ cd "${S}"
+ kde_src_compile
+ fi
+ S="${_S}"
+}
+
+src_install() {
+ kde_src_install
+
+ local _S="${S}"
+ if [ -d "${WORKDIR}/${LANGS_PKG}" ]; then
+ S="${WORKDIR}/${LANGS_PKG}"
+ cd "${S}"
+ kde_src_install
+ fi
+ S="${_S}"
+}
diff --git a/app-text/bibletime/files/digest-bibletime-1.6_rc1 b/app-text/bibletime/files/digest-bibletime-1.6_rc1
new file mode 100644
index 000000000000..8acf7299d0f8
--- /dev/null
+++ b/app-text/bibletime/files/digest-bibletime-1.6_rc1
@@ -0,0 +1,6 @@
+MD5 f12071f594424aefd5a9441109da9396 bibletime-1.6rc1.tar.bz2 1183496
+RMD160 406e50de140044776615b5dae74c73667b5fa453 bibletime-1.6rc1.tar.bz2 1183496
+SHA256 487768cff509bb9cac6934847778c7e75a44c309cedd50f670d928578243abec bibletime-1.6rc1.tar.bz2 1183496
+MD5 8f0fe070bbca81559c2b6383a5669253 bibletime-i18n-1.6rc1.tar.bz2 1012418
+RMD160 264e20ee7b9f2fa40fe1943edd3a617f0d19d225 bibletime-i18n-1.6rc1.tar.bz2 1012418
+SHA256 c49e07b465d2a81944d6bf9f73ce4722d31412c31e3031dc3349ea76af5b9e56 bibletime-i18n-1.6rc1.tar.bz2 1012418