summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-04-28 03:16:16 +0000
committerTravis Tilley <lv@gentoo.org>2004-04-28 03:16:16 +0000
commitb2e2ba2dfd30cc84e479640c2ad4341e3af82577 (patch)
tree9c3e7e5a6fd4bafbb146011be9590ccb5ba79079 /app-text/dgs
parentInitial import. Fixes #46412. (Manifest recommit) (diff)
downloadgentoo-2-b2e2ba2dfd30cc84e479640c2ad4341e3af82577.tar.gz
gentoo-2-b2e2ba2dfd30cc84e479640c2ad4341e3af82577.tar.bz2
gentoo-2-b2e2ba2dfd30cc84e479640c2ad4341e3af82577.zip
gcc 3.4 fix
Diffstat (limited to 'app-text/dgs')
-rw-r--r--app-text/dgs/ChangeLog5
-rw-r--r--app-text/dgs/dgs-0.5.10-r1.ebuild3
-rw-r--r--app-text/dgs/files/dgs-0.5.10-gcc-3.4.diff29
3 files changed, 35 insertions, 2 deletions
diff --git a/app-text/dgs/ChangeLog b/app-text/dgs/ChangeLog
index 7e9c424ba9f8..6fc1a804bc8a 100644
--- a/app-text/dgs/ChangeLog
+++ b/app-text/dgs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/dgs
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dgs/ChangeLog,v 1.14 2004/04/15 17:54:06 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dgs/ChangeLog,v 1.15 2004/04/28 03:16:14 lv Exp $
+
+ 27 Apr 2004; Travis Tilley <lv@gentoo.org> dgs-0.5.10-r1.ebuild:
+ added patch for compiling with gcc 3.4 submitted by Robert Moss
16 Apr 2004; Mamoru KOMACHI <usata@gentoo.org> dgs-0.5.10-r1.ebuild,
files/dgs-0.5.10-tcpd-gentoo.diff:
diff --git a/app-text/dgs/dgs-0.5.10-r1.ebuild b/app-text/dgs/dgs-0.5.10-r1.ebuild
index ce0584548926..7c72985250a1 100644
--- a/app-text/dgs/dgs-0.5.10-r1.ebuild
+++ b/app-text/dgs/dgs-0.5.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dgs/dgs-0.5.10-r1.ebuild,v 1.24 2004/04/15 17:54:06 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dgs/dgs-0.5.10-r1.ebuild,v 1.25 2004/04/28 03:16:15 lv Exp $
inherit gnuconfig eutils
@@ -25,6 +25,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${P}-gs-time_.h-gentoo.diff
epatch ${FILESDIR}/${P}-tcpd-gentoo.diff
+ epatch ${FILESDIR}/${P}-gcc-3.4.diff
use amd64 && gnuconfig_update
}
diff --git a/app-text/dgs/files/dgs-0.5.10-gcc-3.4.diff b/app-text/dgs/files/dgs-0.5.10-gcc-3.4.diff
new file mode 100644
index 000000000000..e66ab479cf10
--- /dev/null
+++ b/app-text/dgs/files/dgs-0.5.10-gcc-3.4.diff
@@ -0,0 +1,29 @@
+--- DPS/clients/makepsres/makepsres.c.old 2004-04-22 19:48:50.568331512 +0100
++++ DPS/clients/makepsres/makepsres.c 2004-04-22 19:50:34.076595864 +0100
+@@ -124,8 +124,6 @@
+
+ char *program;
+
+-extern char *malloc(), *realloc();
+-
+ #if !defined(__NetBSD__) && !defined(__FreeBSD__)
+ # if !defined(__GLIBC__)
+ extern char *sys_errlist[];
+--- DPS/clients/pswrap/psw.c.old 2004-04-22 19:54:13.609221832 +0100
++++ DPS/clients/pswrap/psw.c 2004-04-22 19:54:39.149339144 +0100
+@@ -1906,7 +1906,6 @@
+
+ char *psw_malloc(s) int s; {
+ char *temp;
+- extern char *malloc();
+ if ((temp = malloc((unsigned) s)) == NULL)
+ AllocFailure();
+ return(temp);
+@@ -1914,7 +1913,6 @@
+
+ char *psw_calloc(n,s) int n,s; {
+ char *temp;
+- extern char *calloc();
+ if ((temp = calloc((unsigned) n, (unsigned) s)) == NULL)
+ AllocFailure();
+ return(temp);