summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-01-18 10:05:45 +0000
committerPeter Volkov <pva@gentoo.org>2010-01-18 10:05:45 +0000
commit970bddf828f00c75a89c37dc4596f2d2c87d1a2f (patch)
treeb5f77703f3a176f19d51869b54768b445eb009bf /app-text/djvu
parentVersion bump to 0.2.7 Bug #301292 (diff)
downloadgentoo-2-970bddf828f00c75a89c37dc4596f2d2c87d1a2f.tar.gz
gentoo-2-970bddf828f00c75a89c37dc4596f2d2c87d1a2f.tar.bz2
gentoo-2-970bddf828f00c75a89c37dc4596f2d2c87d1a2f.zip
Revert qt3 drop, nsplugin should stay.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'app-text/djvu')
-rw-r--r--app-text/djvu/ChangeLog5
-rw-r--r--app-text/djvu/djvu-3.5.22.ebuild42
2 files changed, 35 insertions, 12 deletions
diff --git a/app-text/djvu/ChangeLog b/app-text/djvu/ChangeLog
index f20ba8964f30..ede6361b8d9c 100644
--- a/app-text/djvu/ChangeLog
+++ b/app-text/djvu/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/djvu
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/ChangeLog,v 1.98 2010/01/05 03:08:54 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/ChangeLog,v 1.99 2010/01/18 10:05:45 pva Exp $
+
+ 18 Jan 2010; Peter Volkov <pva@gentoo.org> djvu-3.5.22.ebuild:
+ Revert qt3 drop, nsplugin should stay.
05 Jan 2010; Ben de Groot <yngwin@gentoo.org>
djvu-3.5.21_p20090103.ebuild, djvu-3.5.22.ebuild:
diff --git a/app-text/djvu/djvu-3.5.22.ebuild b/app-text/djvu/djvu-3.5.22.ebuild
index 32240401ca4c..d38a051ae226 100644
--- a/app-text/djvu/djvu-3.5.22.ebuild
+++ b/app-text/djvu/djvu-3.5.22.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/djvu-3.5.22.ebuild,v 1.4 2010/01/05 11:17:24 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/djvu-3.5.22.ebuild,v 1.5 2010/01/18 10:05:45 pva Exp $
EAPI=1
-inherit fdo-mime flag-o-matic eutils multilib toolchain-funcs
+inherit fdo-mime nsplugins flag-o-matic eutils multilib toolchain-funcs confutils
MY_P="${PN}libre-${PV#*_p}"
@@ -14,11 +14,13 @@ SRC_URI="mirror://sourceforge/djvu/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="xml jpeg tiff debug nls kde doc"
+IUSE="xml qt3 jpeg tiff debug nls nsplugin kde doc"
RDEPEND="jpeg? ( >=media-libs/jpeg-6b-r2 )
- tiff? ( media-libs/tiff )"
-DEPEND="${RDEPEND}"
+ tiff? ( media-libs/tiff )
+ qt3? ( x11-libs/qt:3 )"
+DEPEND="${RDEPEND}
+ qt3? ( nsplugin? ( x11-libs/libXt ) )"
S=${WORKDIR}/${MY_P}
@@ -27,6 +29,17 @@ for X in ${LANGS}; do
IUSE="${IUSE} linguas_${X}"
done
+pkg_setup() {
+ if ! use qt3; then
+ ewarn
+ ewarn "The standalone djvu viewer, djview, will not be compiled."
+ ewarn "Add \"qt3\" to your USE flags if you want it."
+ ewarn
+ fi
+
+ confutils_use_depend_all nsplugin qt3
+}
+
src_compile() {
local I18N
if use nls; then
@@ -45,17 +58,19 @@ src_compile() {
I18N="--disable-i18n"
fi
- # We install all desktop files by hand and Qt3 is deprecated
- econf \
- --disable-desktopfiles \
- --without-qt \
+ # We install all desktop files by hand.
+ econf --disable-desktopfiles \
+ $(use_with qt3 qt) \
$(use_enable xml xmltools) \
$(use_with jpeg) \
$(use_with tiff) \
"${I18N}" \
- $(use_enable debug)
+ $(use_enable debug) \
+ ${QTCONF}
- sed -e 's:nsdejavu::' -i "${S}"/gui/Makefile || die
+ if ! use nsplugin; then
+ sed -e 's:nsdejavu::' -i "${S}"/gui/Makefile || die
+ fi
emake || die "emake failed"
}
@@ -78,6 +93,11 @@ src_install() {
cp "${D}"/usr/share/mimelnk/image/{vnd.djvu.desktop,x-djvu.desktop}
sed -i -e 's:image/vnd.djvu:image/x-djvu:' "${D}"/usr/share/mimelnk/image/x-djvu.desktop
fi
+
+ if use qt3 ; then
+ insinto /usr/share/icons/hicolor/32x32/apps && newins hi32-djview3.png djvulibre-djview3.png || die
+ insinto /usr/share/applications/ && doins djvulibre-djview3.desktop || die
+ fi
}
pkg_postinst() {