summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-11-18 01:41:20 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-11-18 01:41:20 +0000
commit203d5f35c30ae29fadeb3469372c3390a3216819 (patch)
tree5951b58b9b66837424d5b57f39510dc2bca38e2d /app-text/ggv
parentUpdated cdrtools (diff)
downloadgentoo-2-203d5f35c30ae29fadeb3469372c3390a3216819.tar.gz
gentoo-2-203d5f35c30ae29fadeb3469372c3390a3216819.tar.bz2
gentoo-2-203d5f35c30ae29fadeb3469372c3390a3216819.zip
updated to latest version
Diffstat (limited to 'app-text/ggv')
-rw-r--r--app-text/ggv/files/digest-ggv-1.1.921
-rw-r--r--app-text/ggv/ggv-1.1.92.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-text/ggv/files/digest-ggv-1.1.92 b/app-text/ggv/files/digest-ggv-1.1.92
new file mode 100644
index 000000000000..95d85a2f4e68
--- /dev/null
+++ b/app-text/ggv/files/digest-ggv-1.1.92
@@ -0,0 +1 @@
+MD5 b9261e5e6ca75749a7a30c1c4fe1ab45 ggv-1.1.92.tar.gz 729088
diff --git a/app-text/ggv/ggv-1.1.92.ebuild b/app-text/ggv/ggv-1.1.92.ebuild
new file mode 100644
index 000000000000..dd9ab68d895e
--- /dev/null
+++ b/app-text/ggv/ggv-1.1.92.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/ggv/ggv-1.1.92.ebuild,v 1.1 2001/11/18 01:41:20 hallski Exp $
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnome Ghostview"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+
+RDEPEND=">=gnome-base/gnome-libs-1.4.1.2-r1
+ bonobo? ( >=gnome-base/bonobo-1.0.9-r1 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ if [ "`use bonobo`" ] ; then
+ myconf="$myconf --with-bonobo"
+ CFLAGS="${CFLAGS} `gnome-config --cflags bonobo bonobox`"
+ else
+ myconf="$myconf --without-bonobo"
+ fi
+
+ CFLAGS="$CFLAGS `gdk-pixbuf-config --cflags`"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ $myconf || die
+
+ emake || die
+}
+
+src_install() {
+ gconftool --shutdown
+
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}
+