summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-13 09:33:50 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-13 09:33:50 +0000
commitad5d4cdb7a7f60f7950e100fde8cb107f5039f03 (patch)
tree042c830e985681a2ac1f8dd7f9320a258f2e68e7 /app-text/ggv
parentNew version of package available. (diff)
downloadgentoo-2-ad5d4cdb7a7f60f7950e100fde8cb107f5039f03.tar.gz
gentoo-2-ad5d4cdb7a7f60f7950e100fde8cb107f5039f03.tar.bz2
gentoo-2-ad5d4cdb7a7f60f7950e100fde8cb107f5039f03.zip
New version of ggv
Diffstat (limited to 'app-text/ggv')
-rw-r--r--app-text/ggv/ChangeLog10
-rw-r--r--app-text/ggv/files/digest-ggv-1.1.941
-rw-r--r--app-text/ggv/ggv-1.1.94.ebuild62
3 files changed, 72 insertions, 1 deletions
diff --git a/app-text/ggv/ChangeLog b/app-text/ggv/ChangeLog
index d09d65cee3d0..4a98a73a9e87 100644
--- a/app-text/ggv/ChangeLog
+++ b/app-text/ggv/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-text/ggv
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/ggv/ChangeLog,v 1.2 2002/02/20 03:08:16 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ggv/ChangeLog,v 1.3 2002/03/13 09:33:50 seemant Exp $
+
+*ggv-1.1.94 (12 Mar 2002)
+
+ 12 Mar 2002; Seemant Kulleen <seemant@gentoo.org> ggv-1.1.94.ebuild :
+
+ Version upgrade. Pretty much a copy of the 1.1.93 ebuild, with a few
+ additional dodoc parameters and a version upgrade of the dependency
+ info -- submitted by Matthew Kennedy.
*ggv-1.1.93 (19 Feb 2002)
diff --git a/app-text/ggv/files/digest-ggv-1.1.94 b/app-text/ggv/files/digest-ggv-1.1.94
new file mode 100644
index 000000000000..4cc2b6e3d04f
--- /dev/null
+++ b/app-text/ggv/files/digest-ggv-1.1.94
@@ -0,0 +1 @@
+MD5 6cc996d0e8746dd70e76c8c591bbc773 ggv-1.1.94.tar.gz 734758
diff --git a/app-text/ggv/ggv-1.1.94.ebuild b/app-text/ggv/ggv-1.1.94.ebuild
new file mode 100644
index 000000000000..8ab7ee2bc4fd
--- /dev/null
+++ b/app-text/ggv/ggv-1.1.94.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/ggv/ggv-1.1.94.ebuild,v 1.1 2002/03/13 09:33:50 seemant Exp $
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnome Ghostview"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+
+RDEPEND=">=gnome-base/gnome-libs-1.4.1.4
+ bonobo? ( >=gnome-base/bonobo-1.0.19-r1 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+
+ use nls || myconf="--disable-nls"
+ if use bonobo; then
+ myconf="${myconf} --with-bonobo"
+ else
+ myconf="${myconf} --without-bonobo"
+ fi
+
+ ./configure --build=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --disable-install-schemas \
+ ${myconf} || die
+
+ # CFLAGS was slurped up by ./configure above. It's now in the
+ # Makefiles. We don't want to override it with our own.
+ unset CFLAGS
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+ dodoc ABOUT-NLS AUTHORS ChangeLog COPYING COPYING-DOCS NEWS README TODO
+}
+
+pkg_postinst() {
+ # This is from the devhelp ebuild...
+ # Fix gconf permissions
+ killall gconfd-1 2>/dev/null >/dev/null
+ chmod o+rX /etc/gconf -R
+ # Install schemas
+ gconftool-1 --shutdown
+ SOURCE=xml::/etc/gconf/gconf.xml.defaults
+ GCONF_CONFIG_SOURCE=$SOURCE \
+ gconftool-1 --makefile-install-rule \
+ /etc/gconf/schemas/${PN}.schemas \
+ # 2>/dev/null >/dev/null || exit 1
+ assert "gconftool-1 execution failed"
+}