summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-12-09 20:54:33 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-12-09 20:54:33 +0000
commitb4a8e2cecd18c6e11e87f419a7e2742d555db60c (patch)
tree0f8988dfd952ed897a842ddfe0e218c9bcf79ba6 /app-text/gsview/gsview-4.5.ebuild
parentfix manifests (diff)
downloadgentoo-2-b4a8e2cecd18c6e11e87f419a7e2742d555db60c.tar.gz
gentoo-2-b4a8e2cecd18c6e11e87f419a7e2742d555db60c.tar.bz2
gentoo-2-b4a8e2cecd18c6e11e87f419a7e2742d555db60c.zip
initial import
Diffstat (limited to 'app-text/gsview/gsview-4.5.ebuild')
-rw-r--r--app-text/gsview/gsview-4.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-text/gsview/gsview-4.5.ebuild b/app-text/gsview/gsview-4.5.ebuild
new file mode 100644
index 000000000000..e53f7ebaa2aa
--- /dev/null
+++ b/app-text/gsview/gsview-4.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gsview/gsview-4.5.ebuild,v 1.1 2003/12/09 20:54:33 lanius Exp $
+
+DESCRIPTION="gsView PostScript and PDF viewer"
+SRC_URI="ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/ghostgum/gsv45src.zip"
+HOMEPAGE="http://www.cs.wisc.edu/~ghost/gsview/"
+
+SLOT="0"
+LICENSE="Aladdin"
+KEYWORDS="~x86"
+
+RDEPEND=">=x11-libs/gtk+-1.2
+ app-text/ghostscript-afpl"
+
+src_compile() {
+ ## copy Unix makefile
+ ln -s srcunx/unx.mak Makefile
+
+ ## run Makefile
+ make || die "Error compiling files."
+}
+
+src_install() {
+ dobin bin/gsview bin/esptool
+
+ insinto /usr/share/applications
+ newins srcunx/gvhelp.txt gview
+
+ doman srcunx/gsview.1
+
+ dodoc gsview.css cdorder.txt regorder.txt Readme.txt LICENCE
+ dohtml *.htm bin/*.htm
+
+ insinto /etc/gsview
+ doins src/printer.ini
+}