summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-03-08 04:13:26 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-03-08 04:13:26 +0000
commite1bf03a998f514571cf1ebaa6fd802a611a5683a (patch)
tree1021fd37dd473d0f50ee96758442221094b4ffc9 /app-text/gtkspell
parentbump (diff)
downloadgentoo-2-e1bf03a998f514571cf1ebaa6fd802a611a5683a.tar.gz
gentoo-2-e1bf03a998f514571cf1ebaa6fd802a611a5683a.tar.bz2
gentoo-2-e1bf03a998f514571cf1ebaa6fd802a611a5683a.zip
fix not building without gtk-doc
Diffstat (limited to 'app-text/gtkspell')
-rw-r--r--app-text/gtkspell/ChangeLog6
-rw-r--r--app-text/gtkspell/gtkspell-2.0.4.ebuild13
2 files changed, 14 insertions, 5 deletions
diff --git a/app-text/gtkspell/ChangeLog b/app-text/gtkspell/ChangeLog
index 2005f38bbb98..dbbec76b49ff 100644
--- a/app-text/gtkspell/ChangeLog
+++ b/app-text/gtkspell/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for app-text/gtkspell
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/ChangeLog,v 1.9 2003/03/06 23:44:23 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/ChangeLog,v 1.10 2003/03/08 04:13:26 azarah Exp $
*gtkspell-2.0.4 (07 Mar 2003)
+ 08 Mar 2003; Martin Schlemmer <azarah@gentoo.org> gtkspell-2.0.4.ebuild :
+ Add 'doc' support with DEPEND on gtk-doc, as it fails over here without
+ gtk-doc installed ...
+
07 Mar 2003; foser <foser@gentoo.org> gtkspell-2.0.4.ebuild :
New version, removed obsoleted nls USE
diff --git a/app-text/gtkspell/gtkspell-2.0.4.ebuild b/app-text/gtkspell/gtkspell-2.0.4.ebuild
index 3caea523db25..55eb35959cb4 100644
--- a/app-text/gtkspell/gtkspell-2.0.4.ebuild
+++ b/app-text/gtkspell/gtkspell-2.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/gtkspell-2.0.4.ebuild,v 1.1 2003/03/06 23:44:23 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/gtkspell-2.0.4.ebuild,v 1.2 2003/03/08 04:13:26 azarah Exp $
DESCRIPTION="spell library for GTK2"
SRC_URI="http://${PN}.sourceforge.net/download/${P}.tar.gz"
@@ -9,13 +9,18 @@ HOMEPAGE="http://gtkspell.sourceforge.net/"
LICENSE="GPL-2"
KEYWORDS="~x86 ~sparc ~ppc"
SLOT="0"
-IUSE=""
+IUSE="doc"
DEPEND=">=x11-libs/gtk+-2
- >=app-text/aspell-0.50"
+ >=app-text/aspell-0.50
+ doc? ( dev-util/gtk-doc )"
src_compile() {
- econf || die
+ myconf=
+
+ use doc || myconf="--disable-gtk-doc"
+
+ econf ${myconf} || die
emake || die "compile failure"
}