summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-04-07 17:30:26 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-04-07 17:30:26 +0000
commit5d25ad85d68806f2b10b9b225da15df804440ad3 (patch)
tree04415c3ff085fa8e02e82e5e2fce897c54a88c1c /app-text/gv
parentVersion bump (thx to Flameeyes for reporting on irc) (diff)
downloadgentoo-2-5d25ad85d68806f2b10b9b225da15df804440ad3.tar.gz
gentoo-2-5d25ad85d68806f2b10b9b225da15df804440ad3.tar.bz2
gentoo-2-5d25ad85d68806f2b10b9b225da15df804440ad3.zip
Make gv read its config, bug 158322
(Portage version: 2.1.2.3)
Diffstat (limited to 'app-text/gv')
-rw-r--r--app-text/gv/ChangeLog6
-rw-r--r--app-text/gv/files/digest-gv-3.6.2-r16
-rw-r--r--app-text/gv/files/gv-30_config.patch283
-rw-r--r--app-text/gv/gv-3.6.2-r1.ebuild9
4 files changed, 297 insertions, 7 deletions
diff --git a/app-text/gv/ChangeLog b/app-text/gv/ChangeLog
index 02ab2f3dd6c8..f8f6d96deef0 100644
--- a/app-text/gv/ChangeLog
+++ b/app-text/gv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/gv
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gv/ChangeLog,v 1.65 2007/04/07 17:14:33 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gv/ChangeLog,v 1.66 2007/04/07 17:30:26 genstef Exp $
+
+ 07 Apr 2007; Stefan Schweizer <genstef@gentoo.org>
+ +files/gv-30_config.patch, gv-3.6.2-r1.ebuild:
+ Make gv read its config, bug 158322
07 Apr 2007; Stefan Schweizer <genstef@gentoo.org> gv-3.6.2-r1.ebuild:
Add menu entry thanks to Pacho Ramos <pacho@condmat1.ciencias.uniovi.es> in
diff --git a/app-text/gv/files/digest-gv-3.6.2-r1 b/app-text/gv/files/digest-gv-3.6.2-r1
index ac51275af3b9..35a0945b3a18 100644
--- a/app-text/gv/files/digest-gv-3.6.2-r1
+++ b/app-text/gv/files/digest-gv-3.6.2-r1
@@ -1,6 +1,6 @@
MD5 dcdb2205cf0c61394419e015c7548df1 gv-3.6.2.tar.gz 446040
RMD160 6479102493e3ebf5b2602a577c02a8b573a73cab gv-3.6.2.tar.gz 446040
SHA256 778e79832dd374238a916d8f202f405775de38422477bd6c60bb1aa7845c82f9 gv-3.6.2.tar.gz 446040
-MD5 09d4dadd1e0cb6bd07dfc4764c781038 gv_3.6.2-2.diff.gz 12425
-RMD160 9289e3caab482de08f51c27cc4e535a9d667308f gv_3.6.2-2.diff.gz 12425
-SHA256 14a08f3b7fae1e70eac706b8dddeec91fc8f6603aee8f68b1a7f7f7eeb37eecf gv_3.6.2-2.diff.gz 12425
+MD5 0bbdac99315ffd8d704e3a90435a9f51 gv_3.6.2-3.diff.gz 12464
+RMD160 d1aef518f837501abc0151c681e13b9a07b7afc7 gv_3.6.2-3.diff.gz 12464
+SHA256 cc5c141ecaa3b2c68435d70347508747e2b6a61dec98193fb1f0e51ec01d2d5c gv_3.6.2-3.diff.gz 12464
diff --git a/app-text/gv/files/gv-30_config.patch b/app-text/gv/files/gv-30_config.patch
new file mode 100644
index 000000000000..b98e8044b369
--- /dev/null
+++ b/app-text/gv/files/gv-30_config.patch
@@ -0,0 +1,283 @@
+Index: gv-3.6.2/src/main.c
+===================================================================
+--- gv-3.6.2.orig/src/main.c 2006-10-16 20:55:40.280698642 +0200
++++ gv-3.6.2/src/main.c 2006-10-16 21:05:42.041789721 +0200
+@@ -592,10 +592,8 @@
+ /*### getting resources ############################################*/
+
+ {
+- XrmDatabase db;
+ INFMESSAGE(getting resources)
+- db = resource_buildDatabase(gv_display,gv_class,gv_name,&argc,argv);
+- XrmCombineDatabase(db,&gv_database,False);
++ resource_updateDatabase(gv_display,gv_class,gv_name,&gv_database,&argc,argv);
+ }
+
+ /*### initializing widget set and creating application shell #########################*/
+Index: gv-3.6.2/src/resource.c
+===================================================================
+--- gv-3.6.2.orig/src/resource.c 2005-08-10 13:33:21.000000000 +0200
++++ gv-3.6.2/src/resource.c 2006-10-16 21:23:11.885580469 +0200
+@@ -110,13 +110,14 @@
+ }
+
+ /*#######################################################
+- resource_buildDatabase
++ resource_updateDatabase
+ #######################################################*/
+
+-XrmDatabase resource_buildDatabase(display,app_class,app_name,argcP,argv)
++void resource_updateDatabase(display,app_class,app_name,dbp,argcP,argv)
+ Display *display;
+ char *app_class;
+ char *app_name;
++ XrmDatabase *dbp;
+ int *argcP;
+ char **argv;
+ {
+@@ -126,8 +127,7 @@
+ char *spartan_filename;
+ char tmp[GV_MAX_FILENAME_LENGTH];
+
+-
+- BEGINMESSAGE(resource_buildDatabase)
++ BEGINMESSAGE(resource_updateDatabase)
+
+ /* ### class resources ################# */
+ INFMESSAGE(merging class resources into database)
+@@ -146,6 +146,8 @@
+ XrmCombineFileDatabase(rpath,&db,True);
+ resource_system_file = rpath;
+ }
++ XrmCombineDatabase(db,dbp,False);
++ db = NULL;
+
+ /* ### user resources ################# */
+ INFMESSAGE(checking for user resources)
+@@ -166,6 +168,9 @@
+ resource_user_file = GV_XtNewString(tmp);
+ }
+
++ XrmCombineDatabase(db,dbp,True);
++ db = *dbp;
++
+ /* ### command line resources ################# */
+
+ /*
+@@ -177,35 +182,35 @@
+
+ if (antialias_p)
+ {
+- resource_putResource (&db, app_name, ".antialias", "True");
++ resource_putResource (dbp, app_name, ".antialias", "True");
+ }
+ if (noantialias_p)
+ {
+- resource_putResource (&db, app_name, ".antialias", "False");
++ resource_putResource (dbp, app_name, ".antialias", "False");
+ }
+ if (safer_p)
+ {
+- resource_putResource (&db, app_name, ".gsSafer", "True");
++ resource_putResource (dbp, app_name, ".gsSafer", "True");
+ }
+ if (nosafer_p)
+ {
+- resource_putResource (&db, app_name, ".gsSafer", "False");
++ resource_putResource (dbp, app_name, ".gsSafer", "False");
+ }
+ if (pixmap_p)
+ {
+- resource_putResource (&db, app_name, ".useBackingPixmap", "True");
++ resource_putResource (dbp, app_name, ".useBackingPixmap", "True");
+ }
+ if (nopixmap_p)
+ {
+- resource_putResource (&db, app_name, ".useBackingPixmap", "False");
++ resource_putResource (dbp, app_name, ".useBackingPixmap", "False");
+ }
+ if (color_p)
+ {
+- resource_putResource (&db, app_name, "*Ghostview.palette", "Color");
++ resource_putResource (dbp, app_name, "*Ghostview.palette", "Color");
+ }
+ if (grayscale_p)
+ {
+- resource_putResource (&db, app_name, "*Ghostview.palette", "Grayscale");
++ resource_putResource (dbp, app_name, "*Ghostview.palette", "Grayscale");
+ }
+ if (spartan_p)
+ {
+@@ -214,109 +219,109 @@
+ spartan_filename[0] = '\0';
+ strcat(spartan_filename, GV_LIBDIR);
+ strcat(spartan_filename, "/gv_spartan.dat");
+- resource_putResource (&db, app_name, ".style", spartan_filename);
++ resource_putResource (dbp, app_name, ".style", spartan_filename);
+ GV_XtFree (spartan_filename);
+ }
+ if (quiet_p)
+ {
+- resource_putResource (&db, app_name, ".gsQuiet", "True");
++ resource_putResource (dbp, app_name, ".gsQuiet", "True");
+ }
+ if (monochrome_p)
+ {
+- resource_putResource (&db, app_name, "*Ghostview.palette", "Monochrome");
++ resource_putResource (dbp, app_name, "*Ghostview.palette", "Monochrome");
+ }
+ if (noquiet_p)
+ {
+- resource_putResource (&db, app_name, ".gsQuiet", "False");
++ resource_putResource (dbp, app_name, ".gsQuiet", "False");
+ }
+ if (media_p)
+ {
+- resource_putResource (&db, app_name, ".pageMedia", media_value);
++ resource_putResource (dbp, app_name, ".pageMedia", media_value);
+ }
+ if (orientation_p)
+ {
+- resource_putResource (&db, app_name, ".orientation", orientation_value);
++ resource_putResource (dbp, app_name, ".orientation", orientation_value);
+ }
+ if (page_p)
+ {
+- resource_putResource (&db, app_name, ".page", page_value);
++ resource_putResource (dbp, app_name, ".page", page_value);
+ }
+
+ if (center_p)
+ {
+- resource_putResource (&db, app_name, ".autoCenter", "True");
++ resource_putResource (dbp, app_name, ".autoCenter", "True");
+ }
+ if (nocenter_p)
+ {
+- resource_putResource (&db, app_name, ".autoCenter", "False");
++ resource_putResource (dbp, app_name, ".autoCenter", "False");
+ }
+ if (scale_p)
+ {
+- resource_putResource (&db, app_name, ".scale", scale_value);
++ resource_putResource (dbp, app_name, ".scale", scale_value);
+ }
+ if (magstep_p)
+ {
+- resource_putResource (&db, app_name, ".scale", magstep_value);
++ resource_putResource (dbp, app_name, ".scale", magstep_value);
+ }
+ if (scalebase_p)
+ {
+- resource_putResource (&db, app_name, ".scaleBase", scalebase_value);
++ resource_putResource (dbp, app_name, ".scaleBase", scalebase_value);
+ }
+ if (resize_p)
+ {
+- resource_putResource (&db, app_name, ".autoResize", "True");
++ resource_putResource (dbp, app_name, ".autoResize", "True");
+ }
+ if (noresize_p)
+ {
+- resource_putResource (&db, app_name, ".autoResize", "False");
++ resource_putResource (dbp, app_name, ".autoResize", "False");
+ }
+ if (swap_p)
+ {
+- resource_putResource (&db, app_name, ".swapLandscape", "True");
++ resource_putResource (dbp, app_name, ".swapLandscape", "True");
+ }
+ if (noswap_p)
+ {
+- resource_putResource (&db, app_name, ".swapLandscape", "False");
++ resource_putResource (dbp, app_name, ".swapLandscape", "False");
+ }
+ if (dsc_p)
+ {
+- resource_putResource (&db, app_name, ".respectDSC", "True");
++ resource_putResource (dbp, app_name, ".respectDSC", "True");
+ }
+ if (nodsc_p)
+ {
+- resource_putResource (&db, app_name, ".respectDSC", "False");
++ resource_putResource (dbp, app_name, ".respectDSC", "False");
+ }
+ if (eof_p)
+ {
+- resource_putResource (&db, app_name, ".ignoreEOF", "True");
++ resource_putResource (dbp, app_name, ".ignoreEOF", "True");
+ }
+ if (noeof_p)
+ {
+- resource_putResource (&db, app_name, ".ignoreEOF", "False");
++ resource_putResource (dbp, app_name, ".ignoreEOF", "False");
+ }
+ if (watch_p)
+ {
+- resource_putResource (&db, app_name, ".watchFile", "True");
++ resource_putResource (dbp, app_name, ".watchFile", "True");
+ }
+ if (nowatch_p)
+ {
+- resource_putResource (&db, app_name, ".watchFile", "False");
++ resource_putResource (dbp, app_name, ".watchFile", "False");
+ }
+ if (ad_p)
+ {
+- resource_putResource (&db, app_name, ".ad", ad_value);
++ resource_putResource (dbp, app_name, ".ad", ad_value);
+ }
+ if (style_p)
+ {
+- resource_putResource (&db, app_name, ".style", style_value);
++ resource_putResource (dbp, app_name, ".style", style_value);
+ }
+ if (arguments_p)
+ {
+- resource_putResource (&db, app_name, ".arguments", arguments_value);
++ resource_putResource (dbp, app_name, ".arguments", arguments_value);
+ }
+
+ INFMESSAGE(parsing command line)
+- XrmParseCommand(&db,options,XtNumber(options),app_name,argcP,argv);
++ XrmParseCommand(dbp,options,XtNumber(options),app_name,argcP,argv);
+
+ /* ### style resources ######################## */
+ INFMESSAGE(checking for style resources)
+@@ -354,7 +359,7 @@
+ */
+
+ INFSMESSAGE(merging style resource file into database,s)
+- t = resource_mergeFileIntoDatabase(&db,s);
++ t = resource_mergeFileIntoDatabase(dbp,s);
+ if (!t) {
+ fprintf(stderr,"%s: Style file '%s' not found - ignored\n",app_name,s);
+ s=NULL;
+@@ -384,8 +389,7 @@
+ if (t) GV_XtFree(t);
+ }
+
+- ENDMESSAGE(resource_buildDatabase)
+- return(db);
++ ENDMESSAGE(resource_updateDatabase)
+ }
+
+ /*#######################################################
+Index: gv-3.6.2/src/resource.h
+===================================================================
+--- gv-3.6.2.orig/src/resource.h 2004-12-06 13:52:10.000000000 +0100
++++ gv-3.6.2/src/resource.h 2006-10-16 21:24:43.243115805 +0200
+@@ -38,11 +38,12 @@
+ #endif
+ );
+
+-extern XrmDatabase resource_buildDatabase (
++extern void resource_updateDatabase (
+ #if NeedFunctionPrototypes
+ Display *,
+ char *,
+ char *,
++ XrmDatabase *,
+ int *,
+ char **
+ #endif
diff --git a/app-text/gv/gv-3.6.2-r1.ebuild b/app-text/gv/gv-3.6.2-r1.ebuild
index 556aabf91ece..9676f52e5943 100644
--- a/app-text/gv/gv-3.6.2-r1.ebuild
+++ b/app-text/gv/gv-3.6.2-r1.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gv/gv-3.6.2-r1.ebuild,v 1.11 2007/04/07 17:14:33 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gv/gv-3.6.2-r1.ebuild,v 1.12 2007/04/07 17:30:26 genstef Exp $
inherit eutils
+DPF="gv_3.6.2-3"
DESCRIPTION="gv is used to view PostScript and PDF documents using Ghostscript"
HOMEPAGE="http://www.gnu.org/software/gv/"
SRC_URI="mirror://gnu/gv/${P}.tar.gz
- mirror://debian/pool/main/g/gv/gv_3.6.2-2.diff.gz"
+ mirror://debian/pool/main/g/gv/${DPF}.diff.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -36,7 +37,9 @@ src_unpack() {
epatch "${FILESDIR}"/gv-3.6.1-a0.patch
epatch "${FILESDIR}"/gv-3.6.1-fixedmedia.patch
epatch "${FILESDIR}"/gv-update.patch
- epatch "${WORKDIR}"/gv_3.6.2-2.diff
+ epatch "${FILESDIR}"/gv-30_config.patch
+ # apply debian patches
+ epatch "${WORKDIR}"/${DPF}.diff
epatch ${P}/debian/patches/{*-*,*_*}
# Make font render nicely even with gs-8, bug 135354
sed -i -e "s:-dGraphicsAlphaBits=2:\0 -dAlignToPixels=0:" \