summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-02-03 18:47:32 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-02-03 18:47:32 +0000
commit60c6a27083cd10de763fe6da54b74e5f54f78ae7 (patch)
treec720e8836ac13538c6bdb836ce88a4d6c03725ce /app-text/iso-codes
parentExplicitly call pkg_preinst of java-pkg-2 and subversion eclass (diff)
downloadgentoo-2-60c6a27083cd10de763fe6da54b74e5f54f78ae7.tar.gz
gentoo-2-60c6a27083cd10de763fe6da54b74e5f54f78ae7.tar.bz2
gentoo-2-60c6a27083cd10de763fe6da54b74e5f54f78ae7.zip
Small dep fix. Closes #233166
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-text/iso-codes')
-rw-r--r--app-text/iso-codes/ChangeLog8
-rw-r--r--app-text/iso-codes/iso-codes-3.5.1-r1.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/app-text/iso-codes/ChangeLog b/app-text/iso-codes/ChangeLog
index d9abd85e18fd..8c27a1139041 100644
--- a/app-text/iso-codes/ChangeLog
+++ b/app-text/iso-codes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/iso-codes
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/ChangeLog,v 1.57 2009/01/18 21:53:13 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/ChangeLog,v 1.58 2009/02/03 18:47:32 patrick Exp $
+
+*iso-codes-3.5.1-r1 (03 Feb 2009)
+
+ 03 Feb 2009; Patrick Lauer <patrick@gentoo.org>
+ +iso-codes-3.5.1-r1.ebuild:
+ Small dep fix. Closes #233166
*iso-codes-3.5.1 (18 Jan 2009)
diff --git a/app-text/iso-codes/iso-codes-3.5.1-r1.ebuild b/app-text/iso-codes/iso-codes-3.5.1-r1.ebuild
new file mode 100644
index 000000000000..5ff0028a0c46
--- /dev/null
+++ b/app-text/iso-codes/iso-codes-3.5.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-3.5.1-r1.ebuild,v 1.1 2009/02/03 18:47:32 patrick Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="Provides the list of country and language names"
+HOMEPAGE="http://alioth.debian.org/projects/pkg-isocodes/"
+SRC_URI="ftp://pkg-isocodes.alioth.debian.org/pub/pkg-isocodes/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=""
+DEPEND="sys-devel/gettext
+ || (
+ >=dev-lang/python-2.3[-build,xml]
+ dev-python/pyxml )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fix install location for multilib machines
+ sed -e 's:(datadir)/pkgconfig:(libdir)/pkgconfig:g' \
+ -i Makefile.am || die "sed failed"
+
+ eautomake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc ChangeLog README TODO
+}