summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2007-03-15 13:41:05 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2007-03-15 13:41:05 +0000
commit12a56920d4e147d629d074a0bff7e21b7d69b07a (patch)
tree498e00eb6617ea866ce1f4725409bf2b2f4c13d0 /app-text/kbibtex
parentStable on ppc64; bug #169987 (diff)
downloadgentoo-2-12a56920d4e147d629d074a0bff7e21b7d69b07a.tar.gz
gentoo-2-12a56920d4e147d629d074a0bff7e21b7d69b07a.tar.bz2
gentoo-2-12a56920d4e147d629d074a0bff7e21b7d69b07a.zip
Applied various patches from upstream, previous patch was already present upstream and so replaced it with their patch for consistency.
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-text/kbibtex')
-rw-r--r--app-text/kbibtex/ChangeLog14
-rw-r--r--app-text/kbibtex/files/digest-kbibtex-0.1.5-r23
-rw-r--r--app-text/kbibtex/files/kbibtex-0.1.5-filteredselection.patch41
-rw-r--r--app-text/kbibtex/files/kbibtex-0.1.5-gcc4.2.patch (renamed from app-text/kbibtex/files/kbibtex-0.1.5-compile-fix.patch)8
-rw-r--r--app-text/kbibtex/files/kbibtex-0.1.5-storesearchurls.patch12
-rw-r--r--app-text/kbibtex/files/kbibtex-0.1.5-webquerypubmedmultiplequeries.patch10
-rw-r--r--app-text/kbibtex/kbibtex-0.1.5-r2.ebuild28
7 files changed, 111 insertions, 5 deletions
diff --git a/app-text/kbibtex/ChangeLog b/app-text/kbibtex/ChangeLog
index 631bf5359f7a..f61adcb669aa 100644
--- a/app-text/kbibtex/ChangeLog
+++ b/app-text/kbibtex/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for app-text/kbibtex
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/kbibtex/ChangeLog,v 1.17 2007/03/15 08:53:41 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/kbibtex/ChangeLog,v 1.18 2007/03/15 13:41:05 cryos Exp $
+
+*kbibtex-0.1.5-r2 (15 Mar 2007)
+
+ 15 Mar 2007; Marcus D. Hanwell <cryos@gentoo.org>
+ -files/kbibtex-0.1.5-compile-fix.patch,
+ +files/kbibtex-0.1.5-filteredselection.patch,
+ +files/kbibtex-0.1.5-gcc4.2.patch,
+ +files/kbibtex-0.1.5-storesearchurls.patch,
+ +files/kbibtex-0.1.5-webquerypubmedmultiplequeries.patch,
+ +kbibtex-0.1.5-r2.ebuild:
+ Applied various patches from upstream, previous patch was already present
+ upstream and so replaced it with their patch for consistency.
15 Mar 2007; Marcus D. Hanwell <cryos@gentoo.org>
+files/kbibtex-0.1.5-compile-fix.patch, -kbibtex-0.1.5.ebuild,
diff --git a/app-text/kbibtex/files/digest-kbibtex-0.1.5-r2 b/app-text/kbibtex/files/digest-kbibtex-0.1.5-r2
new file mode 100644
index 000000000000..c1bbfb4304e4
--- /dev/null
+++ b/app-text/kbibtex/files/digest-kbibtex-0.1.5-r2
@@ -0,0 +1,3 @@
+MD5 83a8c1cade06837431b6ebe79d13ef7b kbibtex-0.1.5.tar.bz2 556109
+RMD160 7a7c6ce9ff4b392104e0b35eb888eaa7e7a20383 kbibtex-0.1.5.tar.bz2 556109
+SHA256 588cbd5055c0baea950263c8d768c13c69ef72c54543137dea4d88fb7e4f8f13 kbibtex-0.1.5.tar.bz2 556109
diff --git a/app-text/kbibtex/files/kbibtex-0.1.5-filteredselection.patch b/app-text/kbibtex/files/kbibtex-0.1.5-filteredselection.patch
new file mode 100644
index 000000000000..b5012d453c37
--- /dev/null
+++ b/app-text/kbibtex/files/kbibtex-0.1.5-filteredselection.patch
@@ -0,0 +1,41 @@
+Index: src/documentlistview.cpp
+===================================================================
+--- src/documentlistview.cpp (Revision 301)
++++ src/documentlistview.cpp (Revision 302)
+@@ -221,10 +221,13 @@
+ while ( it.current() )
+ {
+ DocumentListViewItem * kblvi = dynamic_cast<DocumentListViewItem*>( it.current() );
+- m_bibtexFile->deleteElement( kblvi->element() );
+- it++;
+- takeItem( kblvi );
+- delete ( kblvi );
++ if ( kblvi->isVisible() )
++ {
++ m_bibtexFile->deleteElement( kblvi->element() );
++ it++;
++ takeItem( kblvi );
++ delete ( kblvi );
++ }
+ }
+
+ if ( above )
+@@ -246,7 +249,7 @@
+ {
+ DocumentListViewItem * kblvi = dynamic_cast<DocumentListViewItem*>( it.current() );
+ BibTeX::Entry *entry = dynamic_cast<BibTeX::Entry*>( kblvi->element() );
+- if ( entry != NULL )
++ if ( entry != NULL && kblvi->isVisible() )
+ {
+ if ( !refs.isEmpty() )
+ refs.append( "," );
+@@ -621,7 +624,8 @@
+ while ( it.current() )
+ {
+ DocumentListViewItem * kblvi = dynamic_cast<DocumentListViewItem*>( it.current() );
+- exporter->save( &buffer, kblvi->element() );
++ if ( kblvi->isVisible() )
++ exporter->save( &buffer, kblvi->element() );
+ it++;
+ }
+ delete exporter;
diff --git a/app-text/kbibtex/files/kbibtex-0.1.5-compile-fix.patch b/app-text/kbibtex/files/kbibtex-0.1.5-gcc4.2.patch
index 9f961e083227..56f5e721a6f3 100644
--- a/app-text/kbibtex/files/kbibtex-0.1.5-compile-fix.patch
+++ b/app-text/kbibtex/files/kbibtex-0.1.5-gcc4.2.patch
@@ -1,7 +1,7 @@
-# Patch from Andreas Ntaflos <daff@dword.org> to fix compilation issue
-# 15 Mar 2007 Marcus D. Hanwell <cryos@gentoo.org> from bug 171004.
---- src/fileimporter.h 2007-03-15 05:55:41.000000000 +0100
-+++ src/fileimporter.h.new 2007-03-15 05:56:45.000000000 +0100
+Index: src/fileimporter.h
+===================================================================
+--- src/fileimporter.h (Revision 307)
++++ src/fileimporter.h (Arbeitskopie)
@@ -39,7 +39,7 @@
~FileImporter();
diff --git a/app-text/kbibtex/files/kbibtex-0.1.5-storesearchurls.patch b/app-text/kbibtex/files/kbibtex-0.1.5-storesearchurls.patch
new file mode 100644
index 000000000000..205ca83f0454
--- /dev/null
+++ b/app-text/kbibtex/files/kbibtex-0.1.5-storesearchurls.patch
@@ -0,0 +1,12 @@
+diff -Naur kbibtex-0.1.5_orig/src/settings.cpp kbibtex-0.1.5/src/settings.cpp
+--- kbibtex-0.1.5_orig/src/settings.cpp 2006-10-03 21:14:45.000000000 +0200
++++ kbibtex-0.1.5/src/settings.cpp 2007-02-27 13:20:13.000000000 +0100
+@@ -170,7 +170,7 @@
+
+ config->setGroup( "SearchURLs" );
+ int i = 1;
+- for ( QValueList<SearchURL*>::ConstIterator it = searchURLs.begin(); it != searchURLs.end(); ++it )
++ for ( QValueList<SearchURL*>::ConstIterator it = searchURLs.begin(); it != searchURLs.end(); ++it, ++i )
+ {
+ config->writeEntry( QString( "SearchURLDescription%1" ).arg( i ), ( *it ) ->description );
+ config->writeEntry( QString( "SearchURL%1" ).arg( i ), ( *it ) ->url );
diff --git a/app-text/kbibtex/files/kbibtex-0.1.5-webquerypubmedmultiplequeries.patch b/app-text/kbibtex/files/kbibtex-0.1.5-webquerypubmedmultiplequeries.patch
new file mode 100644
index 000000000000..30449f89c4b4
--- /dev/null
+++ b/app-text/kbibtex/files/kbibtex-0.1.5-webquerypubmedmultiplequeries.patch
@@ -0,0 +1,10 @@
+--- kbibtex-0.1.5_orig/src/webquerypubmed.cpp 2006-10-04 21:10:15.000000000 +0200
++++ kbibtex-0.1.5/src/webquerypubmed.cpp 2007-02-27 13:44:16.000000000 +0100
+@@ -206,6 +206,7 @@
+ doc.setContent( buffer );
+ QDomElement docElem = doc.documentElement();
+ ResultParser resultParser( m_listViewResults, doc.documentElement() );
++ buffer->close();
+
+ setEnabled( TRUE );
+ QApplication::restoreOverrideCursor();
diff --git a/app-text/kbibtex/kbibtex-0.1.5-r2.ebuild b/app-text/kbibtex/kbibtex-0.1.5-r2.ebuild
new file mode 100644
index 000000000000..86468c528365
--- /dev/null
+++ b/app-text/kbibtex/kbibtex-0.1.5-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/kbibtex/kbibtex-0.1.5-r2.ebuild,v 1.1 2007/03/15 13:41:05 cryos Exp $
+
+inherit kde eutils
+
+DESCRIPTION="BibTeX editor for KDE"
+HOMEPAGE="http://www.unix-ag.uni-kl.de/~fischer/kbibtex/"
+SRC_URI="http://www.unix-ag.uni-kl.de/~fischer/kbibtex/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/libxml2-2.6.22
+ >=dev-libs/libxslt-1.1.15"
+RDEPEND="${DEPEND}
+ virtual/tetex
+ >=dev-tex/bibtex2html-1.70"
+
+need-kde 3.3
+
+PATCHES="${FILESDIR}/kbibtex-0.1.5-viewdocument.patch
+ ${FILESDIR}/kbibtex-0.1.5-gcc4.2.patch
+ ${FILESDIR}/kbibtex-0.1.5-storesearchurls.patch
+ ${FILESDIR}/kbibtex-0.1.5-filteredselection.patch
+ ${FILESDIR}/kbibtex-0.1.5-webquerypubmedmultiplequeries.patch"