summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Turk <satai@gentoo.org>2003-02-03 00:50:43 +0000
committerMatthew Turk <satai@gentoo.org>2003-02-03 00:50:43 +0000
commit01390cd3e1ff67e8b3a856eb6c80b9a65a291650 (patch)
tree6be4c7e815b81d2987b65839af0e85a02ce11f53 /app-text/latex-eurosym
parentinitial version (diff)
downloadgentoo-2-01390cd3e1ff67e8b3a856eb6c80b9a65a291650.tar.gz
gentoo-2-01390cd3e1ff67e8b3a856eb6c80b9a65a291650.tar.bz2
gentoo-2-01390cd3e1ff67e8b3a856eb6c80b9a65a291650.zip
Added a couple packages. Thanks to Felix Kurth and Lars Weiler!
Diffstat (limited to 'app-text/latex-eurosym')
-rw-r--r--app-text/latex-eurosym/ChangeLog12
-rw-r--r--app-text/latex-eurosym/files/digest-latex-eurosym-1.21
-rw-r--r--app-text/latex-eurosym/latex-eurosym-1.2.ebuild43
3 files changed, 56 insertions, 0 deletions
diff --git a/app-text/latex-eurosym/ChangeLog b/app-text/latex-eurosym/ChangeLog
new file mode 100644
index 000000000000..f32fdf516298
--- /dev/null
+++ b/app-text/latex-eurosym/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for app-text/latex-foiltex
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/latex-eurosym/ChangeLog,v 1.1 2003/02/03 00:50:43 satai Exp $
+
+*latex-eurosym-1.2 (19 January 2002)
+
+ 19 January 2003; Felix Kurth <felix@fkurth,de> :
+
+ Initial release
+
+
+
diff --git a/app-text/latex-eurosym/files/digest-latex-eurosym-1.2 b/app-text/latex-eurosym/files/digest-latex-eurosym-1.2
new file mode 100644
index 000000000000..0b4b5cf4d387
--- /dev/null
+++ b/app-text/latex-eurosym/files/digest-latex-eurosym-1.2
@@ -0,0 +1 @@
+MD5 2380524da188a992a754d500bc732eef eurosym.tar.gz 151186
diff --git a/app-text/latex-eurosym/latex-eurosym-1.2.ebuild b/app-text/latex-eurosym/latex-eurosym-1.2.ebuild
new file mode 100644
index 000000000000..a64be628e61e
--- /dev/null
+++ b/app-text/latex-eurosym/latex-eurosym-1.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright~ 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Maintainer: Felix Kurth <felix@fkurth.de>
+
+inherit latex-package
+S=${WORKDIR}/eurosym
+DESCRIPTION="LaTeX package and fonts used to set the euro (currency) symbol."
+SRC_URI="ftp://ftp.dante.de/tex-archive/fonts/eurosym.tar.gz"
+HOMEPAGE="ftp://ftp.dante.de/tex-archive/help/Catalogue/entries/eurosym.html"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+SUPPLIER="public"
+
+src_install() {
+ cd ${S}
+ cd src
+ latex-package_src_doinstall all
+ cd ${S}
+ cd tfm
+ latex-package_src_doinstall all
+ cd ${S}
+ cd sty
+ latex-package_src_doinstall all
+ cd ${S}
+ insinto ${TEXMF}/fonts/type1/${SUPPLIER}/latex-eurosym
+ doins contrib/type1/fonts/type1/eurosym/*
+ insinto ${TEXMF}/dvips/config/
+ doins contrib/type1/dvips/eurosym.map
+ cd ${S}
+ dodoc README Changes
+ cd doc
+ dodoc *
+ }
+
+pkg_postinst() {
+ latex-package_pkg_postinst
+ einfo ""
+ einfo "Please edit \"/usr/share/texmf/dvips/config/updmap\" and"
+ einfo "add \"eurosym.map\" on line 24 (extra_modules)"
+ einfo "Then run \"/usr/share/texmf/dvips/config/updmap\""
+ einfo ""
+}