summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2005-06-04 09:41:29 +0000
committerAkinori Hattori <hattya@gentoo.org>2005-06-04 09:41:29 +0000
commitd04d8f3c8c562aae4b989cc230089581e50f426d (patch)
tree4d3694509d6f76425299a1b3d31191e5653950d9 /app-text/mecab
parentVersion bump. (diff)
downloadgentoo-2-d04d8f3c8c562aae4b989cc230089581e50f426d.tar.gz
gentoo-2-d04d8f3c8c562aae4b989cc230089581e50f426d.tar.bz2
gentoo-2-d04d8f3c8c562aae4b989cc230089581e50f426d.zip
don't pass --with-charset if the unicode use flag is not set.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-text/mecab')
-rw-r--r--app-text/mecab/ChangeLog5
-rw-r--r--app-text/mecab/mecab-0.81.ebuild8
2 files changed, 10 insertions, 3 deletions
diff --git a/app-text/mecab/ChangeLog b/app-text/mecab/ChangeLog
index 45645b351948..3349921e4d11 100644
--- a/app-text/mecab/ChangeLog
+++ b/app-text/mecab/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/mecab
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/ChangeLog,v 1.16 2005/05/23 15:17:45 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/ChangeLog,v 1.17 2005/06/04 09:41:29 hattya Exp $
+
+ 04 Jun 2005; Akinori Hattori <hattya@gentoo.org> mecab-0.81.ebuild:
+ don't pass --with-charset if the unicode use flag is not set.
23 May 2005; Gustavo Zacarias <gustavoz@gentoo.org> mecab-0.80.ebuild:
Stable on sparc
diff --git a/app-text/mecab/mecab-0.81.ebuild b/app-text/mecab/mecab-0.81.ebuild
index 2a6117a55ed7..9aecf7a72f5f 100644
--- a/app-text/mecab/mecab-0.81.ebuild
+++ b/app-text/mecab/mecab-0.81.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/mecab-0.81.ebuild,v 1.1 2005/05/22 15:50:53 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/mecab-0.81.ebuild,v 1.2 2005/06/04 09:41:29 hattya Exp $
inherit eutils
@@ -29,7 +29,11 @@ src_unpack() {
}
src_compile() {
- econf $(use_with unicode charset utf8) || die
+ local myconf
+
+ use unicode && myconf="${myconf} --with-charset=utf8"
+
+ econf ${myconf} || die
emake || die
}