summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-08-19 18:33:54 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-08-19 18:33:54 +0000
commit9d7958f419d2adba0bcefb68efded9bdb92ddb7e (patch)
tree5a21f912dafebd92c8bb0d7dcc46eb36f1dc951b /app-text/mftrace
parentMask app-admin/eselect-1.2_rc* for testing, and unmask it in prefix. (diff)
downloadgentoo-2-9d7958f419d2adba0bcefb68efded9bdb92ddb7e.tar.gz
gentoo-2-9d7958f419d2adba0bcefb68efded9bdb92ddb7e.tar.bz2
gentoo-2-9d7958f419d2adba0bcefb68efded9bdb92ddb7e.zip
Py 2.6 fix, closes #279997. Thanks to David Leverton.
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'app-text/mftrace')
-rw-r--r--app-text/mftrace/ChangeLog8
-rw-r--r--app-text/mftrace/files/mftrace-1.2.13-python-2.6.patch18
-rw-r--r--app-text/mftrace/mftrace-1.2.13.ebuild11
3 files changed, 32 insertions, 5 deletions
diff --git a/app-text/mftrace/ChangeLog b/app-text/mftrace/ChangeLog
index c5dae57b9ab8..6183f6e2076a 100644
--- a/app-text/mftrace/ChangeLog
+++ b/app-text/mftrace/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/mftrace
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mftrace/ChangeLog,v 1.50 2009/01/11 21:03:17 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mftrace/ChangeLog,v 1.51 2009/08/19 18:33:54 patrick Exp $
+
+ 19 Aug 2009; Patrick Lauer <patrick@gentoo.org> mftrace-1.2.13.ebuild,
+ +files/mftrace-1.2.13-python-2.6.patch:
+ Py 2.6 fix, closes #279997. Thanks to David Leverton.
11 Jan 2009; Markus Meier <maekke@gentoo.org> mftrace-1.2.13.ebuild:
x86 stable, bug #254222
diff --git a/app-text/mftrace/files/mftrace-1.2.13-python-2.6.patch b/app-text/mftrace/files/mftrace-1.2.13-python-2.6.patch
new file mode 100644
index 000000000000..dd0fb8986080
--- /dev/null
+++ b/app-text/mftrace/files/mftrace-1.2.13-python-2.6.patch
@@ -0,0 +1,18 @@
+--- mftrace-1.2.13/mftrace.py~ 2009-08-02 07:19:04.000000000 +0100
++++ mftrace-1.2.13/mftrace.py 2009-08-02 07:19:06.000000000 +0100
+@@ -326,11 +326,11 @@
+
+ return (name, cods)
+
+-def zip_to_pairs (as):
++def zip_to_pairs (xs):
+ r = []
+- while as:
+- r.append ((as[0], as[1]))
+- as = as[2:]
++ while xs:
++ r.append ((xs[0], xs[1]))
++ xs = xs[2:]
+ return r
+
+ def unzip_pairs (tups):
diff --git a/app-text/mftrace/mftrace-1.2.13.ebuild b/app-text/mftrace/mftrace-1.2.13.ebuild
index e4e2cf21039b..e0b9eccbb7f5 100644
--- a/app-text/mftrace/mftrace-1.2.13.ebuild
+++ b/app-text/mftrace/mftrace-1.2.13.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mftrace/mftrace-1.2.13.ebuild,v 1.7 2009/01/11 21:03:17 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mftrace/mftrace-1.2.13.ebuild,v 1.8 2009/08/19 18:33:54 patrick Exp $
-inherit python multilib toolchain-funcs
+EAPI="2"
+
+inherit python multilib toolchain-funcs eutils
DESCRIPTION="traces TeX fonts to PFA or PFB fonts (formerly pktrace)"
HOMEPAGE="http://lilypond.org/download/sources/mftrace/"
@@ -21,11 +23,14 @@ RDEPEND="${DEPEND}
>=app-text/t1utils-1.25
truetype? ( media-gfx/fontforge )"
-src_compile() {
+src_prepare() {
+ epatch "${FILESDIR}/${P}-python-2.6.patch"
python_version
tc-export CC
econf --datadir=/usr/$(get_libdir)/python${PYVER}/site-packages || \
die "econf failed"
+}
+src_compile() {
emake CFLAGS="-Wall ${CFLAGS}" || die "emake failed"
}