summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-08-09 06:25:45 +0000
committerMichael Weber <xmw@gentoo.org>2012-08-09 06:25:45 +0000
commit44208496132596cd3cc8600d529813b9def541f4 (patch)
tree46fd0c2dd97fb4b6147c29795bf013a7b75086cb /app-text/mupdf
parentSmall fix for jython (diff)
downloadgentoo-2-44208496132596cd3cc8600d529813b9def541f4.tar.gz
gentoo-2-44208496132596cd3cc8600d529813b9def541f4.tar.bz2
gentoo-2-44208496132596cd3cc8600d529813b9def541f4.zip
Version bump, try parallel build.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'app-text/mupdf')
-rw-r--r--app-text/mupdf/ChangeLog10
-rw-r--r--app-text/mupdf/files/mupdf-1.1_rc1-buildsystem.patch22
-rw-r--r--app-text/mupdf/files/mupdf-1.1_rc1-zoom-2.patch (renamed from app-text/mupdf/files/mupdf-9999-zoom-2.patch)0
-rw-r--r--app-text/mupdf/mupdf-1.1_rc1.ebuild61
-rw-r--r--app-text/mupdf/mupdf-9999.ebuild11
5 files changed, 97 insertions, 7 deletions
diff --git a/app-text/mupdf/ChangeLog b/app-text/mupdf/ChangeLog
index 8b3fa1900b1a..275b44841a9f 100644
--- a/app-text/mupdf/ChangeLog
+++ b/app-text/mupdf/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-text/mupdf
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/ChangeLog,v 1.46 2012/07/04 19:34:29 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/ChangeLog,v 1.47 2012/08/09 06:25:45 xmw Exp $
+
+*mupdf-1.1_rc1 (09 Aug 2012)
+
+ 09 Aug 2012; Michael Weber <xmw@gentoo.org>
+ +files/mupdf-1.1_rc1-buildsystem.patch, +files/mupdf-1.1_rc1-zoom-2.patch,
+ +mupdf-1.1_rc1.ebuild, -files/mupdf-9999-zoom-2.patch, mupdf-1.0.ebuild,
+ mupdf-9999.ebuild:
+ Version bump, try parallel build.
04 Jul 2012; Michael Weber <xmw@gentoo.org> +files/mupdf-1.0-zoom.patch,
+files/mupdf-9999-zoom-2.patch, -files/mupdf-9999-zoom-1.patch,
diff --git a/app-text/mupdf/files/mupdf-1.1_rc1-buildsystem.patch b/app-text/mupdf/files/mupdf-1.1_rc1-buildsystem.patch
new file mode 100644
index 000000000000..fc7572ebe7d4
--- /dev/null
+++ b/app-text/mupdf/files/mupdf-1.1_rc1-buildsystem.patch
@@ -0,0 +1,22 @@
+--- mupdf-1.0-source/Makerules
++++ mupdf-1.0-source/Makerules
+@@ -6,7 +6,7 @@
+ CFLAGS += -Wall
+
+ ifeq "$(build)" "debug"
+-CFLAGS += -pipe -g -DDEBUG
++CFLAGS += -DDEBUG
+ else ifeq "$(build)" "profile"
+ CFLAGS += -pipe -O2 -DNDEBUG -pg
+ LDFLAGS += -pg
+@@ -21,8 +21,8 @@
+ endif
+
+ ifeq "$(OS)" "Linux"
+-SYS_FREETYPE_INC := `pkg-config --cflags freetype2`
+-X11_LIBS := -lX11 -lXext
++SYS_FREETYPE_INC := $(shell pkg-config --cflags freetype2)
++X11_LIBS := $(shell pkg-config --libs x11 xext)
+ endif
+
+ ifeq "$(OS)" "FreeBSD"
diff --git a/app-text/mupdf/files/mupdf-9999-zoom-2.patch b/app-text/mupdf/files/mupdf-1.1_rc1-zoom-2.patch
index c62122e01eb4..c62122e01eb4 100644
--- a/app-text/mupdf/files/mupdf-9999-zoom-2.patch
+++ b/app-text/mupdf/files/mupdf-1.1_rc1-zoom-2.patch
diff --git a/app-text/mupdf/mupdf-1.1_rc1.ebuild b/app-text/mupdf/mupdf-1.1_rc1.ebuild
new file mode 100644
index 000000000000..b1b9b2dc02c2
--- /dev/null
+++ b/app-text/mupdf/mupdf-1.1_rc1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/mupdf-1.1_rc1.ebuild,v 1.1 2012/08/09 06:25:45 xmw Exp $
+
+EAPI=4
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="a lightweight PDF viewer and toolkit written in portable C"
+HOMEPAGE="http://mupdf.com/"
+SRC_URI=" http://${PN}.googlecode.com/files/${P/_rc/-rc}-source.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="X vanilla"
+
+RDEPEND="media-libs/freetype:2
+ media-libs/jbig2dec
+ >=media-libs/openjpeg-1.5
+ virtual/jpeg
+ X? ( x11-libs/libX11
+ x11-libs/libXext )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P/_rc/-rc}-source
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-buildsystem.patch
+
+ if ! use vanilla ; then
+ epatch "${FILESDIR}"/${P}-zoom-2.patch
+ fi
+}
+
+src_compile() {
+ use X || my_nox11="NOX11=yes MUPDF= "
+
+ emake CC="$(tc-getCC)" OS=Linux \
+ build=debug verbose=true ${my_nox11}
+}
+
+src_install() {
+ emake prefix="${ED}usr" libdir="${ED}usr/$(get_libdir)" \
+ build=debug verbose=true ${my_nox11} install
+
+ insinto /usr/include
+ doins pdf/mupdf{,-internal}.h
+ doins fitz/fitz{,-internal}.h
+ doins xps/muxps{,-internal}.h
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins debian/mupdf.pc
+
+ if use X ; then
+ domenu debian/mupdf.desktop
+ doicon debian/mupdf.xpm
+ fi
+ dodoc README doc/{example.c,overview.txt}
+}
diff --git a/app-text/mupdf/mupdf-9999.ebuild b/app-text/mupdf/mupdf-9999.ebuild
index fa377e6e1d9f..82642ace58cb 100644
--- a/app-text/mupdf/mupdf-9999.ebuild
+++ b/app-text/mupdf/mupdf-9999.ebuild
@@ -1,15 +1,14 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/mupdf-9999.ebuild,v 1.21 2012/07/04 19:34:29 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/mupdf-9999.ebuild,v 1.22 2012/08/09 06:25:45 xmw Exp $
EAPI=4
-EGIT_REPO_URI="git://git.ghostscript.com/mupdf.git"
-
inherit eutils flag-o-matic git-2 multilib toolchain-funcs
DESCRIPTION="a lightweight PDF viewer and toolkit written in portable C"
HOMEPAGE="http://mupdf.com/"
+EGIT_REPO_URI="git://git.ghostscript.com/mupdf.git"
LICENSE="GPL-3"
SLOT="0"
@@ -26,10 +25,10 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.0-buildsystem.patch
+ epatch "${FILESDIR}"/${PN}-1.1_rc1-buildsystem.patch
if ! use vanilla ; then
- epatch "${FILESDIR}"/${PN}-9999-zoom-2.patch
+ epatch "${FILESDIR}"/${PN}-1.1_rc1-zoom-2.patch
fi
}
@@ -37,7 +36,7 @@ src_compile() {
use X || my_nox11="NOX11=yes MUPDF= "
emake CC="$(tc-getCC)" OS=Linux \
- build=debug verbose=true ${my_nox11} -j1
+ build=debug verbose=true ${my_nox11}
}
src_install() {