summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-01-22 15:29:58 +0000
committerUlrich Müller <ulm@gentoo.org>2008-01-22 15:29:58 +0000
commitfeb5f2d71b3650a9865b5b130e2d6497334bdbbb (patch)
tree3727bbd92c4782646feee86469725d6b88c74c81 /app-text/nopaste
parentStable for HPPA (bug #207042). (diff)
downloadgentoo-2-feb5f2d71b3650a9865b5b130e2d6497334bdbbb.tar.gz
gentoo-2-feb5f2d71b3650a9865b5b130e2d6497334bdbbb.tar.bz2
gentoo-2-feb5f2d71b3650a9865b5b130e2d6497334bdbbb.zip
Version bump. Fix output redirection, bug 205525.
(Portage version: 2.1.4)
Diffstat (limited to 'app-text/nopaste')
-rw-r--r--app-text/nopaste/ChangeLog10
-rw-r--r--app-text/nopaste/files/digest-nopaste-28353
-rw-r--r--app-text/nopaste/files/nopaste-2835-output-redirect.patch11
-rw-r--r--app-text/nopaste/nopaste-2835.ebuild30
4 files changed, 52 insertions, 2 deletions
diff --git a/app-text/nopaste/ChangeLog b/app-text/nopaste/ChangeLog
index 0d2f721358e2..1216194c24f3 100644
--- a/app-text/nopaste/ChangeLog
+++ b/app-text/nopaste/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/nopaste
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/nopaste/ChangeLog,v 1.18 2007/11/08 16:11:30 drac Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/nopaste/ChangeLog,v 1.19 2008/01/22 15:29:57 ulm Exp $
+
+*nopaste-2835 (22 Jan 2008)
+
+ 22 Jan 2008; Ulrich Mueller <ulm@gentoo.org>
+ +files/nopaste-2835-output-redirect.patch, +nopaste-2835.ebuild:
+ Version bump. Fix output redirection, bug 205525.
*nopaste-2802 (08 Nov 2007)
diff --git a/app-text/nopaste/files/digest-nopaste-2835 b/app-text/nopaste/files/digest-nopaste-2835
new file mode 100644
index 000000000000..6369ffc565da
--- /dev/null
+++ b/app-text/nopaste/files/digest-nopaste-2835
@@ -0,0 +1,3 @@
+MD5 51d64938a830b2eb523b6755cee4451c nopaste-2835 4227
+RMD160 db7729cc251d67a76f602266414528906f5ba56d nopaste-2835 4227
+SHA256 ac9b8fec84b19ccdf96557bc3564371138db51f1d2c0c4197fd7644074c202a2 nopaste-2835 4227
diff --git a/app-text/nopaste/files/nopaste-2835-output-redirect.patch b/app-text/nopaste/files/nopaste-2835-output-redirect.patch
new file mode 100644
index 000000000000..d1249e6e5eb3
--- /dev/null
+++ b/app-text/nopaste/files/nopaste-2835-output-redirect.patch
@@ -0,0 +1,11 @@
+--- nopaste~ 2008-01-22 16:15:37.000000000 +0100
++++ nopaste 2008-01-22 16:16:31.000000000 +0100
+@@ -141,7 +141,7 @@
+
+ urls << nopaste($options.nick, $options.desc, gets(nil), $options.lang) until ARGV.empty?
+ begin
+- IO.popen("xclip 2>/dev/null", "w") {|p| p.print urls.map {|u| u.to_s}.join(' ') }
++ IO.popen("xclip >/dev/null 2>&1", "w") {|p| p.print urls.map {|u| u.to_s}.join(' ') }
+ rescue Errno::EPIPE
+ begin
+ IO.popen("xcut 2>/dev/null", "w") {|p| p.print urls.map {|u| u.to_s}.join(' ') }
diff --git a/app-text/nopaste/nopaste-2835.ebuild b/app-text/nopaste/nopaste-2835.ebuild
new file mode 100644
index 000000000000..5262c6ca9ccc
--- /dev/null
+++ b/app-text/nopaste/nopaste-2835.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/nopaste/nopaste-2835.ebuild,v 1.1 2008/01/22 15:29:57 ulm Exp $
+
+inherit eutils
+
+DESCRIPTION="command-line interface to rafb.net/paste"
+HOMEPAGE="http://n01se.net/agriffis/nopaste"
+SRC_URI="${HOMEPAGE}/${P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc-fbsd ~sparc ~x86 ~x86-fbsd"
+IUSE="X"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-lang/ruby
+ X? ( x11-misc/xclip )"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp "${DISTDIR}/${P}" ${PN}
+ epatch "${FILESDIR}/${P}-output-redirect.patch"
+}
+
+src_install() {
+ dobin ${PN} || die
+}