summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-02-02 10:25:16 +0000
committerJustin Lecher <jlec@gentoo.org>2012-02-02 10:25:16 +0000
commitf684fc065da99888a464892e44881ec78abb3382 (patch)
treed93a6a27bd8c8400d26423c3ddbfd61fb16946c4 /app-text/pastebin
parentDon't crash when printing, upstream bug #543520, thanks to gringo for reporting. (diff)
downloadgentoo-2-f684fc065da99888a464892e44881ec78abb3382.tar.gz
gentoo-2-f684fc065da99888a464892e44881ec78abb3382.tar.bz2
gentoo-2-f684fc065da99888a464892e44881ec78abb3382.zip
Reinstall latest version and drop correct one
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'app-text/pastebin')
-rw-r--r--app-text/pastebin/ChangeLog6
-rw-r--r--app-text/pastebin/pastebin-0.6.2-r1.ebuild (renamed from app-text/pastebin/pastebin-0.6.2.ebuild)16
2 files changed, 18 insertions, 4 deletions
diff --git a/app-text/pastebin/ChangeLog b/app-text/pastebin/ChangeLog
index 892746f982cb..944e737bcfe5 100644
--- a/app-text/pastebin/ChangeLog
+++ b/app-text/pastebin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/pastebin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pastebin/ChangeLog,v 1.16 2012/02/02 07:25:41 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pastebin/ChangeLog,v 1.17 2012/02/02 10:25:15 jlec Exp $
+
+ 02 Feb 2012; Justin Lecher <jlec@gentoo.org> -pastebin-0.6.2.ebuild,
+ +pastebin-0.6.2-r1.ebuild:
+ Reinstall latest version and drop correct one
02 Feb 2012; Justin Lecher <jlec@gentoo.org> -pastebin-0.6.2-r1.ebuild:
Dropped old
diff --git a/app-text/pastebin/pastebin-0.6.2.ebuild b/app-text/pastebin/pastebin-0.6.2-r1.ebuild
index 4e9686efc3ab..72bf49b43b35 100644
--- a/app-text/pastebin/pastebin-0.6.2.ebuild
+++ b/app-text/pastebin/pastebin-0.6.2-r1.ebuild
@@ -1,6 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pastebin/pastebin-0.6.2.ebuild,v 1.4 2011/01/11 22:28:52 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pastebin/pastebin-0.6.2-r1.ebuild,v 1.6 2012/02/02 10:25:15 jlec Exp $
+
+EAPI=4
+
+inherit eutils perl-app
DESCRIPTION="CLI to pastebin.com"
HOMEPAGE="http://code.google.com/p/pastebin-cli/"
@@ -14,6 +18,12 @@ IUSE=""
DEPEND=""
RDEPEND="dev-perl/libwww-perl"
+S="${WORKDIR}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-lnot-specified.patch
+}
+
src_install() {
- dobin ${PN} || die
+ dobin ${PN}
}