summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-11-13 12:06:11 +0000
committerMamoru Komachi <usata@gentoo.org>2004-11-13 12:06:11 +0000
commit55a2b70180da8a1d565329736bb4f95251228dac (patch)
tree2bac127814d1157119cd79873a4cb97bd4d7118d /app-text/pdftk/pdftk-1.12.ebuild
parentVersion bumped. Marked 2.94.13-r2 stable on alpha. (Manifest recommit) (diff)
downloadgentoo-2-55a2b70180da8a1d565329736bb4f95251228dac.tar.gz
gentoo-2-55a2b70180da8a1d565329736bb4f95251228dac.tar.bz2
gentoo-2-55a2b70180da8a1d565329736bb4f95251228dac.zip
Version bumped.
Diffstat (limited to 'app-text/pdftk/pdftk-1.12.ebuild')
-rw-r--r--app-text/pdftk/pdftk-1.12.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-text/pdftk/pdftk-1.12.ebuild b/app-text/pdftk/pdftk-1.12.ebuild
new file mode 100644
index 000000000000..83b7c01f4ffc
--- /dev/null
+++ b/app-text/pdftk/pdftk-1.12.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdftk/pdftk-1.12.ebuild,v 1.1 2004/11/13 12:06:11 usata Exp $
+
+DESCRIPTION="A tool for manipulating PDF documents"
+HOMEPAGE="http://www.accesspdf.com/pdftk"
+SRC_URI="http://www.pdfhacks.com/pdftk/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="virtual/libc
+ >=sys-devel/gcc-3.3"
+S=${WORKDIR}/${P}/${PN}
+
+pkg_setup() {
+ if [ -z "$(which gcj 2>/dev/null)" ]; then
+ eerror "It seems that your system doesn't provides a Java compiler."
+ eerror "Re-emerge sys-devel/gcc with \"java\" and \"gcj\" enabled."
+ die "gcj not found."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ # force usage of custom CFLAGS.
+ mv ${S}/Makefile.Generic ${T}/Makefile.Generic.orig
+ sed 's:-O2:\$(CFLAGS):g' \
+ < ${T}/Makefile.Generic.orig > ${S}/Makefile.Generic
+}
+
+src_compile() {
+ # java-config settings break compilation by gcj.
+ unset CLASSPATH
+ unset JAVA_HOME
+ make -f Makefile.Generic || die "Compilation failed."
+}
+
+src_install() {
+ dobin pdftk
+ newman ../pdftk.1.txt pdftk.1
+ dohtml ../pdftk.1.html
+}