summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-05-29 08:03:38 +0000
committerTorsten Veller <tove@gentoo.org>2011-05-29 08:03:38 +0000
commit2825e413e2d8a7280e8844a485b835e32a7cfe5d (patch)
treeea020d489b92e84e3e90fc1ac5ff379108fc699a /app-text/po4a
parentx86 stable wrt bug #367827 (diff)
downloadgentoo-2-2825e413e2d8a7280e8844a485b835e32a7cfe5d.tar.gz
gentoo-2-2825e413e2d8a7280e8844a485b835e32a7cfe5d.tar.bz2
gentoo-2-2825e413e2d8a7280e8844a485b835e32a7cfe5d.zip
Depend on dev-libs/libxslt, app-text/docbook-xsl-stylesheets (#368909), app-text/docbook-xml-dtd:4.1.2. Work around the endless waiting if output is redirected (#369011)
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'app-text/po4a')
-rw-r--r--app-text/po4a/ChangeLog8
-rw-r--r--app-text/po4a/files/0.41-po4a-build.patch16
-rw-r--r--app-text/po4a/po4a-0.41.ebuild6
3 files changed, 28 insertions, 2 deletions
diff --git a/app-text/po4a/ChangeLog b/app-text/po4a/ChangeLog
index 0a43cabe5071..8a9f98e81674 100644
--- a/app-text/po4a/ChangeLog
+++ b/app-text/po4a/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/po4a
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/po4a/ChangeLog,v 1.53 2011/05/22 08:13:38 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/po4a/ChangeLog,v 1.54 2011/05/29 08:03:38 tove Exp $
+
+ 29 May 2011; Torsten Veller <tove@gentoo.org> +files/0.41-po4a-build.patch,
+ po4a-0.41.ebuild:
+ Depend on dev-libs/libxslt, app-text/docbook-xsl-stylesheets (#368909),
+ app-text/docbook-xml-dtd:4.1.2. Work around the endless waiting if output is
+ redirected (#369011)
*po4a-0.41 (22 May 2011)
diff --git a/app-text/po4a/files/0.41-po4a-build.patch b/app-text/po4a/files/0.41-po4a-build.patch
new file mode 100644
index 000000000000..f869775ccee2
--- /dev/null
+++ b/app-text/po4a/files/0.41-po4a-build.patch
@@ -0,0 +1,16 @@
+--- a/Po4aBuilder.pm
++++ b/Po4aBuilder.pm
+@@ -29,7 +29,12 @@
+ my $self = shift;
+ $self->depends_on('binpo');
+ $self->make_files_writable("po/pod");
+- system("./share/po4a-build -f po4a-build.conf") && die;
++ { # Fix for massive slowdown/Memory consumption
++ open( my $fh, '-|', qw( ./share/po4a-build -f po4a-build.conf )) or die;
++ while( defined ( my $line = <$fh> ) ){
++ print $line;
++ }
++ }
+ File::Path::mkpath( File::Spec->catdir( 'blib', 'manl10n' ), 0, oct(777) );
+ system ("cp -R _build/po4a/man/* blib/manl10n") && die;
+ }
diff --git a/app-text/po4a/po4a-0.41.ebuild b/app-text/po4a/po4a-0.41.ebuild
index 0a7f4fee4ffe..9f40913eed96 100644
--- a/app-text/po4a/po4a-0.41.ebuild
+++ b/app-text/po4a/po4a-0.41.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/po4a/po4a-0.41.ebuild,v 1.1 2011/05/22 08:13:38 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/po4a/po4a-0.41.ebuild,v 1.2 2011/05/29 08:03:38 tove Exp $
EAPI=4
@@ -18,13 +18,17 @@ IUSE="test"
RDEPEND="dev-perl/SGMLSpm
>=sys-devel/gettext-0.13
app-text/openjade
+ dev-libs/libxslt
dev-perl/Locale-gettext
dev-perl/TermReadKey
dev-perl/Text-WrapI18N"
DEPEND="${RDEPEND}
>=virtual/perl-Module-Build-0.34.0201
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.1.2
test? ( app-text/docbook-sgml-dtd
app-text/docbook-sgml-utils
virtual/tex-base )"
SRC_TEST="do"
+PATCHES=( "${FILESDIR}"/0.41-po4a-build.patch )