summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2015-01-03 11:24:17 +0000
committerMatthias Maier <tamiko@gentoo.org>2015-01-03 11:24:17 +0000
commit332cb89bf9fc33d3c2299f01b79bf0c3e97b91ed (patch)
treec3b7476acecf6b495ddae13668436451d1d8c95e /app-text/poppler
parentImprove use of distutils-r1. Ensure correct Python impl for waf-utils. (diff)
downloadgentoo-2-332cb89bf9fc33d3c2299f01b79bf0c3e97b91ed.tar.gz
gentoo-2-332cb89bf9fc33d3c2299f01b79bf0c3e97b91ed.tar.bz2
gentoo-2-332cb89bf9fc33d3c2299f01b79bf0c3e97b91ed.zip
workaround for multilib portage, fix qt library locations for 32bit variant
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key BD3A97A3)
Diffstat (limited to 'app-text/poppler')
-rw-r--r--app-text/poppler/ChangeLog7
-rw-r--r--app-text/poppler/files/poppler-0.28.1-fix-multilib-configuration.patch23
-rw-r--r--app-text/poppler/poppler-0.28.1.ebuild7
-rw-r--r--app-text/poppler/poppler-0.29.0.ebuild5
4 files changed, 36 insertions, 6 deletions
diff --git a/app-text/poppler/ChangeLog b/app-text/poppler/ChangeLog
index 9501d27021e5..9ceacea4afd8 100644
--- a/app-text/poppler/ChangeLog
+++ b/app-text/poppler/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/poppler
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/ChangeLog,v 1.439 2015/01/02 14:20:26 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/ChangeLog,v 1.440 2015/01/03 11:24:17 tamiko Exp $
+
+ 03 Jan 2015; Matthias Maier <tamiko@gentoo.org>
+ +files/poppler-0.28.1-fix-multilib-configuration.patch, poppler-0.28.1.ebuild,
+ poppler-0.29.0.ebuild:
+ workaround for multilib portage, fix qt library locations for 32bit variant
*poppler-0.29.0 (02 Jan 2015)
diff --git a/app-text/poppler/files/poppler-0.28.1-fix-multilib-configuration.patch b/app-text/poppler/files/poppler-0.28.1-fix-multilib-configuration.patch
new file mode 100644
index 000000000000..f0a8d3c7eb4a
--- /dev/null
+++ b/app-text/poppler/files/poppler-0.28.1-fix-multilib-configuration.patch
@@ -0,0 +1,23 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 7178d25..934f38f 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -119,6 +119,18 @@ else(${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}.${CMAKE_PATCH_VERSION} VERSIO
+ message("-- CMake >= 2.8.8 is needed to enable Qt5")
+ endif(${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}.${CMAKE_PATCH_VERSION} VERSION_GREATER 2.8.7)
+
++#
++# Ugly workaround: Manually patch library paths for Qt4 and Qt5:
++#
++IF( "${CMAKE_CXX_FLAGS}" MATCHES "-m32")
++ GET_CMAKE_PROPERTY(_res VARIABLES)
++ FOREACH(_var ${_res})
++ IF(_var MATCHES "^QT" AND ${_var} MATCHES "lib64")
++ STRING(REPLACE "lib64" "lib32" ${_var} "${${_var}}")
++ ENDIF()
++ ENDFOREACH()
++ENDIF()
++
+ macro_optional_find_package(Cairo ${CAIRO_VERSION})
+ if(CAIRO_FOUND)
+ set(HAVE_CAIRO ${CAIRO_FOUND})
diff --git a/app-text/poppler/poppler-0.28.1.ebuild b/app-text/poppler/poppler-0.28.1.ebuild
index fe1b76e0a4bf..0c2a07ecf01d 100644
--- a/app-text/poppler/poppler-0.28.1.ebuild
+++ b/app-text/poppler/poppler-0.28.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.28.1.ebuild,v 1.2 2014/12/03 20:57:38 tamiko Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.28.1.ebuild,v 1.3 2015/01/03 11:24:17 tamiko Exp $
EAPI=5
@@ -62,7 +62,8 @@ DOCS=(AUTHORS NEWS README README-XPDF TODO)
PATCHES=(
"${FILESDIR}/${PN}-0.26.0-qt5-dependencies.patch"
- "${FILESDIR}/${P}-respect-cflags.patch" )
+ "${FILESDIR}/${P}-respect-cflags.patch"
+ "${FILESDIR}/${P}-fix-multilib-configuration.patch" )
src_configure() {
local mycmakeargs=(
diff --git a/app-text/poppler/poppler-0.29.0.ebuild b/app-text/poppler/poppler-0.29.0.ebuild
index c7c39b436d2a..147feca958bb 100644
--- a/app-text/poppler/poppler-0.29.0.ebuild
+++ b/app-text/poppler/poppler-0.29.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.29.0.ebuild,v 1.1 2015/01/02 14:20:26 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.29.0.ebuild,v 1.2 2015/01/03 11:24:17 tamiko Exp $
EAPI=5
@@ -62,7 +62,8 @@ DOCS=(AUTHORS NEWS README README-XPDF TODO)
PATCHES=(
"${FILESDIR}/${PN}-0.26.0-qt5-dependencies.patch"
- "${FILESDIR}/${PN}-0.28.1-respect-cflags.patch" )
+ "${FILESDIR}/${PN}-0.28.1-respect-cflags.patch"
+ "${FILESDIR}/${PN}-0.28.1-fix-multilib-configuration.patch" )
src_configure() {
local mycmakeargs=(