summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-08-13 10:17:34 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-08-13 10:17:34 +0000
commitdc5469fdbe812a1743cdedbaed6fb4d26c3b9c0b (patch)
treeec41ad4a1f6c5c581b62089930ec2619d6014bad /app-text/sgmltools-lite/sgmltools-lite-3.0.3-r10.ebuild
parentStable on hppa. (diff)
downloadgentoo-2-dc5469fdbe812a1743cdedbaed6fb4d26c3b9c0b.tar.gz
gentoo-2-dc5469fdbe812a1743cdedbaed6fb4d26c3b9c0b.tar.bz2
gentoo-2-dc5469fdbe812a1743cdedbaed6fb4d26c3b9c0b.zip
New revision, avoids collisions with sgml-common and linuxdoc-tools (to be added soon). Bug #88232
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-text/sgmltools-lite/sgmltools-lite-3.0.3-r10.ebuild')
-rw-r--r--app-text/sgmltools-lite/sgmltools-lite-3.0.3-r10.ebuild97
1 files changed, 97 insertions, 0 deletions
diff --git a/app-text/sgmltools-lite/sgmltools-lite-3.0.3-r10.ebuild b/app-text/sgmltools-lite/sgmltools-lite-3.0.3-r10.ebuild
new file mode 100644
index 000000000000..3b94fc3673c3
--- /dev/null
+++ b/app-text/sgmltools-lite/sgmltools-lite-3.0.3-r10.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/sgmltools-lite/sgmltools-lite-3.0.3-r10.ebuild,v 1.1 2005/08/13 10:17:34 leonardop Exp $
+
+inherit python sgml-catalog
+
+DESCRIPTION="Python interface to SGML software in a DocBook/OpenJade env"
+HOMEPAGE="http://sgmltools-lite.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sgmltools-lite/${P}.tar.gz
+ mirror://sourceforge/sgmltools-lite/nw-eps-icons-0.0.1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~arm ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="tetex"
+
+DEPEND=">=virtual/python-1.5
+ app-text/sgml-common
+ ~app-text/docbook-sgml-dtd-3.1
+ app-text/docbook-dsssl-stylesheets
+ app-text/openjade
+ tetex? ( app-text/jadetex )
+ || (
+ www-client/w3m
+ www-client/lynx )"
+
+
+sgml-catalog_cat_include "/etc/sgml/sgml-lite.cat" \
+ "/usr/share/sgml/stylesheets/sgmltools/sgmltools.cat"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Remove CVS directories from the tree
+ find . -name CVS | xargs rm -rf
+}
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ einstall etcdir=${D}/etc/sgml || die
+
+ dodoc COPYING ChangeLog POSTINSTALL README*
+ dohtml -r .
+
+ cd ${WORKDIR}/nw-eps-icons-0.0.1/images
+ insinto /usr/share/sgml/docbook/dsssl-stylesheets/images
+ doins *.eps
+
+ cd callouts
+ insinto /usr/share/sgml/docbook/dsssl-stylesheets/images/callouts
+ doins *.eps
+
+ rm ${D}/etc/sgml/catalog.{suse,rh62}
+
+ # Remove file provided by sgml-common
+ rm ${D}/usr/bin/sgmlwhich
+
+ # Remove the backends that require tetex
+ use tetex || \
+ rm ${D}/usr/share/sgml/misc/sgmltools/python/backends/{Dvi,Ps,Pdf,JadeTeX}.py
+
+ # List of backends to alias with sgml2*
+ # Do not provide sgml2{txt,rtf,html} anymore, they are part of
+ # linuxdoc-tools
+ local BACKENDS=""
+ use tetex && BACKENDS="ps dvi pdf"
+
+ # Create simple alias scripts that people are used to
+ # And make the manpages for those link to the sgmltools-lite manpage
+ mandir=${D}/usr/share/man/man1
+ ScripTEXT="#!/bin/sh\n/usr/bin/sgmltools --backend="
+ for back in ${BACKENDS}
+ do
+ echo -e ${ScripTEXT}${back} '$*' > sgml2${back}
+ exeinto /usr/bin
+ doexe sgml2${back}
+
+ cd ${mandir}
+ ln -sf sgmltools-lite.1.gz sgml2${back}.1.gz
+ cd ${S}
+ done
+}
+
+pkg_postinst() {
+ python_mod_optimize ${ROOT}usr/share/sgml/misc/sgmltools/python
+ sgml-catalog_pkg_postinst
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${ROOT}usr/share/sgml/misc/sgmltools/python
+ sgml-catalog_pkg_postrm
+}