summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-07-16 15:35:13 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-07-16 15:35:13 +0000
commitfad04a04d857bef6df0df93a1812dd24217c1e28 (patch)
treeabe39cb13d90548901414e1b98e4ab0088d1e31e /app-text/ttf2pk2
parentStable on alpha, bug 555086 (diff)
downloadgentoo-2-fad04a04d857bef6df0df93a1812dd24217c1e28.tar.gz
gentoo-2-fad04a04d857bef6df0df93a1812dd24217c1e28.tar.bz2
gentoo-2-fad04a04d857bef6df0df93a1812dd24217c1e28.zip
bump to texlive 2015 version
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'app-text/ttf2pk2')
-rw-r--r--app-text/ttf2pk2/ChangeLog8
-rw-r--r--app-text/ttf2pk2/ttf2pk2-2.0_p20150521.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/app-text/ttf2pk2/ChangeLog b/app-text/ttf2pk2/ChangeLog
index 51e2413ab45f..3b11fdf5e5df 100644
--- a/app-text/ttf2pk2/ChangeLog
+++ b/app-text/ttf2pk2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/ttf2pk2
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ttf2pk2/ChangeLog,v 1.29 2015/07/15 09:35:38 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ttf2pk2/ChangeLog,v 1.30 2015/07/16 15:35:13 aballier Exp $
+
+*ttf2pk2-2.0_p20150521 (16 Jul 2015)
+
+ 16 Jul 2015; Alexis Ballier <aballier@gentoo.org>
+ +ttf2pk2-2.0_p20150521.ebuild:
+ bump to texlive 2015 version
15 Jul 2015; Alexis Ballier <aballier@gentoo.org>
ttf2pk2-2.0_p20140525.ebuild:
diff --git a/app-text/ttf2pk2/ttf2pk2-2.0_p20150521.ebuild b/app-text/ttf2pk2/ttf2pk2-2.0_p20150521.ebuild
new file mode 100644
index 000000000000..be8bc9ad4f99
--- /dev/null
+++ b/app-text/ttf2pk2/ttf2pk2-2.0_p20150521.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/ttf2pk2/ttf2pk2-2.0_p20150521.ebuild,v 1.1 2015/07/16 15:35:13 aballier Exp $
+
+EAPI=5
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Freetype 2 based TrueType font to TeX's PK format converter"
+HOMEPAGE="http://tug.org/texlive/"
+SRC_URI="mirror://gentoo/texlive-${PV#*_p}-source.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Note about blockers: it is a freetype2 based replacement for ttf2pk and
+# ttf2tfm from freetype1, so block freetype1.
+# It installs some data that collides with
+# dev-texlive/texlive-langcjk-2011[source]. Hope it'd be fixed with 2012,
+# meanwhile we can start dropping freetype1.
+RDEPEND=">=dev-libs/kpathsea-6.2.1
+ media-libs/freetype:2
+ sys-libs/zlib
+ !media-libs/freetype:1
+ !=dev-texlive/texlive-langcjk-2011*[source]"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+S=${WORKDIR}/texlive-${PV#*_p}-source/texk/${PN}
+
+src_configure() {
+ has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
+ econf --with-system-kpathsea \
+ --with-system-freetype2 \
+ --with-system-zlib
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc BUGS README TODO ChangeLog
+}