summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-03-09 11:19:15 +0000
committerFabian Groffen <grobian@gentoo.org>2010-03-09 11:19:15 +0000
commit0afc6cccbd85e10202c1a42b3afd9aae16695476 (patch)
treebfe585a557dd37cecce2966758a67ccd129d1840 /app-text/unrtf
parentFix building with libpng14. (diff)
downloadgentoo-2-0afc6cccbd85e10202c1a42b3afd9aae16695476.tar.gz
gentoo-2-0afc6cccbd85e10202c1a42b3afd9aae16695476.tar.bz2
gentoo-2-0afc6cccbd85e10202c1a42b3afd9aae16695476.zip
Add semi-optimal patch to solve linking issues with libiconv
(Portage version: 2.2.00.15754-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'app-text/unrtf')
-rw-r--r--app-text/unrtf/ChangeLog6
-rw-r--r--app-text/unrtf/files/unrtf-0.21.1-iconv-detection.patch14
-rw-r--r--app-text/unrtf/unrtf-0.21.1.ebuild3
3 files changed, 21 insertions, 2 deletions
diff --git a/app-text/unrtf/ChangeLog b/app-text/unrtf/ChangeLog
index f6e2e5a51bde..c93468c65bd2 100644
--- a/app-text/unrtf/ChangeLog
+++ b/app-text/unrtf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/unrtf
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/unrtf/ChangeLog,v 1.39 2010/02/01 06:40:31 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/unrtf/ChangeLog,v 1.40 2010/03/09 11:19:14 grobian Exp $
+
+ 09 Mar 2010; Fabian Groffen <grobian@gentoo.org> unrtf-0.21.1.ebuild,
+ +files/unrtf-0.21.1-iconv-detection.patch:
+ Add semi-optimal patch to solve linking issues with libiconv
*unrtf-0.21.1 (01 Feb 2010)
diff --git a/app-text/unrtf/files/unrtf-0.21.1-iconv-detection.patch b/app-text/unrtf/files/unrtf-0.21.1-iconv-detection.patch
new file mode 100644
index 000000000000..284e9295a315
--- /dev/null
+++ b/app-text/unrtf/files/unrtf-0.21.1-iconv-detection.patch
@@ -0,0 +1,14 @@
+--- configure.ac
++++ configure.ac
+@@ -44,7 +44,11 @@
+ AC_CANONICAL_HOST
+ case $host in
+ *-*-cygwin*) AC_SUBST(LIBS, ["-liconv"]);;
++ *-*-darwin*) AC_SUBST(LIBS, ["-liconv"]);;
++ *-*-solaris*) AC_SUBST(LIBS, ["-liconv"]);;
+ esac
++# should actually use this instead (from gettext):
++#AM_ICONV
+
+ AC_CONFIG_FILES([Makefile
+ charmaps/Makefile
diff --git a/app-text/unrtf/unrtf-0.21.1.ebuild b/app-text/unrtf/unrtf-0.21.1.ebuild
index 31b7910a56be..989a1c01d15a 100644
--- a/app-text/unrtf/unrtf-0.21.1.ebuild
+++ b/app-text/unrtf/unrtf-0.21.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/unrtf/unrtf-0.21.1.ebuild,v 1.1 2010/02/01 06:40:31 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/unrtf/unrtf-0.21.1.ebuild,v 1.2 2010/03/09 11:19:14 grobian Exp $
inherit eutils autotools
@@ -20,6 +20,7 @@ src_unpack() {
-e 's,/usr/local/lib/,/usr/share/,g' \
"${S}"/src/*.h || die "failed to sed"
cd "${S}"
+ epatch "${FILESDIR}"/${P}-iconv-detection.patch
eautoreconf
}