summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-05-17 16:32:49 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-05-17 16:32:49 +0000
commit5df4c2dee192e9992106606e0bc441ee2d1315ce (patch)
tree1f549ed4602bd618477d519ff1d39e3f6a7e66cd /app-text/xindy/xindy-2.3.ebuild
parentClean up. Remove deprecated slot_rebuild() check. Back to ~ppc. (diff)
downloadgentoo-2-5df4c2dee192e9992106606e0bc441ee2d1315ce.tar.gz
gentoo-2-5df4c2dee192e9992106606e0bc441ee2d1315ce.tar.bz2
gentoo-2-5df4c2dee192e9992106606e0bc441ee2d1315ce.zip
Initial import, thanks to Gour and other people involved in bug #71531 and also thanks to people in #gentoo-lisp for help with having it to work with external clisp
(Portage version: 2.1.5)
Diffstat (limited to 'app-text/xindy/xindy-2.3.ebuild')
-rw-r--r--app-text/xindy/xindy-2.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-text/xindy/xindy-2.3.ebuild b/app-text/xindy/xindy-2.3.ebuild
new file mode 100644
index 000000000000..3f1aadc3326f
--- /dev/null
+++ b/app-text/xindy/xindy-2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xindy/xindy-2.3.ebuild,v 1.1 2008/05/17 16:32:49 aballier Exp $
+
+DESCRIPTION="A Flexible Indexing System"
+
+HOMEPAGE="http://www.xindy.org/"
+SRC_URI="mirror://sourceforge/xindy/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="doc"
+RDEPEND="virtual/latex-base
+ >=dev-lisp/clisp-2.44.1-r1"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+src_compile() {
+ local clisp_dir
+ clisp_dir=`clisp --version | grep "Installation directory:" | sed 's/Installation directory: //'`
+ econf \
+ $(use_enable doc docs) \
+ --enable-external-clisp --enable-clisp-dir=${clisp_dir}
+ emake -j1 || die "Make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc AUTHORS ChangeLog.Gour NEWS README
+}