summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-23 20:35:27 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-23 20:35:27 +0000
commit036b2d5632b999a76758f327da7041608179d9b4 (patch)
tree071d4a6455f84f213e2ec32910432796b5f7d134 /app-text
parentBump. Improves support for bezier curves and opacity, and adds utilities for ... (diff)
downloadgentoo-2-036b2d5632b999a76758f327da7041608179d9b4.tar.gz
gentoo-2-036b2d5632b999a76758f327da7041608179d9b4.tar.bz2
gentoo-2-036b2d5632b999a76758f327da7041608179d9b4.zip
Add patches to fix libgxps-0.2 and texlive-2011 support.
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/evince/ChangeLog8
-rw-r--r--app-text/evince/evince-3.2.1-r1.ebuild111
-rw-r--r--app-text/evince/files/evince-3.2.1-libgxps-0.2.patch45
3 files changed, 163 insertions, 1 deletions
diff --git a/app-text/evince/ChangeLog b/app-text/evince/ChangeLog
index 4244c28a0f2e..02cc21e84960 100644
--- a/app-text/evince/ChangeLog
+++ b/app-text/evince/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/evince
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/evince/ChangeLog,v 1.232 2011/11/16 10:56:14 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/ChangeLog,v 1.233 2011/11/23 20:35:27 tetromino Exp $
+
+*evince-3.2.1-r1 (23 Nov 2011)
+
+ 23 Nov 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +evince-3.2.1-r1.ebuild, +files/evince-3.2.1-libgxps-0.2.patch:
+ Add patches to fix libgxps-0.2 and texlive-2011 support.
16 Nov 2011; Justin Lecher <jlec@gentoo.org> evince-2.32.0-r2.ebuild,
evince-2.32.0-r3.ebuild, evince-3.2.1.ebuild:
diff --git a/app-text/evince/evince-3.2.1-r1.ebuild b/app-text/evince/evince-3.2.1-r1.ebuild
new file mode 100644
index 000000000000..2ab712e1b49a
--- /dev/null
+++ b/app-text/evince/evince-3.2.1-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/evince-3.2.1-r1.ebuild,v 1.1 2011/11/23 20:35:27 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="Simple document viewer for GNOME"
+HOMEPAGE="http://www.gnome.org/projects/evince/"
+
+SRC_URI="${SRC_URI}
+ http://dev.gentoo.org/~tetromino/distfiles/${PN}/${P}-synctex-1.17.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="dbus debug djvu doc dvi gnome-keyring +introspection nautilus t1lib tiff xps"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris"
+
+# Since 2.26.2, can handle poppler without cairo support. Make it optional ?
+# not mature enough
+# atk used in libview
+# gdk-pixbuf used all over the place
+# libX11 used for totem-screensaver
+RDEPEND="
+ >=app-text/libspectre-0.2.0
+ dev-libs/atk
+ >=dev-libs/glib-2.25.11:2
+ >=dev-libs/libxml2-2.5:2
+ sys-libs/zlib
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.0.2:3[introspection?]
+ x11-libs/libX11
+ >=x11-libs/libSM-1
+ x11-libs/libICE
+ gnome-base/gsettings-desktop-schemas
+ || (
+ >=x11-themes/gnome-icon-theme-2.17.1
+ >=x11-themes/hicolor-icon-theme-0.10 )
+ >=x11-libs/cairo-1.10.0
+ >=app-text/poppler-0.16[cairo]
+ djvu? ( >=app-text/djvu-3.5.17 )
+ dvi? (
+ virtual/tex-base
+ dev-libs/kpathsea
+ t1lib? ( >=media-libs/t1lib-5.0.0 ) )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-2.22.0 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6 )
+ nautilus? ( >=gnome-base/nautilus-2.91.4[introspection?] )
+ tiff? ( >=media-libs/tiff-3.6:0 )
+ xps? ( >=app-text/libgxps-0.2.0 )
+"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=app-text/gnome-doc-utils-0.3.2
+ ~app-text/docbook-xml-dtd-4.1.2
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=dev-util/gtk-doc-am-1.13
+ doc? ( >=dev-util/gtk-doc-1.13 )"
+
+ELTCONF="--portage"
+
+# Needs dogtail and pyspi from http://fedorahosted.org/dogtail/
+# Releases: http://people.redhat.com/zcerza/dogtail/releases/
+RESTRICT="test"
+
+pkg_setup() {
+ # Passing --disable-help would drop offline help, that would be inconsistent
+ # with helps of the most of Gnome apps that doesn't require network for that.
+ G2CONF="${G2CONF}
+ --disable-schemas-compile
+ --disable-scrollkeeper
+ --disable-static
+ --disable-tests
+ --enable-pdf
+ --enable-comics
+ --enable-thumbnailer
+ --with-smclient=xsmp
+ --with-platform=gnome
+ --enable-help
+ $(use_enable dbus)
+ $(use_enable djvu)
+ $(use_enable dvi)
+ $(use_with gnome-keyring keyring)
+ $(use_enable introspection)
+ $(use_enable nautilus)
+ $(use_enable t1lib)
+ $(use_enable tiff)
+ $(use_enable xps)"
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+}
+
+src_prepare() {
+ # Do not depend on gnome-icon-theme, bug #326855
+ sed 's/gnome-icon-theme//' -i configure.ac || die "sed failed"
+
+ # Fix .desktop file so menu item shows up
+ epatch "${FILESDIR}"/${PN}-0.7.1-display-menu.patch
+
+ # Upstream patch to fix texlive-2011 compatibility, will be in next release
+ epatch "../${P}-synctex-1.17.patch"
+
+ # Patch from upstream git master branch to fix libgxps-0.2 compatibility
+ epatch "${FILESDIR}/${PN}-3.2.1-libgxps-0.2.patch"
+
+ gnome2_src_prepare
+}
diff --git a/app-text/evince/files/evince-3.2.1-libgxps-0.2.patch b/app-text/evince/files/evince-3.2.1-libgxps-0.2.patch
new file mode 100644
index 000000000000..5bbded6479e9
--- /dev/null
+++ b/app-text/evince/files/evince-3.2.1-libgxps-0.2.patch
@@ -0,0 +1,45 @@
+From 740263e84f812e069c25d32e6fbf40bec4c061e2 Mon Sep 17 00:00:00 2001
+From: Carlos Garcia Campos <carlosgc@gnome.org>
+Date: Sun, 20 Nov 2011 16:18:30 +0100
+Subject: [PATCH] xps: Bump libgxps requirements to 0.2.0
+
+[Alexandre Rostovtsev <tetromino@gentoo.org>: remove update to configure.ac]
+---
+ backend/xps/xps-document.c | 14 ++------------
+ 1 files changed, 2 insertions(+), 12 deletions(-)
+
+diff --git a/backend/xps/xps-document.c b/backend/xps/xps-document.c
+index 6e34f07..cbba96b 100644
+--- a/backend/xps/xps-document.c
++++ b/backend/xps/xps-document.c
+@@ -156,17 +156,7 @@ xps_document_get_page_size (EvDocument *document,
+ double *width,
+ double *height)
+ {
+- GXPSPage *xps_page;
+- guint w, h;
+-
+- xps_page = GXPS_PAGE (page->backend_page);
+-
+- gxps_page_get_size (xps_page, &w, &h);
+-
+- if (width)
+- *width = (gdouble)w;
+- if (height)
+- *height = (gdouble)h;
++ gxps_page_get_size (GXPS_PAGE (page->backend_page), width, height);
+ }
+
+ static EvDocumentInfo *
+@@ -210,7 +200,7 @@ xps_document_render (EvDocument *document,
+ EvRenderContext *rc)
+ {
+ GXPSPage *xps_page;
+- guint page_width, page_height;
++ gdouble page_width, page_height;
+ guint width, height;
+ cairo_surface_t *surface;
+ cairo_t *cr;
+--
+1.7.8.rc3
+