summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-08-09 03:36:53 +0000
committerMichael Weber <xmw@gentoo.org>2011-08-09 03:36:53 +0000
commit13ce3861f317aff9c0eafe55571265b2a9f39552 (patch)
tree2952b8b1386b3cf8c062f1bf40207dbaa68741e1 /app-text
parentVersion bump for dev channel release. Remove old. (diff)
downloadgentoo-2-13ce3861f317aff9c0eafe55571265b2a9f39552.tar.gz
gentoo-2-13ce3861f317aff9c0eafe55571265b2a9f39552.tar.bz2
gentoo-2-13ce3861f317aff9c0eafe55571265b2a9f39552.zip
Update to git-2 eclass, fix src_compile
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/llpp/ChangeLog5
-rw-r--r--app-text/llpp/llpp-9999.ebuild7
2 files changed, 8 insertions, 4 deletions
diff --git a/app-text/llpp/ChangeLog b/app-text/llpp/ChangeLog
index f9eac5ecedf4..a285d765169b 100644
--- a/app-text/llpp/ChangeLog
+++ b/app-text/llpp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/llpp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/llpp/ChangeLog,v 1.8 2011/08/09 03:25:08 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/llpp/ChangeLog,v 1.9 2011/08/09 03:36:53 xmw Exp $
+
+ 09 Aug 2011; Michael Weber <xmw@gentoo.org> llpp-9999.ebuild:
+ Update to git-2 eclass, fix src_compile
*llpp-5 (09 Aug 2011)
diff --git a/app-text/llpp/llpp-9999.ebuild b/app-text/llpp/llpp-9999.ebuild
index d0830b87f920..b3edbbbec140 100644
--- a/app-text/llpp/llpp-9999.ebuild
+++ b/app-text/llpp/llpp-9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/llpp/llpp-9999.ebuild,v 1.5 2011/06/12 16:08:50 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/llpp/llpp-9999.ebuild,v 1.6 2011/08/09 03:36:53 xmw Exp $
EAPI=3
EGIT_REPO_URI="git://repo.or.cz/llpp.git"
-inherit git toolchain-funcs
+inherit git-2 toolchain-funcs
DESCRIPTION="a graphical PDF viewer which aims to superficially resemble less(1)"
HOMEPAGE="http://repo.or.cz/w/llpp.git"
@@ -26,12 +26,13 @@ DEPEND="${RDEPEND}"
src_compile() {
ocamlopt -c -o link.o -ccopt -O link.c || die
+ ocamlopt -c -o parser.cmo parser.ml || die
ocamlopt -c -o main.cmo -I +lablGL main.ml || die
ocamlopt -o llpp \
-I +lablGL str.cmxa unix.cmxa lablgl.cmxa lablglut.cmxa link.o \
-cclib "-lmupdf -lfitz -lz -ljpeg -lopenjpeg -ljbig2dec -lfreetype -lpthread" \
- main.cmx || die
+ parser.cmx main.cmx || die
}
src_install() {