summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-02-26 14:19:59 +0000
committerIan Delaney <idella4@gentoo.org>2015-02-26 14:19:59 +0000
commit2e49654a1e7fe8298b5260030f1ab9a5f79d01c2 (patch)
tree452b84663ba298c6390d0911f1235db45b3e7720 /app-text
parentVersion bump (thanks sping, bug 526508), update ebuilds. (diff)
downloadgentoo-2-2e49654a1e7fe8298b5260030f1ab9a5f79d01c2.tar.gz
gentoo-2-2e49654a1e7fe8298b5260030f1ab9a5f79d01c2.tar.bz2
gentoo-2-2e49654a1e7fe8298b5260030f1ab9a5f79d01c2.zip
revbump; convert -> python-single-r1 and upgrade EAPI, consent by maintainer hwoarang
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/chm2pdf/ChangeLog10
-rw-r--r--app-text/chm2pdf/chm2pdf-0.9.1-r2.ebuild40
2 files changed, 48 insertions, 2 deletions
diff --git a/app-text/chm2pdf/ChangeLog b/app-text/chm2pdf/ChangeLog
index f6451242da99..377702d715e6 100644
--- a/app-text/chm2pdf/ChangeLog
+++ b/app-text/chm2pdf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/chm2pdf
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/chm2pdf/ChangeLog,v 1.14 2014/08/06 07:09:32 patrick Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/chm2pdf/ChangeLog,v 1.15 2015/02/26 14:19:59 idella4 Exp $
+
+*chm2pdf-0.9.1-r2 (26 Feb 2015)
+
+ 26 Feb 2015; Ian Delaney <idella4@gentoo.org> +chm2pdf-0.9.1-r2.ebuild:
+ revbump; convert -> python-single-r1 and upgrade EAPI, consent by maintainer
+ hwoarang
06 Aug 2014; Patrick Lauer <patrick@gentoo.org> chm2pdf-0.9.1-r1.ebuild,
chm2pdf-0.9.1.ebuild:
diff --git a/app-text/chm2pdf/chm2pdf-0.9.1-r2.ebuild b/app-text/chm2pdf/chm2pdf-0.9.1-r2.ebuild
new file mode 100644
index 000000000000..26fd1d6e299d
--- /dev/null
+++ b/app-text/chm2pdf/chm2pdf-0.9.1-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/chm2pdf/chm2pdf-0.9.1-r2.ebuild,v 1.1 2015/02/26 14:19:59 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="A script that converts a CHM file into a single PDF file"
+HOMEPAGE="http://code.google.com/p/chm2pdf/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/pychm[${PYTHON_USEDEP}]
+ app-text/htmldoc
+ >=dev-libs/chmlib-0.40-r1[examples]
+ ${PYTHON_DEPS}"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+PATCHES=( "${FILESDIR}/tempdir.patch" )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare(){
+ python_fix_shebang .
+}
+
+src_install() {
+ default
+ python_doscript ${PN} || die "failed to create executable"
+}