summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-11-29 19:02:05 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-11-29 19:02:05 +0000
commit35039f9ee8ec87252673d8cccd29bc2f1437508d (patch)
tree16759f597434ad96b1face44d1ff1cd051a612f6 /app-text
parentAdd missing slot operator to dev-lang/perl dependency, package installs modul... (diff)
downloadgentoo-2-35039f9ee8ec87252673d8cccd29bc2f1437508d.tar.gz
gentoo-2-35039f9ee8ec87252673d8cccd29bc2f1437508d.tar.bz2
gentoo-2-35039f9ee8ec87252673d8cccd29bc2f1437508d.zip
Revert changes to stable ebuild by monsieurp and put them in a revision bump instead.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/po4a/ChangeLog9
-rw-r--r--app-text/po4a/po4a-0.45-r1.ebuild33
-rw-r--r--app-text/po4a/po4a-0.45-r2.ebuild64
3 files changed, 74 insertions, 32 deletions
diff --git a/app-text/po4a/ChangeLog b/app-text/po4a/ChangeLog
index 6a2bc1ea174f..a4f1b1608078 100644
--- a/app-text/po4a/ChangeLog
+++ b/app-text/po4a/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/po4a
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/po4a/ChangeLog,v 1.85 2014/11/29 18:06:14 monsieurp Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/po4a/ChangeLog,v 1.86 2014/11/29 19:02:05 dilfridge Exp $
+
+*po4a-0.45-r2 (29 Nov 2014)
+
+ 29 Nov 2014; Andreas K. Huettel <dilfridge@gentoo.org> po4a-0.45-r1.ebuild,
+ +po4a-0.45-r2.ebuild:
+ Revert changes to stable ebuild by monsieurp and put them in a revision bump
+ instead.
29 Nov 2014; Patrice Clement <monsieurp@gentoo.org> po4a-0.45-r1.ebuild:
Honour languages set by LINGUAS. Bug #402691.
diff --git a/app-text/po4a/po4a-0.45-r1.ebuild b/app-text/po4a/po4a-0.45-r1.ebuild
index 65ce6f590aed..2764ca51407e 100644
--- a/app-text/po4a/po4a-0.45-r1.ebuild
+++ b/app-text/po4a/po4a-0.45-r1.ebuild
@@ -1,15 +1,12 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/po4a/po4a-0.45-r1.ebuild,v 1.3 2014/11/29 18:06:14 monsieurp Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/po4a/po4a-0.45-r1.ebuild,v 1.4 2014/11/29 19:02:05 dilfridge Exp $
EAPI=5
-PLOCALES="af ca cs da de eo es et eu fr hr id it ja kn ko nb nl pl pt_BR pt ru sl sv uk vi zh_CN zh_HK"
-PLOCALES_BACKUP="en"
-
# Needed because this package also installs to vendor_perl
GENTOO_DEPEND_ON_PERL_SUBSLOT="yes"
-inherit perl-app perl-module l10n
+inherit perl-app
DESCRIPTION="Tools for helping translation of documentation"
HOMEPAGE="http://po4a.alioth.debian.org"
@@ -36,29 +33,3 @@ DEPEND="${RDEPEND}
virtual/tex-base )"
SRC_TEST="do"
-
-src_prepare() {
- # Check against locale files in ${S}/pod/bin for mismatches
- # with languages listed in PLOCALES
- local locales_path="$S/po/bin"
- l10n_find_plocales_changes "$locales_path" "" ".po"
-
- # Array containing locale files to remove
- local locales_to_remove=( )
-
- # Get rid of disabled locales
- my_get_disabled_locales() {
- local locale=$1
- local locale_abs_path="$locales_path/$locale.po"
- locales_to_remove+=$locale_abs_path
- }
-
- l10n_for_each_disabled_locale_do my_get_disabled_locales
-
- einfo "Your LINGUAS lists the following languages: $LINGUAS"
- einfo "Removing locale files not listed in it ..."
-
- # perl_rm_files also updates the Manifest file
- # and therefore silences Perl as to .po files we're about to clean
- perl_rm_files "${locales_to_remove[@]}"
-}
diff --git a/app-text/po4a/po4a-0.45-r2.ebuild b/app-text/po4a/po4a-0.45-r2.ebuild
new file mode 100644
index 000000000000..fb4a1cac615f
--- /dev/null
+++ b/app-text/po4a/po4a-0.45-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/po4a/po4a-0.45-r2.ebuild,v 1.1 2014/11/29 19:02:05 dilfridge Exp $
+
+EAPI=5
+
+PLOCALES="af ca cs da de eo es et eu fr hr id it ja kn ko nb nl pl pt_BR pt ru sl sv uk vi zh_CN zh_HK"
+PLOCALES_BACKUP="en"
+
+# Needed because this package also installs to vendor_perl
+GENTOO_DEPEND_ON_PERL_SUBSLOT="yes"
+inherit perl-app perl-module l10n
+
+DESCRIPTION="Tools for helping translation of documentation"
+HOMEPAGE="http://po4a.alioth.debian.org"
+SRC_URI="mirror://debian/pool/main/p/po4a/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="dev-perl/SGMLSpm
+ >=sys-devel/gettext-0.13
+ app-text/openjade
+ dev-libs/libxslt
+ dev-perl/Locale-gettext
+ dev-perl/TermReadKey
+ dev-perl/Text-WrapI18N"
+DEPEND="${RDEPEND}
+ >=virtual/perl-Module-Build-0.380.0
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.1.2
+ test? ( app-text/docbook-sgml-dtd
+ app-text/docbook-sgml-utils
+ virtual/tex-base )"
+
+SRC_TEST="do"
+
+src_prepare() {
+ # Check against locale files in ${S}/pod/bin for mismatches
+ # with languages listed in PLOCALES
+ local locales_path="$S/po/bin"
+ l10n_find_plocales_changes "$locales_path" "" ".po"
+
+ # Array containing locale files to remove
+ local locales_to_remove=( )
+
+ # Get rid of disabled locales
+ my_get_disabled_locales() {
+ local locale=$1
+ local locale_abs_path="$locales_path/$locale.po"
+ locales_to_remove+=$locale_abs_path
+ }
+
+ l10n_for_each_disabled_locale_do my_get_disabled_locales
+
+ einfo "Your LINGUAS lists the following languages: $LINGUAS"
+ einfo "Removing locale files not listed in it ..."
+
+ # perl_rm_files also updates the Manifest file
+ # and therefore silences Perl as to .po files we're about to clean
+ perl_rm_files "${locales_to_remove[@]}"
+}